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About This Handbook
This handbook is intended to complement the instructor-led presentation of this
course, and serve as a source of reference. It is not suitable for self-study.

Typographic Conventions
American English is the standard used in this handbook. The following
typographic conventions are also used.

Type Style Description

Example text Words or characters that appear on the screen. These
include field names, screen titles, pushbuttons as well
as menu names, paths, and options.

Also used for cross-references to other documentation
both internal and external.

Example text Emphasized words or phrases in body text, titles of
graphics, and tables

EXAMPLE TEXT Names of elements in the system. These include
report names, program names, transaction codes, table
names, and individual key words of a programming
language, when surrounded by body text, for example
SELECT and INCLUDE.

Example text Screen output. This includes file and directory names
and their paths, messages, names of variables and
parameters, and passages of the source text of a
program.

Example text Exact user entry. These are words and characters that
you enter in the system exactly as they appear in the
documentation.

<Example text> Variable user entry. Pointed brackets indicate that you
replace these words and characters with appropriate
entries.
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About This Handbook AC280

Icons in Body Text
The following icons are used in this handbook.

Icon Meaning

For more information, tips, or background

Note or further explanation of previous point

Exception or caution

Procedures

Indicates that the item is displayed in the instructor's
presentation.
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Course Overview
When you are working in the SAP system, you display and evaluate information
that is contained in the database. You export this data from the database and edit
it using reports. In this course you will familiarize yourself with and execute
these reports.

Target Audience
This course is intended for the following audiences:

� Project team
� IT employees who use the evaluation options in FI-GL, FI-AP, and FI-AR
� Consultants

Course Prerequisites
Required Knowledge

� AC010
� AC200
� Knowledge of Financial Accounting

Course Goals
This course will prepare you to:

� Use a number of reporting tools in addition to the standard reports that SAP
provides. In this course, you will not only learn how to run these reports,
you will also use them.

Course Objectives
After completing this course, you will be able to:

� Explain why reports are necessary
� Explain the significance of reporting tools
� Differentiate between:
� Standard reports provided by SAP, and
� Reports that you create yourself
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Unit 1
Standard Reports in General Ledger
Accounting, Accounts Receivable
Accounting, and Accounts Payable

Accounting

Unit Overview
Which standard reports are provided in the SAP system in General Ledger
Accounting (FI-GL), Accounts Receivable Accounting (FI-AR), and Accounts
Payable Accounting (FI-AP)? Where do users find these reports and how do they
start them with their own selection criteria? How do they save these selection
criteria? Users want to be able to display standard lists with minimum effort.

Unit Objectives
After completing this unit, you will be able to:

� Demonstrate where to find the reports required in General Ledger, Accounts
Receivable, and Accounts Payable Accounting

� Explain the importance of information systems
� Execute reports
� Create report variants
� Use report variables

Unit Contents
Lesson: Information Systems .... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2
Lesson: Report Variants and Variables .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .8

Exercise 1: Report Variants and Variables .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
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Lesson: Information Systems

Lesson Overview
In this lesson, you will learn about the different selection criteria available
to search for reports in General Ledger Accounting, Accounts Receivable
Accounting, and Accounts Payable Accounting.

Lesson Objectives
After completing this lesson, you will be able to:

� Demonstrate where to find the reports required in General Ledger, Accounts
Receivable, and Accounts Payable Accounting

� Explain the importance of information systems
� Execute reports

Business Example
Employees in General Ledger Accounting, Accounts Receivable Accounting, and
Accounts Payable Accounting want to use different reports to access their data.

Figure 1: Where Are the Reports?
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You can find the reports you require in various places in the system:

� You can access important reports using the information system for each
area (General Ledger, Accounts Receivable, Accounts Payable) and on
the general report selection screen.

� Reports are also included in role-based user menus.
� Under System, choose System Services→ Reporting. The general ABAP

program execution screen appears and you can enter the report name. If
you do not know the technical name of the report, you can use F4 help and
placeholders (for example, RFD*) to obtain an overview of the reports
contained in General Ledger, Accounts Receivable, and Accounts Payable
Accounting, in addition to the reports in the information system for each area.

Figure 2: Report Names

You can often work out the names of the standard reports from the letters they
contain. For example, the name of the vendor account list is RFKKVZ00, the
name of the customer account list is RFDKVZ00, and the name of the G/L
account list is RFSKVZ00.

The reports that start with RF are differentiated by account type. Reports start
with RFK_____ (for vendors), RFD_____ (for customers), RFS_____ (for G/L
accounts), and RFB_____ (for document reports).

To display program documentation, choose I.
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Figure 3: Accounts Payable Information System: Reports for Accounts
Payable Accounting

The Accounts Payable information system is split into reports for vendor balances,
vendor items, master data, and payment transactions. This information system
contains all the key reports that you need as an accounts payable accountant.

In Dynamic Selections, you have various selection options (for example, industry,
account group, country, city, and so on).

If you use the search help, you will also receive complex selection options that
you can use for different reports.
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Figure 4: Accounts Receivable Information System: Reports for Accounts
Receivable Accounting

When you use the selections and output control, you can restrict the data displayed
in the list. For example, for report RFDUML00, Customer Sales, you can create
a current or historical customer list that is sorted by the customer's sales. To do
this, choose Additional Selections and enter appropriate intervals before you run
the report.

When you enter the sales, you can use single values or ranges by selecting and/or
excluding single values and ranges.

Figure 5: General Ledger Information System: General Ledger Reports
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The G/L account balance list displays the selected totals figures by reporting
period. You can see the carryforward balance at the start of the fiscal year, the total
for the carryforward period, the debit and credit total for the reporting period, and
the debit and credit balances at the end of each reporting period.

At the end of the list, you can see the total for each company code and the final
total for all company codes for each local currency.

You can choose a sorting method that also allows you to summarize data using
summarization levels. For example, you can summarize data by business area or
G/L account.

6 © 2009 SAP AG. All rights reserved. 2009



AC280 Lesson: Information Systems

Lesson Summary

You should now be able to:
� Demonstrate where to find the reports required in General Ledger, Accounts

Receivable, and Accounts Payable Accounting
� Explain the importance of information systems
� Execute reports
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Lesson: Report Variants and Variables

Lesson Overview
In this lesson, you will learn how to create and use report variables.

Lesson Objectives
After completing this lesson, you will be able to:

� Create report variants
� Use report variables

Business Example
Employees in General Ledger Accounting, Accounts Receivable Accounting, and
Accounts Payable Accounting want to use different selection criteria to access their
dataset. Employees need to be able to save these selection criteria (some of which
will not change for a long time) so that they can access the data quickly and easily.

Figure 6: Report Variants: Selection Criteria

You can define multiple report variants for one report. These report variants
contain different selection criteria. A variant is a selection memory for a
specific quantity of saved selection criteria. Instead of entering values for
selection criteria each time you start the report, you enter the values only once
and then save the variant. The next time you execute the report, you can use the
variant. The option of creating variants with your own selection criteria, thereby
reducing time and effort later, is particularly useful for reports that are used
frequently or periodically.
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A report can therefore have different report variants, each of which provides a
specific type of information based on the selection criteria that you define. For
example, for report RFKKVZ00 (Vendor Account List), you can use one variant
for domestic vendors and another for foreign vendors.

First, enter the required selection criteria on the selection screen. The options
available for the selection criteria in the individual reports are explained in the
following figures.

Choose Goto→Variants→ Save as variant.

Figure 7: Report Variants: Attributes

Enter variant attributes for your variant; first a Variant name, and then the
Description.

If you select the Only for background processing field, then the variant is only
permitted for background processing. If you do not select the field, the variant
is permitted for background and online processing.

If you select the Protect variant field, then only you can change the variant.

System variants are only displayed in the catalog and not in F4 Input Help if you
select the relevant indicator.

You can assign certain properties to some fields. For example, you can protect a
field, hide a field, or make a field a required entry field.
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Figure 8: Report Variants: Selection Variables

Instead of entering values for selection criteria each time you start a report, you can
enter the values only once and then save them in a variant. If you call up the report
and use a variant, but still want to display certain values up to the current date (for
example, open items up to a certain key date), you can use selection variables.

If, for example, you want to see all the items up to a specific key date in a report,
you can choose the Selection Variable pushbutton when maintaining attributes
or more specifically when maintaining the selection screen objects and then you
can choose the type of selection variable.

Currently, the following two types of selection variables are supported (but not
for each selection criterion):

� Table variables from TVARV
� Dynamic date calculation
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Figure 9: Table Variables

Table variables from TVARV: You use these variables when you store statistical
information that can be used in different reports. This means that when you save
the attributes for the variant, you can maintain parameters in table TVARV
that contain your selection options, single values, and/or intervals by choosing
Maintain environment→ Selection variables. Once you have maintained these
selection variables in table TVARV, you can use them in any other report variants
and reports.

Figure 10: Dynamic Date Calculation
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Dynamic date calculations:

The prerequisite for using these variables is that the corresponding selection
criterion in the program is type D (date). If you change the selection variable from
type T to type D, the Name of Variables field is no longer ready for input. You
can only set values using input help.
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Exercise 1: Report Variants and Variables

Exercise Objectives
After completing this exercise, you will be able to:
� Create report variants
� Use report variables

Business Example
You want to replicate the same report using the same selection criteria.

Task 1:
Create a variant for report RFBELJ00 (compact document journal).

1. Create a report variant with the name and description AC280-1-## (##
= your group number) for the compact document journal RFBELJ00 such
that only documents 0100000000 to 0199999999 are displayed in company
code 1000 in the current fiscal year.

Execute this report with your report variant.

2. Change your variant with name and description AC280-1-## such that
your variant is protected. The company code must not be changeable.
The fiscal year is a required entry field and the document number ranges
must not contain just documents 0100000000 to 0199999999, but also
documents 1700000000 to 1799999999 and 1800000000 to 1899999999.
For the posting date, choose a dynamic date calculation, with the posting
date from the beginning of the month to today.

Hide all other fields.

Task 2:
To group the many vendors in a meaningful way, the accounts have been split into
account groups. To obtain an overview of the existing vendor master records, you
want a list containing specific vendors.

1. Using report RFKKVZ00, create a report variant AC280-2-## (## = your
group number) with a list of all vendors in account group LIEF that are
located in Berlin.

Only vendors in company codes 1000, 2000, 2200, 3000, 4000, 5000, and
6000 are to be included. Since this company code range is also relevant
to other reports and you do not want to maintain these company codes
individually in each selection variant, use selection variables.

Continued on next page
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Create the selection variable AC280_GR##.

Task 3:
Optional:

1. To be able to perform a targeted advertising campaign, you are asked to
create a list of customers in high tech industries (HITE) and mechanical
engineering (MBAU) with sales between 2,000,000 and 1,000,000
currency units (an entry that you should protect in the variant) in the
periods of the current fiscal year in company codes 1000, 2000, 2200,
3000, 4000, 5000, and 6000.

You want to display the data in currency USD, with exchange rate type M
for translation of exchange rates at the current key date.

Create a variant with name and description AC280-3-## (## = your group
number).

Task 4:

1. Specify the menu path for the report documentation.
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Solution 1: Report Variants and Variables
Task 1:
Create a variant for report RFBELJ00 (compact document journal).

1. Create a report variant with the name and description AC280-1-## (##
= your group number) for the compact document journal RFBELJ00 such
that only documents 0100000000 to 0199999999 are displayed in company
code 1000 in the current fiscal year.

Execute this report with your report variant.

a) Create a report variant:

Menu path: System→ Services→ Reporting

(or in the SAP Easy Access menu:

Accounting → Financial Accounting → General Ledger →
Information System→ General Ledger Reports (New)→ Document
→ General→ Compact Document Journal

Field name or data type Values
Program RFBELJ00

Choose Execute.

Enter your selection criteria:

Field name or data type Values
Company code 1000
Document no. 0100000000 to

0199999999

Fiscal Year Current Year
Ledger 0L

Menu path: Goto→ Variants→ Save as variant...

Field name or data type Values
Variant AC280-1-##

Description AC280-1-##

Choose Save.

Continued on next page
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Execute the report.

Menu path: System→ Services→ Reporting

(or in the SAP Easy Access menu:

Accounting → Financial Accounting → General Ledger →
Information System→ General Ledger Reports (New)→ Document
→ General→ Compact Document Journal

Execute RFBELJ00 with the new variant AC280-1-##.

Program: RFBELJ00

Program→ Execute with variant (or Variant button)

Variant: AC280-1-##

Enter

Execute

2. Change your variant with name and description AC280-1-## such that
your variant is protected. The company code must not be changeable.
The fiscal year is a required entry field and the document number ranges
must not contain just documents 0100000000 to 0199999999, but also
documents 1700000000 to 1799999999 and 1800000000 to 1899999999.
For the posting date, choose a dynamic date calculation, with the posting
date from the beginning of the month to today.

Hide all other fields.

a) Menu path: System→ Services→ Reporting

Field name or data type Values
Program RFBELJ00

Choose Goto→ Variants.

Enter AC280-1-##

Choose Variants→ Change→ Change values.

After the document number, choose theMultiple selection button.

Choose the tab page Ranges

Enter 0100000000 to 0199999999,

1700000000 to 1799999999,

and 1800000000 to 1899999999.

Choose Execute.

Continued on next page
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Choose Variant→ Attribute (or the Variant Attribute button).

Field name or data type Values
Protect variant Select

Company code Protect field
Fiscal year Required entry field

All other fields except Posting Date Choose Hide field

Field name: Posting date

Pushbutton: Selection variable. Selection (matchcode: Select icon)

Type of variable:

Select �D� (for dynamic date calculation).

Choose the Name der Variable pushbutton (entries only possible using
input help)

Double-click �From month end to today�.

Save the variant.

When the system displays the message �Do you want to overwrite
variant AC280-1-##?�, choose Yes.

Execute RFBELJ00 with the changed variant AC280-1-##:

Program: RFBELJ00

Program→ Execute with variant (or Variant button)

Variant: AC280-1-##

Choose Enter. Pay attention to the selection options

Execute

Task 2:
To group the many vendors in a meaningful way, the accounts have been split into
account groups. To obtain an overview of the existing vendor master records, you
want a list containing specific vendors.

1. Using report RFKKVZ00, create a report variant AC280-2-## (## = your
group number) with a list of all vendors in account group LIEF that are
located in Berlin.

Continued on next page
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Only vendors in company codes 1000, 2000, 2200, 3000, 4000, 5000, and
6000 are to be included. Since this company code range is also relevant
to other reports and you do not want to maintain these company codes
individually in each selection variant, use selection variables.

Create the selection variable AC280_GR##.

a) Create a report variant:

Menu path: System→ Services→ Reporting: RFKKVZ00

(or in the SAP Easy Access menu:

Accounting→ Financial Accounting→ Accounts Payable→
Information System→ Reports for Accounts Payable Accounting
→ Master Data→ Vendor List)

Report: RFKKVZ00

Choose Goto→ Variants.

Field name or data type Values
Variant AC280-2-## (## = group

number)

Choose Variant→ Create.

Choose Edit→ Dynamic selections.

Select Account group

Pushbutton: Choose the Copy selected (arrow) button.

Account group: LIEF

When Selection via search help appears, enter:

Search help ID: A (Vendors general)

City: Berlin

Enter

Choose Edit→ Attributes.

Description AC280_2_##

Choose Environment→ Maintain selection variables.

Choose Variables→ Change.

You will receive the message, �The table is cross-client.�

Continued on next page
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Choose Enter.

Choose the Selection options tab page.

Choose Edit→ Create.

Name: AC280_GR## (## = your group number)

Choose the Multiple selection button.

Enter company codes 1000, 2000, 2200, 3000, 4000,
5000, and 6000

Choose Execute.

Choose Save.

Choose Back.

Field Name: Company code

Pushbutton: Selection variables

Type of variable: T: Table variables from TVARV

Pushbutton: Name of variable (entry only possible using input help)

Select AC280_GR## from the list

Save the variant.

Execute RFKKVZ00 with the variant AC280-2-##.

Program: RFKKVZ00

Program→ Execute with variant (or Variant button)

Variant: AC280-2-##

Choose Enter. Pay attention to the selection options.

Choose Execute.

Task 3:
Optional:

1. To be able to perform a targeted advertising campaign, you are asked to
create a list of customers in high tech industries (HITE) and mechanical
engineering (MBAU) with sales between 2,000,000 and 1,000,000
currency units (an entry that you should protect in the variant) in the
periods of the current fiscal year in company codes 1000, 2000, 2200,
3000, 4000, 5000, and 6000.

You want to display the data in currency USD, with exchange rate type M
for translation of exchange rates at the current key date.

Continued on next page
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Create a variant with name and description AC280-3-## (## = your group
number).

a) Report: RFDUML00

Variant with name and description AC280-3-## (## = your group
number)

Create a report variant

Choose

System→ Services→ Reporting: RFDUML00

or, in the SAP Easy Access menu, choose

Accounting→ Financial Accounting→ Accounts Receivable→
Information System→ Reports for Accounts Receivable Accounting→
Customer Balances→ Customer Sales.

Report: RFDUML00

Choose Goto→ Variants→ Save as Variant.

Field name or data type Values
Variant AC280-3-## (## = group

number)

Choose Variant→ Create

Choose Edit→ Dynamic selections.

Industry: HITE (High Tech) and MBAU

Reporting periods: 1 to 16

Sales for account: 100 to 1,000,000 currency units

Fiscal year: Current fiscal year

Translate in output currency: Select

Currency: USD

Exchange rate type: M

Date: Current date

Enter

Choose Edit→ Attributes

Description: AC280-03-##

Field Name: Company code

Continued on next page
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Pushbutton: Selection variables

As the variable type, choose T: Table variables from TVARV

Pushbutton: Name of variable (entry only possible using input help)

Select AC280_GR## from the list

Under Sales for account, choose Protect field.

ER_DATUM (translation date)

Pushbutton: Selection variable. Selection (matchcode: Select icon)

Type of variable: Select �D� (for dynamic date calculation) and then
choose the Name der Variable pushbutton (entries only possible using
input help)

Choose Current Date

Save the variant.

Execute RFDUML00 with the variant AC280-3-##.

Program: RFDUML00

Program→ Execute with variant (or Variant button)

Variant: AC280-3-##

Choose Enter. Pay attention to the selection options.

Execute

Task 4:

1. Specify the menu path for the report documentation.

a) Choose Report documentation.

On the report selection screen, choose Help→ Application help.

Help→ Application help

You have created new variants and worked with:

� Dynamic selections
� Selection variables
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Lesson Summary

You should now be able to:
� Create report variants
� Use report variables

22 © 2009 SAP AG. All rights reserved. 2009



AC280 Unit Summary

Unit Summary
You should now be able to:
� Demonstrate where to find the reports required in General Ledger, Accounts

Receivable, and Accounts Payable Accounting
� Explain the importance of information systems
� Execute reports
� Create report variants
� Use report variables
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Unit 2
List Viewer

Unit Overview
How can users work efficiently with the List Viewer, for example, to display
their open item lists? The SAP variants are useful, but users have their own ideas
about how the list should look.

Unit Objectives
After completing this unit, you will be able to:

� Explain the concept SAP List Viewer
� Use the functions of the SAP List Viewer
� Use selection criteria for accounts in which you want to find line items in

specific company codes
� Choose selection criteria using search help
� Choose line items based on their status and category
� Change standard and user-specific screen layouts

Unit Contents
Lesson: SAP List Viewer Design ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
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Lesson: Changing the Screen Layout. .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

Exercise 3: Changing the Screen Layout .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
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Lesson: SAP List Viewer Design

Lesson Overview
In the SAP List Viewer, you can display different variations of documents and
use different designs.

Lesson Objectives
After completing this lesson, you will be able to:

� Explain the concept SAP List Viewer
� Use the functions of the SAP List Viewer

Business Example
The manager of the accounting department wants to know how to create
standardized lists in the SAP system. He also wants to learn more about the
functions of the SAP List Viewer.

Figure 11: SAP List Viewer: Line Item List

The SAP List Viewer is a generic display tool that creates a standard ergonomic
list from predefined data.

The List Viewer standardizes and simplifies the use of lists in the SAP system by
providing a uniform interface and list preparation function.

You can use the List Viewer to display simple and hierarchical sequential lists.
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The SAP List Viewer contains a number of interactive functions such as sorting,
summation, filters, and so on.

You can change the layout of lists without selecting data first and save the changed
list layout in variants.

Figure 12: SAP List Viewer: Display/Change Documents

The SAP List Viewer provides the following functions for displaying and
changing documents:

Select detail

To get detailed information for an item, you have to select it first. You can
then use the eyeglasses icon (or double-click the item) to display the individual
document. You can also call up the item with the pencil icon if you want to make
changes to the document.

Select items To select an item, select it on the left side of the line item list. To
select multiple items, select a single item, hold Ctrl, and select the other items. To
select all the items, use the appropriate icon.

Once you have selected multiple items, you can carry out a mass change in the
corresponding documents. To see the changes in the line item list, choose Refresh
List. If changes fail, you can see the reasons in the Change errors log using
the corresponding pushbutton.

You can choose whether you want to branch to the document item view or the
document overview of the document display. The accounting editing options
contain a corresponding checkbox.
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Figure 13: SAP List Viewer: Generic Functions

Some of the functions provided by the SAP List Viewer include the following
generic cross-application functions:

Select columns: To select a column, you click the column heading once. To select
multiple columns, select a column, hold Ctrl, and select the required columns.

You can sort the list in ascending or descending order. Sort the list by selecting
the required column and then choosing the corresponding function.

You can set and delete filters the same way.

Summation: You can create totals and subtotals for specific values. Create totals
by selecting the required column and then choosing the appropriate icon.
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Figure 14: List Viewer: Display Variants and Fields

In addition to the display variants provided by SAP, you can also create your own
display variants. This allows you to define your own specific view of a list.

You select fields that you want to see from the fields available in the column set.
You can hide fields that you do not require. You can also sort fields in the column
selection in the order that you require.

You can also add special fields to the column set in addition to the fields that are
already displayed. For more information, refer to SAP Notes 215798 and 420591.

If you require offsetting account information, refer to SAP Note 112312. This is
not a modification of the standard system, but a business transaction event.
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Figure 15: Classic List and Grid Control in the Line Item List

When you display the list, you can choose between the ALV classic list and the
ALV grid control (grid design).

With some lists, you cannot switch between the two layouts; this is a special
feature of the line item list.

The ALV classic list is the list that is displayed when no specific settings have
been made.

The ALV classic list is essentially the print screen and offers a better overview of
the sorted list when the items for multiple accounts are displayed.

The grid control design has proportionate text and is particularly useful when
you display individual accounts online for Internet services offered by SAP
programs.

Since SAP R/3 4.6C, users have been able to select the grid design by choosing
Settings→ Switch List. This list design is entered in the user parameters
(parameter FIT_ALVC) when you switch the list.
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Figure 16: User Parameters for the List

You can display (and change if necessary) the settings using transaction FB00, the
accounting editing options on the Line Items tab page. You can also display and
change parameters using transaction SU3.

Using parameter IDs, you can enter user default values in fields where the value
usually remains constant. If, for example, you switch the list to grid control, the
value will be saved in your user parameters. When you call up the list, this value
appears automatically in the corresponding design. This means that you do not
have to manually switch the list again. The next time you log on to the system,
you do not have to re-select the required layout.
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Lesson Summary

You should now be able to:
� Explain the concept SAP List Viewer
� Use the functions of the SAP List Viewer
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Lesson: Selections

Lesson Overview
Participants can use specific selection criteria to choose line items that they wish
to analyze. These selection criteria are related to:

� The accounts for which you want to see line items; these are created within
specific company codes

� Selection criteria that can be chosen using search help and the selection of
the line items themselves, based on their status and category

Lesson Objectives
After completing this lesson, you will be able to:

� Use selection criteria for accounts in which you want to find line items in
specific company codes

� Choose selection criteria using search help
� Choose line items based on their status and category

Business Example
Employees working in Accounting want to know how to select items in lists in
the SAP system.

It also wants to learn more about the selection criteria that can be used in the
SAP List Viewer.

Figure 17: Line Item List
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You can use specific selection criteria to choose line items that you want to
evaluate.

These selection criteria refer to:

� The accounts in which you want to see line items in specific company codes

� Selection criteria that you can choose using search help

� The selection of line items themselves, based on their status and category

In addition, you can also choose the following for the list output:

� Layout
� Maximum number of items

Figure 18: Selection of G/L Account, Vendor, and Customer

When you make your account selection for G/L accounts, customer accounts, and
vendor accounts, you can use simple and multiple selection to include or exclude
individual accounts and account intervals from the selection.

If you select the Worklists Available field, you can activate and deactivate the
input fields for worklists on the selection screen for each line item list. If the
worklists exist, when you select the Worklist Input Fields Active field when you
call up the selection screen for the line item display, this selection screen is
displayed with input fields for worklists. You can maintain the values for worklists
using transaction OB55.
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Figure 19: Selection using Search Help

If you select items using search help, the system provides input help for the G/L
account line item list:

� G/L account number in chart of accounts (also in combination with the
company code specification)

� G/L account name (G/L account long text) in chart of accounts (also in
combination with the company code specification)

� G/L accounts with deletion and block indicators
� Keywords
� Alternative account numbers

When you select items using search help, the system offers input help for the
vendor line item list:

� General vendor data (search term, postal code, city, name, and number of
vendor)

� Vendor country/company code
� Vendor by personnel number
� Vendor by purchase, material, or plant reference
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When you select items using search help, the system offers input help for the
customer line item list:

� General customer data (search term, postal code, city, name, and number
of customer)

� Customer country/company code/account group
� Customers with rental agreement
� Customers for each sales group or with plant reference
� Head office customers

Figure 20: Item Selection

You can select items for the line item list based on their status and category.

When you select open items, you select items that are or were open at a specific
time. The current date is proposed by default.

If you choose Cleared Items, the system displays items that were cleared by the
clearing date specified and that were still open on the key date. If you do not
specify the clearing date and the key date, the system displays all the cleared items.

If you want to see open and cleared items, choose All Items. You can restrict
this selection using the posting date.
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Figure 21: Head Office/Branch

In some industries, customers submit orders locally -- that is, via the branch -- but
pay invoices centrally through the head office. SAP differentiates between the
flow of goods and the flow of money. In the SAP system, you can set up head
office and branch accounts.

All items posted to a branch account are automatically forwarded to the head
office account.

If you select the Branch/Head Office indicator, a dialog box appears for each
branch account. In the dialog box, you can choose whether the branch can display
items that are managed at the head office.

If you deactivate the dialog box, the setting made in the Items Managed at Head
Office field applies automatically.
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Figure 22: Selection by Net Due Date

When you display the line items, you can make a selection by net due date.

If you select the Selection by Net Due Date field in the editing options of the user
parameters, the system activates the input fields for the selection by net due
date on the Selection screen.

Figure 23: Key for Icons

In the header of the ALV classic list, you can display the key for the icons
for the item status (open, parked, cleared), as well as the icons for the due
date (overdue, due, not due).
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In the editing options for the line items display, you can select whether you want
to see these keys when you call up the list.

Comment: The key date is the determining factor in classifying whether an item is
open or cleared. By backdating an item, you can display the status of the item on a
key date in the past. Items posted after the key date are not displayed.

Figure 24: The Assignment Field as Sort Field

In addition to selecting columns, when you create or change the layout, you can
also define sort criteria for sorting and create subtotals.

The system automatically fills the assignment field for a line item according to the
Sort Field entry in the master record when you post items.

The assignment field can be a combination of up to four fields with a maximum
of 18 characters. For example, to display the document number (10 characters)
and the posting date (six characters), these field names can be included in the
assignment field definition.

If you chose the Purchase Order Number sort key in the customer/vendor master
record, the assignment field for the line item contains the purchase order number
for customers/vendors.

If you selected the sort key for the Cost Center in a general ledger master record,
the assignment field in the corresponding G/L account item for the line item
contains the number of the cost center when you post to this G/L account.
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The line items in the line item display are frequently sorted by the value in the
assignment field. A practical example:

� For example, when an invoice is posted in SD, an accounting document
is created in FI. The accounting document has a document number that
is usually not identical to the number of the invoice in SD. Using the
reference and the assignment, you can find out the SD document on which
the accounting document is based. The reference and the assignment in the
FI invoice are copied from the reference and assignment in the SD billing
document. You can define which numbers (purchase order, sales order,
delivery, billing document) are copied as a reference and which are copied as
an assignment in the SD document and then copied into FI. You can then use
these fields as selection criteria in FI.
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Exercise 2: Selections

Exercise Objectives
After completing this exercise, you will be able to:
� Use the SAP List Viewer, using the line item list as an example
� Find out what selection criteria appear in the selection for the line item list

Business Example
The accounting department wants to know how to select items from lists in the
SAP system, and which selection options are available.

Task:
You have learned about the SAP List Viewer as a tool for preparing standardized
lists, and now you want to investigate the options the tool provides in your work
area. You therefore look at the customer line item list.

Look at the customer line item list for customer 1033 in company code 1000.
Select the open items and choose today's date as the key date.

1. You want to sort the assignment column. What sort options are there? How
do you proceed?

2. In addition, you only want to display documents that contain amounts up
to 40 currency units. How can you do this? How do you display all the
documents again?

3. For customer 1033 you also want to display a totals line for a subtotal
according to the payment date.

4. A colleague informs you that you can also display the list in grid design, in
addition to the ALV classic list design. You now want to use grid design.

5. You want to display the Payment Date and Terms of Payment columns next
to the Open/Cleared/Parked Items icon. How can you move the column
to the required position?

6. You also want to enter the business area account assignment as an
additional field in the list. You want to display the field to the left of the
field for the text.

7. You do not want to have to move the columns or add new columns each
time, and so you want to create a display variant in which the required
fields are in the correct position and in which the business area account
assignment is also shown.

Continued on next page
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Create an appropriate user-specific display variant and save it as
AC280-D-## (##= your group number) without using the default setting.
Display variant AC280-D-## (## = your group number) is called with
business area.
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Solution 2: Selections
Task:
You have learned about the SAP List Viewer as a tool for preparing standardized
lists, and now you want to investigate the options the tool provides in your work
area. You therefore look at the customer line item list.

Look at the customer line item list for customer 1033 in company code 1000.
Select the open items and choose today's date as the key date.

1. You want to sort the assignment column. What sort options are there? How
do you proceed?

a) Choose Accounting→ Financial Accounting→ Accounts Receivable
→ Account→ Display/change line items (Transaction FBL5N).

Customer: 1033
Company code: 1000

Open items

Open at key date: Current date

Program→ Execute

b) You can sort the display in ascending or descending order.

Choose Edit→ Sort in ascending order/Sort in descending order

(Alternatively, place the cursor on the column and use the
appropriate buttons (Sort in ascending order or Sort in descending
order))

Continued on next page
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2. In addition, you only want to display documents that contain amounts up
to 40 currency units. How can you do this? How do you display all the
documents again?

a) Set filter/Delete filter:

Edit→ Set filter

(or, place the cursor on the column and use the Set filter button).

Local currency: EUR
Amounts: To 40

Enter

Then:

Edit→ Delete filter

3. For customer 1033 you also want to display a totals line for a subtotal
according to the payment date.

a) Subtotal for payment date:

First, select another layout:

Settings→ Display variant→ Choose

(or Select layout button)

Choose 1SAP-P

Place the cursor on the Payment Date column.

Edit→ Subtotal

(or, choose Subtotals button)

4. A colleague informs you that you can also display the list in grid design, in
addition to the ALV classic list design. You now want to use grid design.

a) Switch list:

Settings→ Switch list

Continued on next page

44 © 2009 SAP AG. All rights reserved. 2009



AC280 Lesson: Selections

5. You want to display the Payment Date and Terms of Payment columns next
to the Open/Cleared/Parked Items icon. How can you move the column
to the required position?

a) Payment Date and Terms of Payment columns after the
Open/Cleared/Parked Items icon:

Place the cursor on the column and drag the column to the appropriate
position (keep finger on the left mouse button)

(or Settings→ Display variant→ Current:

move the selected lines upwards or downwards using the arrows).

6. You also want to enter the business area account assignment as an
additional field in the list. You want to display the field to the left of the
field for the text.

a) Additional field (Business area):

Settings→ Display variant→ Current:

In the column set (right): Select Business area

Move it to the column selection (left) using the arrow Add selected
fields.

Move the selected lines upwards or downwards to the required place
using the arrows.

7. You do not want to have to move the columns or add new columns each
time, and so you want to create a display variant in which the required
fields are in the correct position and in which the business area account
assignment is also shown.

Create an appropriate user-specific display variant and save it as
AC280-D-## (##= your group number) without using the default setting.
Display variant AC280-D-## (## = your group number) is called with
business area.

a) Choose Settings→ Save display variant.

You can save the variant under your own name (AC280-D-##).

Save layout: AC280-D-##

Name: With business area

Select User-specific.

Choose Continue.

The system issues the following message: �Layout was saved.�.
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Lesson Summary

You should now be able to:
� Use selection criteria for accounts in which you want to find line items in

specific company codes
� Choose selection criteria using search help
� Choose line items based on their status and category
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Lesson: Changing the Screen Layout

Lesson Overview
There are various standard layouts that you can supplement. In this lesson, you
will learn about standard layouts and user-specific layouts.

Lesson Objectives
After completing this lesson, you will be able to:

� Change standard and user-specific screen layouts

Business Example
When displaying a list, accountants want to choose between different (standard
and user-specific) layouts.

Figure 25: Layout

When you display a list, you can choose between different layouts.

SAP provides various standard layouts that you can supplement with other
(standard) layouts. Standard layouts start with a slash (/). You can choose a
standard layout as your default layout. If the indicator for a display variant is set
as the initial variant, this variant is always used for the list output unless you
explicitly specify an alternative display variant.

You can also choose a user-specific layout, provided that you can save
user-specific display variants.

2009 © 2009 SAP AG. All rights reserved. 47



Unit 2: List Viewer AC280

Enter the ALV initial layout in the accounting editing options.

Figure 26: Standard Layout: Default and Initial Layout

The standard layout is the layout that applies for all users.

You can select a layout for the list output for your line item display. If you so
require, this layout is displayed again the next time you call up transaction FBL*N
(* = 1 for vendors, = 3 for G/L accounts, and = 5 for customers). In the accounting
editing options in your user parameters, you can save the last layout used as a
default. If you select the Last layout entered for default field, every time you
execute the line item display, the layout on the selection screen is saved as the
default in the user specifications. Tip: If you want to prevent the default being
accidentally overwritten by the selection of another layout, leave the field blank.

If you have not selected a layout, the list layout from the default selection screen
is selected from your user parameters. You can default the input field for each
account type.

If you do not make an entry, and no default setting is made for the selection
screen in the user parameters, the system uses the ALV initial layout. You cannot
define the ALV initial layout in the accounting editing options; you can only
do this in the line item list itself. You default the ALV initial layout in display
variant management.

If you do not make a default setting in display variant management, the system
chooses the 1SAP layout.
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Figure 27: User-Specific Layout

You can create a user-specific layout, which only you can use.

If you only want to work with your user-specific layout, call up the relevant line
item list with your new, user-specific layout. In the editing options of the user
parameters, the default selection screen is updated with your new, user-specific
layout. If you also want to be able to call up the line item list using another layout
in your selection as well as your user-specific layout, deselect the Save last layout
for default field.

The following order applies: User-specific initial screen (set as default) has
priority over general initial variant (set as default).
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Exercise 3: Changing the Screen Layout

Exercise Objectives
After completing this exercise, you will be able to:
� Change and save a screen layout
� Choose a layout

Business Example
When choosing a list, accountants can choose between different (standard and
user-specific) layouts. They want to add to their own layouts.

Task 1:
Carry out the following task:

1. Call up the open items list for customer 1033 in company code 1000 again.
Find display variant AC280-D-##. Select Default setting for your display
variant and save it again. Which display variant does the system propose
when you call up the open items list again?

2. In the item texts for the open items, you want to be able to see how the sales
revenue was achieved. Change all the items using themass change function
so that the text Flat screens appears in the item text.

Task 2:
G/L account line item list

1. You are asked to look at all the items in the account sales revenue for
domestic products (800000). How many items are displayed?

2. To find the posting date, you have to first switch from the document item to
the document header. However, you would prefer to find the information
immediately when you branch to the document. What options do you have?

3. You have also been asked to create a list that shows only totals for the profit
centers posted to and that displays the amount in local currency. When
you analyze the subtotals for the line items, you want to see the document
date and document number. You want all users to be able to use the display
variant AC280-PC-## (## = your group number), with the description Profit
center ##. Can you do this?

4. A user wants to see the line items for profit center 1600.

5. In addition to the G/L account with number, name, and the company code,
in the header item of the list you also want to see the account group to
which the account belongs.
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Solution 3: Changing the Screen Layout
Task 1:
Carry out the following task:

1. Call up the open items list for customer 1033 in company code 1000 again.
Find display variant AC280-D-##. Select Default setting for your display
variant and save it again. Which display variant does the system propose
when you call up the open items list again?

a) By choosing Settings→Choose display variant

Layout configuration→ User-specific

you can find your variant AC280-D-##.

By choosing Settings→ Save Layout

you can save your variant AC280-D-##.

The variant must remain user-specific. Select the default setting.

Choose Continue.

The system issues the following message: �This layout already exists.
Do you want to overwrite the existing layout?�

Choose Yes to confirm.

The system issues the following message: �Layout was saved.�

Call up the open item list again: Variant AC280-D-## is displayed.

2. In the item texts for the open items, you want to be able to see how the sales
revenue was achieved. Change all the items using themass change function
so that the text Flat screens appears in the item text.

a) Mass change:

Call up the open items list and choose Edit→ Select all..

Edit→ Select all

Environment→ Mass change→ New values (or choose Mass change).

Choose Enter.

List→ Refresh.

Continued on next page
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Task 2:
G/L account line item list

1. You are asked to look at all the items in the account sales revenue for
domestic products (800000). How many items are displayed?

a) Accounting→ Financial Accounting→ General Ledger→ Account→
Display/Change Line Items (New)

G/L account: 800000

Company code:1000

Item Selection: All Items

Type: Ledger 0L

Program→ Execute

2. To find the posting date, you have to first switch from the document item to
the document header. However, you would prefer to find the information
immediately when you branch to the document. What options do you have?

a) Accounting → Financial Accounting → General Ledger →
Environment→ User Parameters→ Editing Options

Tab page Line Items

Item selection: Go to .... Document Overview

3. You have also been asked to create a list that shows only totals for the profit
centers posted to and that displays the amount in local currency. When
you analyze the subtotals for the line items, you want to see the document
date and document number. You want all users to be able to use the display
variant AC280-PC-## (## = your group number), with the description Profit
center ##. Can you do this?

a) Call up the line item list again.

Settings→ Layout→ Current (or choose Select Layout)

In the column set: Select all (Ctrl button + click)

Arrow pointing right (hide selected fields)

In the column set:

� Profit center
� Amount in local currency
� Document date
� Document no.

Continued on next page
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Arrow pointing left (add selected fields) to add the fields to the column
selection

Arrange them in this order (see above)

Sort order tab page

In the column set: Select all (Ctrl key + click)

Arrow pointing right (hide selected fields)

In the column set:

� Profit center

Arrow pointing left (add selected fields) to add the fields to the column
selection

Choose Sort ascending

Choose Subtotals

Choose Enter

Settings→ Summation Levels→ Define Breakdown

Select level 1 (Profit center) (or * ...)

Settings→ Layout→ Save

Layout: /AC280-PC-##

Name: Profit Center

(* ... If you have not defined the breakdown by choosing Settings→
Summation levels→ Define breakdown, on the tab page, choose �Save
with�:

Select the sort order and subtotals

Breakdown to summation level: 1 *Profit Center)

4. A user wants to see the line items for profit center 1600.

a) Choose the icon for the subtotal. Select the * in the output to open up
the line items for the selected profit center.

Continued on next page
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5. In addition to the G/L account with number, name, and the company code,
in the header item of the list you also want to see the account group to
which the account belongs.

a) List header:

Settings→ Layout→ Current Heading

Insert→ Characteristics (or choose Characteristics)

Variable category: Character-Related Text Variable

Characteristic: Account Group

Text type: Name

Value type: Single Value

Format: Select Intense, width 25

Insert→ Characteristics (or choose Characteristics)

Variable category: Character-Related Text Variable

Characteristic: Account Group

Text type: Value

Value type: Single Value

Format: Width 4

Save
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Lesson Summary

You should now be able to:
� Change standard and user-specific screen layouts
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Unit Summary
You should now be able to:
� Explain the concept SAP List Viewer
� Use the functions of the SAP List Viewer
� Use selection criteria for accounts in which you want to find line items in

specific company codes
� Choose selection criteria using search help
� Choose line items based on their status and category
� Change standard and user-specific screen layouts
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Unit 3
AR/AP Information System

Unit Overview
Employees in Accounts Receivable Accounting want to be able to evaluate
selected data records for customers and vendors without having to execute reports
online.

Unit Objectives
After completing this unit, you will be able to:

� Explain how the accounts receivable/accounts payable information system
works

� Name the various options for customizing the accounts receivable/accounts
payable information system and explain the effect of these options on
evaluations

� Create evaluations in the information system
� Use various options to display evaluations and navigate within the tree

structure of the accounts receivable/accounts payable information system

Unit Contents
Lesson: The AR/AP Information System ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Exercise 4: The AR/AP Information System ... . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Lesson: Customizing the AR/AP Information System.... . . . . . . . . . . . . . . . . . . . 67

Exercise 5: Customizing the AR/AP Information System .... . . . . . . . . . . 73
Lesson: Creating and Displaying Evaluations .. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Exercise 6: Customer/Vendor Information System ... . . . . . . . . . . . . . . . . . . 97
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Lesson: The AR/AP Information System

Lesson Overview
The accounts receivable (AR)/accounts payable (AP) information system is an
information system for analyzing important customer and vendor business data.
Accounting is the primary data basis for this information system.

Lesson Objectives
After completing this lesson, you will be able to:

� Explain how the accounts receivable/accounts payable information system
works

Business Example
The accounts receivable and accounts payable departments have requested
additional reports for their area. In particular, they want to be able to analyze
combinations of variables, such as company, business area, credit control area,
and so on.

Figure 28: The A/R Information System

The accounts receivable (AR)/accounts payable (AP) information system is an
information system for analyzing important customer and vendor business data.
Accounting is the primary data basis for this information system. The aim of the
AP/AR information system is to enable you to analyze an extensive database
online, and to display the information in an overview tree structure on the screen.
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You can access the analyses using the AR and AP reporting trees. The AP/AR
information system provides special types of analyses, including: These include
analyses of:

� Due date structure

� Payment history

� Currency risk

� Overdue items

� DSO analysis (how many days' sales the customer owes my company)

� The customer's cash discount history (days agreed/actual days)

The above-mentioned analyses are based on preselected datasets (evaluation
views, represented in figure 33 by the two cubes: Customers: Audit evaluations
and Customers: Standard evaluations) that are regularly created or updated by
jobs from the SAP database. Using the AP/AR information system, you can
execute analyses for specific business areas as often as you wish. If you need
current data every morning, you can schedule jobs to run during the night.

The AP/AR information system provides an extensive combination of variables
and a classification of reports by document.

Figure 29: Evaluations - Multilevel Process: Selection
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Firstly, the data retrieval report (RFDRRSEL or RFKRRSEL) collects selected
data from the SAP database using a selection variant (data retrieval variant). For
example, it collects from a specific area data for customers/vendors in specific
company codes. The data is passed on to all of the evaluations defined that belong
to the evaluation view and that are defined for regeneration.

Additional reports (RFDDRRE01, RFDRRE02 or RFKRRE01, RFKKRE02)
create the evaluations. For example, RFDRRE01 creates the due date structure
of the open customer items. You cannot start these reports online or in a batch
session, since the required data records are supplied by the data retrieval report
(RFDRRSEL, RFKRRSEL).

Figure 30: Evaluations - Multilevel Process: Display

The system does not display the results of the reports (RFDRRE01, RFDRRE02,
or RFKRRE01, RFKKRE02,) in a list, but saves them in table RFRR to be
displayed later. The data retrieval report (RFDRRSEL or RFKRRSEL)
provides the data records required to do this.

The system continues to process this data, and the display reports send the results
to the screen.

RFDRRANZ and RFKRRANZ create the report trees that are used to display
the evaluations in the accounts receivable/accounts payable information system.
Since you do not make selections yourself, these reports do not have any selection
fields or selection variants.
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Exercise 4: The AR/AP Information System

Exercise Objectives
After completing this exercise, you will be able to:
� Create evaluations in the information system
� Describe various display options for evaluations
� Navigate in the tree structure of the AR/AP information system and adjust

this to your needs

Business Example
Managers in accounts receivable want better reporting functions. In particular,
they want to be able to analyze combinations of different variables (for example,
company code, business area, and credit control area). In addition, they want to be
able to drill down from the totals levels to the detail levels of individual documents.

You need to demonstrate that these reporting functions are provided by the
accounts receivable information system, which accesses predefined datasets.

Task:
Due date analysis with the Accounts Receivable Information System

Using the accounts receivable information system, display a due date analysis
by business area for company code 1000. Use the evaluation view Standard
Customer Evaluations. When you display the evaluation, switch on the Day/Time.

1. What is the total for all the due items in your business area, BA## (## =
your group number)?

__________________________________________________________________

2. What is the total for all the open items in your business area BA##? (If you
want to see the key instead of the name, you can change the characteristic
display with the settings).

__________________________________________________________________

3. In what time interval are the items that are not yet due?

__________________________________________________________________

4. Which customers in your business area BA## (## = your group number)
still have liabilities?

__________________________________________________________________

5. Which of the customers is a foreign customer and how many days ago were
this customer's items due?

__________________________________________________________________
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Solution 4: The AR/AP Information System
Task:
Due date analysis with the Accounts Receivable Information System

Using the accounts receivable information system, display a due date analysis
by business area for company code 1000. Use the evaluation view Standard
Customer Evaluations. When you display the evaluation, switch on the Day/Time.

1. What is the total for all the due items in your business area, BA## (## =
your group number)?

__________________________________________________________________

a) Due date analysis using the Accounts Receivable Information
System SAP menu:

Accounting→ Financial Accounting→ Accounts Receivable→
Information System→ Tools→ Display Evaluations

Choose Customer standard evaluations→ Due date analysis→
Evaluation by business area→ For company code: 1000 IDES AG

or Choose the Switch path pushbutton, and then choose Customer
standard evaluations→ For business area→ BA## (## = your group
number)→ Due date analysis→ By company code (click) search
for 1000 IDES AG.

Choose Extras→ Day/Time on/off.

b) Place the cursor on the Business area column.

Choose Setting→ Change. Then choose characteristic display key.
Now you can see BA## (## = your group number), second column:
Due items

2. What is the total for all the open items in your business area BA##? (If you
want to see the key instead of the name, you can change the characteristic
display with the settings).

__________________________________________________________________

a) Last column: Total OIs

3. In what time interval are the items that are not yet due?

__________________________________________________________________

a) Choose View→ Open items not due (or choose the Open items not
due button).

Continued on next page
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4. Which customers in your business area BA## (## = your group number)
still have liabilities?

__________________________________________________________________

a) Place the cursor on your business area BA## (## = your group
number).

Choose View→ Top N customers by→ Total OIs (or double-click
your business area, BA##)

5. Which of the customers is a foreign customer and how many days ago were
this customer's items due?

__________________________________________________________________

a) Place the cursor on the foreign customer.

Choose View→ OI due.

Choose View→ Line item analysis.
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Lesson Summary

You should now be able to:
� Explain how the accounts receivable/accounts payable information system

works
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Lesson: Customizing the AR/AP Information System

Lesson Overview
In this lesson, we will discuss evaluation views, evaluation types, and evaluation
versions.

Lesson Objectives
After completing this lesson, you will be able to:

� Name the various options for customizing the accounts receivable/accounts
payable information system and explain the effect of these options on
evaluations

Business Example
The accounts receivable and accounts payable departments have requested
additional reports for their area. In particular, they want to be able to analyze
combinations of variables, such as company, business area, credit control area, and
so on. You now have the task of fulfilling these requirements in Customizing for
the accounts receivable/accounts payable information system.

Figure 31: Evaluation Views

Each table entry at the highest level of the evaluation view automatically creates a
separate node in the standard report tree. You use the evaluation views to create
evaluations from different perspectives and to organize them according to your
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needs. If your company has multiple company codes, business areas, credit
control areas, and so on, you can use the corresponding number of evaluation
views to create separate evaluations for these.

Using the selection variants for the data retrieval program (RFDRRSEL or
RFKRRSEL) that you maintain here, you define for each evaluation view the
(maximum) data volume that is available to the display programs.

Example for a customer evaluation:

You make three entries: one for company code Europe, one for company code
USA, and a third for both company codes. When you make these settings, the
system automatically creates three nodes in the accounts receivable information
system. You then set up the variants for the data retrieval program (in our example,
RFDRRSEL) such that the corresponding company codes are included in the three
different variants of the data retrieval program.

Hint: It is easier to make the settings by copying existing entries than to
create new entries. When you copy existing entries, the system copies the
complete table hierarchy of the source entry to the target entry.

Figure 32: Evaluation Types

Depending on the account type you select, you can choose from various
predefined evaluation types in the system.

The evaluation type specifies the type of evaluation (due date analysis, payment
history, and so on) within an evaluation view. You can also define your own
reports for creating and displaying the evaluations for the evaluation type.
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If you have copied an entry on the previous level (in the evaluation view), on this
level you will see all the evaluation types that belong to the source entry. Delete
the entries that you do not need.

Figure 33: Evaluation Versions

At the lowest level of the table entries, you can also create your own evaluation
versions in addition to the evaluation versions delivered. Each entry uses a
different variant of the creation report, which is part of the data retrieval.

To view a definition of the selection report variant (RFDRRE01,02,03,04,05),
double-click a standard entry.

The evaluation versions within an evaluation type differentiate between the
evaluations according to a grouping criterion that you select. For example,
evaluations for the due date analysis could be grouped in version A according to
company code, and in version B according to business area.
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Figure 34: Evaluations

If you activate the Create evaluation checkbox, the system creates the data during
the next generation run. You can make this specification in Customizing or
in the application.

You have to activate the checkboxes in the Evaluations required area if you want to
define one of these database fields as a grouping criterion (variant configuration).

You have to do this because the program does not read the values from the
following database fields unless prompted to do so:

KNA1-KNAS (VAT registration number, tax data)

KNA1-KNKA and KNA1-KNKK (credit control data, credit control area data)

KNA1-KNBK (bank data)

KNB1-KNB5 (customer's dunning master data)
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Figure 35: Variant Maintenance for Selection Report

You enter the database field to be used to group the evaluation on this screen. For
the evaluation Due date structure by company code, you have to enter the database
field KNB1-BUKRS (see example on figure 40).

In the Number of Top Customers field, specify how many accounts or documents
are to be included in the ranked list for this evaluation.

Using the parameters for sorting by number of days, you can enter day intervals
for sorting the selected items (for example, for the due/not due items). The system
would generate a sorted list using entries 15, 30, and 45:

� 0 � 15

� 16 - 30

� 31 � 45

� > 45
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Figure 36: Additional Variant Attributes

When you activate the parameters, the system creates evaluations on various
levels:

� Client

� Credit control area

� Company code

� Business area
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Exercise 5: Customizing the AR/AP
Information System

Exercise Objectives
After completing this exercise, you will be able to:
� Customize the accounts receivable/accounts payable information system

Business Example
Managers in accounts receivable want better reporting functions. In particular,
they want to be able to analyze combinations of different variables (for example,
company code, business area, and credit control area). In addition, they want to be
able to drill down from the totals levels to the detail levels of individual documents.

You have to show that these reporting functions are provided in Customizing for
the accounts receivable information system, which accesses predefined datasets.

Task 1:
Analysis of overdue items with the accounts receivable information system

1. In Customizing, create your own evaluation view, GR##, and your own
selection variant, GR##VARI, so that you can subsequently produce and
execute your own evaluation view.

2. Create the new evaluation view.

Enter the name GR## (## = your group number) for your evaluation view,
and

enter Customer evaluations GR## (## = your group number) as the
description.

Copy the existing entry SAP evaluation view for account type D, standard
customer evaluations from the table with the evaluation views.

Hint: It is easier to copy an entry than to create a new entry and
maintain it individually. Therefore, use the entry SAP, D, Standard
customer evaluation as a reference.

3. Create the data retrieval selection variant.

For the data retrieval report RFDRRSEL, create your own data retrieval
selection variant, GR##VARI (## = your group number) for your
evaluation view GR## (## = your group number).

Continued on next page

2009 © 2009 SAP AG. All rights reserved. 73



Unit 3: AR/AP Information System AC280

In this variant, choose the customers Customer01 to Customer20 and
Foreign01 to Foreign20 in company code 1000.

Name your variant Group ## variant (## = your group number).

For the open item selection, choose a selection variable that ensures that
the system performs a dynamic date calculation with the current date.

Task 2:
Your company is currently investigating in which cities late payers are located so
that it can use a collection agency to collect the receivables.

1. Use the Customer evaluations GR## evaluation view (## = your group
number), which you created in the previous step. In evaluation view GR##
(## = your group number), create an evaluation version for the evaluation
type Overdue Items. In the evaluation version, you must be able to find the
items due by the cities in which the late payers are located. This evaluation
version is called version g and has the description Overdue items by city.
In the evaluation version's selection variant Cityvari## (## = your group
number) (description: city variant) for the selection report RFDRRE04, the
city is the field used to group items (field KNA1-ORT01).
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Solution 5: Customizing the AR/AP
Information System
Task 1:
Analysis of overdue items with the accounts receivable information system

1. In Customizing, create your own evaluation view, GR##, and your own
selection variant, GR##VARI, so that you can subsequently produce and
execute your own evaluation view.

a) From the SAP Reference IMG, choose Financial Accounting (New)
→ Accounts Receivable and Accounts Payable→ Information
System→ Accounts Receivable→ Standard Evaluations→ Select
Standard Evaluations.

b) Create a new evaluation view GR## (## = your group number) and
a selection variant GR##VARI (## = your group number) for the
data retrieval report RFDRRSEL.

2. Create the new evaluation view.

Enter the name GR## (## = your group number) for your evaluation view,
and

enter Customer evaluations GR## (## = your group number) as the
description.

Continued on next page
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Copy the existing entry SAP evaluation view for account type D, standard
customer evaluations from the table with the evaluation views.

Hint: It is easier to copy an entry than to create a new entry and
maintain it individually. Therefore, use the entry SAP, D, Standard
customer evaluation as a reference.

a) Evaluation view: GR## (## = your group number)

Select the entry:

Evaluation view: SAP (Customer standard evaluations)

Account type: D

Data retrieval report: RFDRRSEL

Data retrieval variant: SAP_VARI

Edit→ Copy as (or Copy as pushbutton)

Evaluation view: GR## (## = your group number)

Account type: D

Name of evaluation view: Customer evaluation GR##

Enter

Dialog box Specify objects to be copied: Select Copy all

Confirm the information about the Number of copied entries: 45 by
choosing Enter

Save

3. Create the data retrieval selection variant.

For the data retrieval report RFDRRSEL, create your own data retrieval
selection variant, GR##VARI (## = your group number) for your
evaluation view GR## (## = your group number).

In this variant, choose the customers Customer01 to Customer20 and
Foreign01 to Foreign20 in company code 1000.

Name your variant Group ## variant (## = your group number).

For the open item selection, choose a selection variable that ensures that
the system performs a dynamic date calculation with the current date.

a) Data retrieval selection variant GR##VARI (## = your group number)
for your evaluation view GR## (## = your group number)

Select

Continued on next page
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Evaluation view: GR## (## = your group number)

Account type: D

Name of evaluation view: Customer evaluation GR##

→ Environment→ Maintain variant (or Maintain variant pushbutton)

Variant: GR##VARI (## = your group number)

Variants→ Create (or choose the Create pushbutton)

For customer account: Multiple selection button (right):

Choose the Ranges tab page

In the first range: Customer00 to Customer20

In the second range: Foreign00 to Foreign20

Copy

Enter

Execute

Company code: 1000

Edit→ Attribute (or choose the Attributes button)

Description: Variant group ## (## = your group number)

Choose the Selection Variable pushbutton for the object of the selection
screen �Open Items at Key Date� and choose Type of Variable:

Choose the Name der Variable pushbutton (entries only possible using
input help)

Choose Current Date

Save (to save the variant GR##VARI)

Go back twice (green arrow).

Enter the following:

Evaluation view: GR## (## = your group number)

Account type: D

Name of evaluation view: Customer evaluation GR##

Your variant: GR##VARI (## = your group number)

Save

Continued on next page
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Task 2:
Your company is currently investigating in which cities late payers are located so
that it can use a collection agency to collect the receivables.

1. Use the Customer evaluations GR## evaluation view (## = your group
number), which you created in the previous step. In evaluation view GR##
(## = your group number), create an evaluation version for the evaluation
type Overdue Items. In the evaluation version, you must be able to find the
items due by the cities in which the late payers are located. This evaluation
version is called version g and has the description Overdue items by city.
In the evaluation version's selection variant Cityvari## (## = your group
number) (description: city variant) for the selection report RFDRRE04, the
city is the field used to group items (field KNA1-ORT01).

a) New evaluation by city for the Overdue items evaluation type:

Select the evaluation view that you previously created

Evaluation view: GR## (## = your group number)

Account type: D

Name of evaluation view: Customer evaluation GR##

DB: Variant GR##VARI (## = your group number)

Double click Evaluation Types (in dialog structure)

Select the evaluation type: 04; name: �Overdue items�

Double click Evaluations (in dialog structure)

Select the evaluation Overdue items by company code

Edit→ Copy as (or Copy button)

Evaluation view: GR## (## = your group number)

Account type: D

Evaluation type: 04 (Overdue items)

Evaluation version: G

Evaluation name: Overdue items by city

Create evaluation: Select

For selection:

Selection variant: Cityvari## (## = your group number)

ENTER

The following message appears:

Continued on next page
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Variant RFDRRE04 CITYVARI## does not exist. Please create.

Button: Maintain variant

Program: RFDRRE04

Variant: Cityvari##

Variant→ Create

Field for grouping: KNA1-ORT01

Edit→ Attributes

Description: City variant

Save and choose the green arrow to go back to the previous screen.

Do not forget to SAVE the new evaluation.
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Lesson Summary

You should now be able to:
� Name the various options for customizing the accounts receivable/accounts

payable information system and explain the effect of these options on
evaluations
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Lesson: Creating and Displaying Evaluations

Lesson Overview
Evaluations are performed and displayed. In this lesson, you will learn to create
evaluations in the information system, and navigate within reports using the
appropriate list functions.

Lesson Objectives
After completing this lesson, you will be able to:

� Create evaluations in the information system
� Use various options to display evaluations and navigate within the tree

structure of the accounts receivable/accounts payable information system

Business Example
The accounts receivable and accounts payable departments have requested
additional reports for their area. In particular, they want to be able to analyze
combinations of variables, such as company, business area, credit control area,
and so on.

You need to demonstrate that these functions can be performed by creating
and navigating within a dataset in the accounts receivable/accounts payable
information system.

Figure 37: Report Tree
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Figure 38: Creating Evaluations

To create an evaluation, the system analyzes the master data and the line items of
the customer and vendor accounts. This process can be very time-consuming for
large volumes of data. You therefore perform evaluations as a background job.
You can use the Job Wizard to do this.

You can run background processing at specific times. For example, you can
perform a specific evaluation run daily, weekly, or monthly.

Note that evaluations can only be as up to date as the last data retrieval. If you
have carried out activities since the last data retrieval, then the current customer or
vendor information may not correspond with the evaluation.

You can change the data volume using the relevant report variants.

Figure 39: Displaying Evaluation Results
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Access the accounts receivable (or accounts payable) information system through
the central accounts receivable (or accounts payable) tree.

If you have not done so already, define the data volume for your accounts
receivable/accounts payable information system.

Then select which evaluations you want to have created.

In the next step, you define a job with which the system will create your
evaluation.

You can then display the evaluation. Navigate through the tree structure of the
AP/AR information system until you find the required evaluations.

Figure 40: Standard Evaluations

Standard evaluations are delivered with the accounts receivable/accounts
payable information system. You can copy them into a client system in the IMG.

The evaluations provided are combinations of:

� Evaluation views (for example, standard evaluations for customers)
� Evaluation types (for example, due date analysis)
� Evaluation versions (an evaluation by criterion; for example, by company

code)
� Creation parameters (a create evaluation for criterion; for example, for

a business area)

An evaluation reflects an evaluation type for a representative of the for criterion,
whereby the data is further classified with regard to the by criterion.
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Figure 41: Due Date Analysis

The due date analysis evaluation type is available for customers and vendors.

The open items at a key date are taken into account in the due date analysis. The
item amounts are summarized according to the due and not due criteria. For these
values, you can display a sorted list according to the due since and due in criteria.

The following applies to all evaluations: If you break down the data by line item
(call up the line item list), you are accessing current database information that may
be different from the total shown in the previous run of the data retrieval program.

Figure 42: Payment History

This evaluation is only available for customers.
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When considering the payment history, the system takes into account the short-
and medium-term payment history and the current situation based on the open
items due. For each of these periods, the system calculates the number of days in
arrears, the amounts, and the interest calculation numerators.

Figure 43: Payment History: Days in Arrears by Country

This is based on the updated payment history. This includes the clearing volume
and the average number of days in arrears, split by payments with and without
cash discount.

To determine the medium-term days in arrears, the program uses the values of
the last three posting periods (for the short-term days in arrears, the values of
the last posting period) in which payment transactions took place.

Calculation is based on the total interest calculation numerators and the total
payment amount. The advantage of this is that when you summarize the
average days in arrears, the system also includes information about the payment
volumes concerned.
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Figure 44: A Customer's Payment History

To determine the medium-term interest amount, the program uses the values of the
last three posting periods (for the short-term interest amount, the values of the last
posting period) in which payment transactions took place. The interest calculation
numerators are firstly determined for each period. The average value is displayed.

The interest calculation numerator is a quantity in which two items of
information are put together: the duration of the arrears and the amount
concerned. The days in arrears are weighted with the relevant payment
volumes (or vice versa). The interest calculation numerator provides better
information about the extent of payment arrears than the amount or the
duration of arrears by themselves.
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Figure 45: Currency Analysis

The currency analysis evaluation is available for customers and vendors.

Figure 46: Currency Analysis by Business Area
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The currency analysis by business area shows:

� The total number of documents posted in foreign currency at the historical
exchange rate, that is, the exchange rate saved in the document. It contains
the items open at the key date displayed. The display is in the currency
shown in the header item.

� The total foreign currency at the current exchange rate; total for the
documents posted in foreign currency at the current exchange rate (that is,
the exchange rate valid on the key date.)

� The exchange rate difference: the difference between the historic and
current totals.

Figure 47: Overdue Items

The overdue items evaluation is available for customers and vendors.

Figure 48: DSO Analysis
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The DSO (Days Sales Outstanding) evaluation is only available for customers.

Figure 49: DSO Analysis: Balance

The Use Periods parameter in the variant maintenance function for report
RFDRRE05 determines how many periods are used to calculate the DSO. If you
enter 3, this means that the last three closed periods are used.

You can define the calculation type in the selection variant of this report:

� Calculation type 1 for DSO days: The balance displayed is the average
period closing balance of the last n closed periods. The last n closed periods
refer to the key date displayed in the header item (see example in figure 54).

� Calculation type 2 for DSO days: If the key date is within a period that has
not been closed, the balance displayed is the current balance. However, if
the key date is within a closed period, the balance displayed is the closing
balance of this period.

2009 © 2009 SAP AG. All rights reserved. 89



Unit 3: AR/AP Information System AC280

Figure 50: DSO Analysis: Sales

Figure 51: DSO Analysis: Days

The key figure DSO shows a customer's balance in relation to his or her sales. It
specifies how many days' sales a customer owes a company.

There are two procedures for calculating the DSO days. On the selection screen,
you can define the procedure required using the DSO calculation type parameter.

Examples for both calculation types:

n = 3 Balance Sales
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Key date 02/15/2002 18,000 8,000

Period 01/2002 10,000 8,000

Period 12/2001 5,000 2,000

Period 11/2001 5,000 2,000

Calculation type 1:

-------------------------

Average balance = (10,000 + 5,000 + 3,000) / 3 = 6,000

Average sales = (8,000 + 5,000 +2,000) / 3 = 5,000

6.000

DSO = ---------- * 30 = 36

5.000

Result: The customer owes the equivalent of 36 days' sales

Calculation type 2:

-------------------------

Current balance = 18,000

Average sales = (8,000 + 5,000 +2,000) / 3 = 5,000

18.000

DSO = ----------- * 30 = 108

5.000

Result: The customer owes the equivalent of 108 days' sales
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Figure 52: Terms Agreed/Terms Taken

In the terms agreed/terms taken evaluation, the difference between the terms taken
and the terms agreed with the customer is calculated.

This evaluation is only available for customers.

Figure 53: Days Agreed

To determine the agreed terms of payment (in days), the invoices issued in the
key date - n days period are used. You can define the number of days and the key
date when you create the evaluation.
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Calculation is based on the total interest calculation numerators and the total
invoiced amount. The advantage of this is that when you summarize the agreed
days, the system also includes information about the invoice volumes concerned.

The agreed days are calculated for all three subterms (cash discount days 1, cash
discount days 2, and net days), if they exist.

Figure 54: Days Taken

To determine the actual terms of payment (in days), the invoices paid in the key
date - n days period are used. You can define the number of days and the key
date when you create the evaluation.

The calculation also uses the total interest calculation numerators and the total
invoiced amounts. The advantage of this is that when you summarize the actual
days, the system also includes information about the invoice volumes.

First, the report determines which subterm of payment was used to pay each
invoice (cash discount 1, cash discount 2, or net).

The following applies:

� No cash discount used, invoice paid net
� Up to 90 percent of the cash discount permitted for cash discount 1, invoice

paid with cash discount 2
� 90 percent or more of the cash discount permitted for cash discount 1,

invoice paid with cash discount 1
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Figure 55: Functions for Drilldown Lists

Navigate to a drilldown list on the lowest level of the tree structure of the AR/AP
information system. The functions listed in figure 60 are available in all drilldown
lists.

You can:

� Change the currency for the display
� Display percentages
� Set up scaling (for example, reports in thousands)
� Choose how the characteristics are to be displayed (with name or key)
� Set up the line item display according to your requirements
� Display the headings of the lists
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Figure 56: Printing and Sorting

You can:

� Print the drilldown list
� Sort the drilldown list by the columns displayed

Figure 57: SAP Presentation Graphic

You can display the values using an SAP presentation graphic.
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Figure 58: Report Tree: User-Specific Access Path
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Exercise 6: Customer/Vendor Information
System

Exercise Objectives
After completing this exercise, you will be able to:
� Create evaluations in the information system
� Describe various display options for evaluations
� Navigate in the tree structure of the accounts receivable/accounts payable

information system and adjust it to your needs

Business Example
Managers in accounts receivable want better reporting functions. In particular,
they want to be able to analyze combinations of different variables (for example,
company code, business area, and credit control area). They also want to be able to
drill down from the totals levels to the detail levels of individual documents. You
need to demonstrate that these functions are provided by the accounts receivable
information system, which accesses a preselected dataset.

Task 1:
Create an evaluation for evaluation view GR## (## = your group number),
which you just created.

1. To ensure that the system selects only the data from your new evaluation
view, GR##, create a corresponding variant ## (## = your group number) for
the data generation report RFDRRGEN with the name evaluation view
GR## (## = your group number) by choosing only your new evaluation
view, GR## (## = your group number).

2. Use the Job Wizard. Give your job the name Infosystem GR## (## = your
group number). Choose ABAP program step. The name of the report is
RFDRRGEN. Use the variant that you just created, variant ##. You want to
start the job immediately, as soon as you have finished defining it.

Check to see when your job is complete.

Continued on next page
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Task 2:
Display the evaluation so that you can analyze the overdue items in the application.

Display the results of the evaluation.

After you have created the data for your evaluation view, you can display the data
in accounts receivable.

1. Using the accounts receivable information system, generate an overdue
items by city analysis for company code 1000. Use your evaluation view
Customer Evaluations GR## (## = your group number).

2. Which city has the highest number of days in arrears?

3. Which city has the highest total items displayed at the key date?

Task 3:
Optional: Investigate the options provided by the functions in the drilldown
list:

1. Switch path. Find your evaluation in your evaluation view GR##.

2. Set focus in the accounts receivable/accounts payable information system.
Save your settings. Exit the report tree and then call it up again. Check
whether your settings have been saved.

Use the expanded level of both structures to save your user-specific settings.

This is useful if you always want to evaluate the same data selection.

3. Display the evaluation with the currency USD as the analysis currency,
exchange rate type�M�, translation on current date.

4. As additional headings for your list, choose the names of the evaluation
view, evaluation type, and evaluation.
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Solution 6: Customer/Vendor Information
System
Task 1:
Create an evaluation for evaluation view GR## (## = your group number),
which you just created.

1. To ensure that the system selects only the data from your new evaluation
view, GR##, create a corresponding variant ## (## = your group number) for
the data generation report RFDRRGEN with the name evaluation view
GR## (## = your group number) by choosing only your new evaluation
view, GR## (## = your group number).

a) Own variant for program RFDRRGEN:

Choose System→ Services→ Reporting

Report: RFDRRGEN

→ Goto→ Variants

Variant: ## (## = your group number)

Variants→ Create (or choose �Create�)

Evaluation view: GR## (## = your group number)

(Enter your evaluation view GR## from the previous exercise)

Edit→ Attributes

Meaning: Evaluation view GR##

Save

(A message appears, stating that your variant has been saved). Again:
Save (stores the values of your variant).

2. Use the Job Wizard. Give your job the name Infosystem GR## (## = your
group number). Choose ABAP program step. The name of the report is
RFDRRGEN. Use the variant that you just created, variant ##. You want to
start the job immediately, as soon as you have finished defining it.

Continued on next page
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Check to see when your job is complete.

a) Create preselected dataset

Information System→ Tools→ Create Evaluations→ Goto→ Wizard
version (or choose �Job Wizard�).

Continue

Job name: Information system GR## (## = your group number)

Continue

Choose �ABAP program step�

Continue

ABAP program name: RFDRRGEN

Variant: ##

Continue

Continue

Choose Start Immediately.

Continue

Continue

Finish

Display job:

Goto→ Own jobs (or choose Own jobs)

Goto→ Update display (or choose �Update� until you reach the
�Complete� status)

Select your second job.

Choose Job log.

You will see that your new evaluation view �GR##� has been created.

Continued on next page
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Task 2:
Display the evaluation so that you can analyze the overdue items in the application.

Display the results of the evaluation.

After you have created the data for your evaluation view, you can display the data
in accounts receivable.

1. Using the accounts receivable information system, generate an overdue
items by city analysis for company code 1000. Use your evaluation view
Customer Evaluations GR## (## = your group number).

a) Choose Information System→ Tools→ Display Evaluations

You see that your evaluation view GR## (customer evaluations
GR##) has been created as an additional node in the report tree.

Navigate within the evaluation view that you created.

Choose Customer evaluations GR##→ Overdue items→ Evaluation
by city→ For company code: 1000 IDES AG.

2. Which city has the highest number of days in arrears?

Answer:

3. Which city has the highest total items displayed at the key date?

Answer:

Task 3:
Optional: Investigate the options provided by the functions in the drilldown
list:

1. Switch path. Find your evaluation in your evaluation view GR##.

a) Switch path.

Choose Customer evaluations GR##→ For company code→ 1000
IDES AG→ Overdue items analysis→ By city:

2. Set focus in the accounts receivable/accounts payable information system.
Save your settings. Exit the report tree and then call it up again. Check
whether your settings have been saved.

Use the expanded level of both structures to save your user-specific settings.

Continued on next page
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This is useful if you always want to evaluate the same data selection.

a) If you have expanded the customer tree:

Set focus

Save

Exit the report tree and then call it up again.

3. Display the evaluation with the currency USD as the analysis currency,
exchange rate type�M�, translation on current date.

a) Setting→ Change

Value display: Select Currency analysis and choose Change

Currency: USD

Exchange rate type: M

Key date for conversion: current date

4. As additional headings for your list, choose the names of the evaluation
view, evaluation type, and evaluation.

a) Setting→ Change

Additional headings: select all
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Lesson Summary

You should now be able to:
� Create evaluations in the information system
� Use various options to display evaluations and navigate within the tree

structure of the accounts receivable/accounts payable information system
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Unit Summary
You should now be able to:
� Explain how the accounts receivable/accounts payable information system

works
� Name the various options for customizing the accounts receivable/accounts

payable information system and explain the effect of these options on
evaluations

� Create evaluations in the information system
� Use various options to display evaluations and navigate within the tree

structure of the accounts receivable/accounts payable information system
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Unit 4
Drilldown Reporting in Financial

Accounting

Unit Overview
Employees in General Ledger Accounting are looking for ways to display
appropriate evaluations and key figures with their own forms and reports when
they drill down data within data that is to be evaluated.

Unit Objectives
After completing this unit, you will be able to:

� Describe your knowledge of the architecture of drilldown reporting
� Explain the terms characteristics and key figures and the different types

of each.
� Explain the difference between single-axis and dual-axis forms and use these

forms appropriately
� Use various navigation options in drilldown reports
� Define forms
� Define and execute reports
� Define forms and reports more flexibly using characteristic and text variables
� Use different types of report outputs
� Create graphics
� Export data to Microsoft Excel
� Have the system perform currency translation
� Set up a report/report interface
� Use report assignments
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Lesson: Architecture of Drilldown Reporting

Lesson Overview
In this lesson, we will discuss the architecture of drilldown reporting.

Lesson Objectives
After completing this lesson, you will be able to:

� Describe your knowledge of the architecture of drilldown reporting

Business Example
Employees in Financial Accounting want to use the evaluation options in
drilldown reporting. They are primarily interested in finding out the basics of the
drilldown reporting architecture. They also want a brief insight into the possible
report types using existing form types in Financial Accounting.

Figure 59: Drilldown Reporting

Drilldown reporting is a dialog-oriented information system for evaluating data
from the FI, GL, AR, and AP databases.

Drilldown reporting contains helpful functions for navigating in the dataset. It also
contains several additional functions for processing a report interactively.

SAP Graphics, SAPmail, and various printing functions are connected to drilldown
reporting together with Microsoft Word for Windows and Microsoft Excel.
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Figure 60: Using the Report Painter

You can use the graphic interface of the Report Painter for various activities (for
example, to define Report Writer reports, drilldown forms, and planning layouts).

In this unit, you will learn how to use the Report Painter to create drilldown report
forms, which are required for drilldown reports in FI.

Figure 61: Form Types: Drilldown Reporting in FI

The following report types can be used for G/L account evaluations:
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1. Reports for financial statement analysis: These reports are based on the
financial statement versions defined in Financial Accounting. You can carry out
any number of variance analyses based on actual and plan data (annual, half-year,
quarterly, and monthly).

2. Key figure reports: For key figure reports, the system takes into account only
the financial statement items in the financial statement version that you need for
the calculation of specific key figures. This is not the case for financial statement
analysis reports. Financial statement version key figures could be for example,
equity ratio (stockholders' equity: total equity), debt-equity ratio (external capital:
stockholders' equity), and capitalization ratio (fixed assets: total assets). You can
create key figures from report rows and/or columns using an integrated formula
interpreter.

3. Balance display:

You can use the following report types for customer or vendor drilldown reports:

a) Balance display

b) Line item analysis

Figure 62: Architecture of Drilldown Reporting

As shown above, a report definition can contain characteristics, key figures, and
forms. A report is a number of interactive, controllable report lists and graphics
that are displayed on the screen.

Drilldown reporting provides useful functions for navigating within the dataset
(for example, next level, next object within a level, hiding a level, detail
list/drilldown list). It also contains several additional functions that can be used
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to process a report interactively (sorting, specification of conditions, ranked list,
and so on). You can send report lists (for example, as a fax), display them on the
Internet, or transfer them as files to Microsoft Word and Microsoft Excel.

In addition to the dialog functions for displaying reports, drilldown reporting
also contains functions for printing reports. There are various print preparation
functions for you to structure your report as you require (such as pagebreak,
headers and footers, and underlining).

A form describes the basic content and formal structure of report lists. A form
can be seen as a semi-finished product for a report; it is later completed with
characteristics and key figures when you define the report. Characteristics appear
in the form as well as in the report. You can choose key figures either in the form
or the report.
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Lesson Summary

You should now be able to:
� Describe your knowledge of the architecture of drilldown reporting
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Lesson: Characteristics and Key Figures

Lesson Overview
In this lesson, you will learn the meaning of characteristics and key figures in lists.

Lesson Objectives
After completing this lesson, you will be able to:

� Explain the terms characteristics and key figures and the different types
of each.

Business Example
Employees in Financial Accounting want to use characteristics and key figures in
drilldown reporting. They are mainly interested in the different types.

Figure 63: Characteristics and Characteristic Values

Characteristics specify the classification options for the dataset. Examples of
characteristics are company code, business area, and plan/actual indicator. The
time reference (fiscal year, period) is also a characteristic.

Characteristic values are concrete forms of a characteristic. Possible values for
the characteristic company code could be 0001, 0002, 1000, or all the company
codes defined in the system.

A combination of characteristics and characteristic values is generally called an
object in drilldown reporting.
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Figure 64: Key Figures

In the applications, there are various key figures that can be relevant to
evaluations. Key figures are not just values and quantities, but also calculations
involving these values and quantities with user-defined formulas.

The following are examples of key figures:

� Value: Balance sheet value, debit total, sales/purchases

� Quantity: Number of employees, sales quantity

� Calculation: Sales per employee, plan/actual variance
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Figure 65: Drilldown List/Detail List

There are two types of list for displaying information: The detail list and the
drilldown list.

In a drilldown list, several objects (for example, assets under construction,
vehicles, chemicals) are formatted using a selection of key figures. Usually, the
key figures are in the columns of the list (for example, balance sheet value, total
debit postings, total credit postings). The rows contain the characteristic values of
all the characteristics that are drilled down.

In a detail list, an individual object (for example, business area) is formatted for
all key figures according to the form. Usually, the key figures are in the rows of
the detail list (for example, balance sheet value, total debit postings, total credit
postings).
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Lesson Summary

You should now be able to:
� Explain the terms characteristics and key figures and the different types

of each.
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Lesson: Form Types

Lesson Overview
In this lesson, you will learn about using single-axis and dual-axis forms (matrix)
for drilldown reporting in FI.

Lesson Objectives
After completing this lesson, you will be able to:

� Explain the difference between single-axis and dual-axis forms and use these
forms appropriately

Business Example
Employees in Financial Accounting want to use a single-axis or dual-axis form
with key figures.

Figure 66: Different Types of Forms

The following form types exist:

Single-axis form without key figure

� If you are using a single-axis form without key figures, you define either
the form rows or columns with characteristics. When you access the initial
screen, the system displays an empty list with columns.
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Single-axis form with key figure

� If you are using a single-axis form with key figures, you define either the
form rows or columns with key figures and characteristics. When you access
the initial screen, the system displays an empty list with rows.

Dual-axis form with key figure

� If you are using a dual-axis form with key figures, you define the form rows
and the columns with key figures and characteristics. When you access the
initial screen, the system displays an empty list containing rows and columns.
You are free to define whether the rows contain key figures and the columns
contain characteristics, or vice versa. It depends on what you want to report.

When you create a form, you define the name and the type of form that you
want to process.

Figure 67: One Axis with Key Figure

In a single-axis form with no key figures, you make selections only in the
characteristics columns. The characteristics that you select in the form define the
column content. You can also perform calculations with formulas (for example,
the variance could be the difference between plan and actual).

You select the key figures and the drilldown characteristics (that is, the
characteristics whose values you want to use to navigate in the report) when
you define the report (for example, the characteristics business area, financial
statement item, or account number).
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The drilldown list contains a two-line column heading. The key figures (for
example, balance sheet value, total debit postings, total credit postings) are in
the first row and the characteristics that you selected in the form (for example,
fiscal year, prior year, variance) are listed below. The values for the drilldown
characteristics are in the rows (for example, assets under construction, vehicles,
and chemicals for the business area).

In the detail list, the characteristics chosen in the form are contained in the
columns, and the key figures are contained in the rows. The detail list displays the
results of a selected characteristic value (for example, assets under construction
for business area).

Figure 68: One Axis with Key Figure

In a single-axis form with key figures, the key figures are integrated with
characteristics in the rows of the form (for example, fiscal year balance sheet
value, prior year balance sheet value with variance).

In the report definition, only the drilldown characteristics are chosen (for example,
business area, financial statement item account number, and so on).

In the drilldown list, the key figures integrated with the characteristics are the
columns of the form, and the values of the drilldown characteristics form the rows
(for example, assets under construction, vehicles, chemicals, and so on).
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The detail list has one column and contains the selected characteristic value for
which you want to report (for example, assets under construction), and the key
figures are in the rows.

Hint: When you use a single-axis form with key figures, you define either
the rows or the columns for the form. From the initial screen, the system
displays a list containing rows but no content. However, you can use the
column display function to tilt the form. This means that you are free to
decide whether you want to define rows or columns for this form type.

You define the detail list when you define a form. This means that the position
of the elements that you define in the form corresponds to the position in the
detail list. Therefore, for single-axis forms with key figures, the key figures are
defined in the rows by default.

Figure 69: Two Axes (Matrix)

In a form with two axes (matrix), both the rows and columns are defined using
key figures or characteristics. The key figures have to be in either the rows or
the columns of the form, but you can enter the characteristics in the rows and
the columns.

When you define the report, you then choose only the drilldown characteristics
(for example, business area, company code, account number, and so on).

2009 © 2009 SAP AG. All rights reserved. 119



Unit 4: Drilldown Reporting in Financial Accounting AC280

In figure 74, the columns of the drilldown list are created with two levels; that is,
the higher level contains the key figures (debit total, credit total) and the lower
level contains the characteristics chosen in the form (fiscal year actual, fiscal year
plan with variance). The lines contain the values for the business area (assets
under construction, vehicles, chemicals, and so on).

In the detail list, the characteristics chosen in the form appear in the columns, and
the key figures chosen in the form appear in the rows. The detail list is a report
about the characteristic value chosen (assets under construction).

Hint: In all types of forms, you can use various functions to change the
layout and settings as you require (colors, number format, separators,
text, and so on).
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Lesson Summary

You should now be able to:
� Explain the difference between single-axis and dual-axis forms and use these

forms appropriately
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Lesson: Navigation in Reports

Lesson Overview
In this lesson, you will learn to navigate in drilldown reports, using basic lists
and drilldown lists.

Lesson Objectives
After completing this lesson, you will be able to:

� Use various navigation options in drilldown reports

Business Example
Employees in Financial Accounting want to use the wide range of navigation
options provided in FI drilldown reports.

Figure 70: Navigation in Classic Drilldown Reports

From drilldown list to detail list

If you want to switch from the drilldown list to the detail list, choose the Detail
list symbol. All of the row selection symbols are then highlighted in a different
color. Choose the required evaluation object. The system then displays the
required detail list.
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Back to basic list: If you want to return to the basic list, choose the XX symbol (in
red). Note that changes that you make to settings in the meantime -- for example,
changes to the number format -- are retained.

Figure 71: Navigation in Classic Drilldown Reports (2)

From detail list to drilldown list

If the basic list is defined as the detail list for a report, the detail list is the first
screen to be displayed when you execute your report. If you want to switch
from the detail list to the drilldown list, choose Drilldown list. The system
then highlights all the free characteristics in the navigation block. Choose a
characteristic by clicking it. The system then displays the drilldown list.
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Figure 72: Navigation in Classic Drilldown Reports (3)

You are in the drilldown list in which the FS item characteristic is drilled down.
The navigation area for the drilldown list contains additional characteristics that
you can use. If you want to exchange the FS item with another characteristic, for
example, Period, first click FS item and then Period. The two characteristics then
change places: FS item is now available for selection in the navigation block, and
Period is drilled down for all characteristic values.

Note: With new G\L functionality all forms and reports are based in the
new table FAGLFLEXS which is the reporting table for FAGLFLEXT
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Exercise 7: Drilldown Reporting in
Financial Accounting

Exercise Objectives
After completing this exercise, you will be able to:
� Define and execute forms and reports of different types in General Ledger

Accounting.
� Explain and use navigation options when you are displaying a report
� Define forms and reports more flexibly using characteristic and text variables
� Try various layout settings for the report output
� Explain the different types of cells and use cells in formulas
� Use different output types for reports and test the functions during output

Business Example
Employees in Financial Accounting want to learn about the evaluation options
provided by drilldown reporting, and use the various navigation options.

Task:
Navigation

1. Execute the standard report for the financial statement analysis
0SAPFS10-01 (Actual/Actual Comparison for Year).

User menu→ AC280 Drilldown Activities→ Execute standard drilldown
reports→ Actual/actual comparison for year

On the selection screen, enter company code 1000 and the Currency type
10. The FIS Annual Rep.Structure is INT. Ledger is 0L Reporting year is
current year. Reporting year from and to is 1-16 and comparison year is the
previous year from 1-16 Choose Classic drilldown report as the output type.

The initial display is a drilldown list. The FIS Annual Rep.Structure and the
financial statement items are shown in the row. The columns show the
financial statement results for the current fiscal year, the previous year
and the variance.

Using your knowledge of the navigation options in the output (changing
from drilldown to detail list and changing the drilldown characteristics), find
the following results and make a note of them in the following table:

Continued on next page
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1. Financial statement itemWages and salaries for the current fiscal
year _________
2. Financial statement item Provisions for the profit center 1005
(Automobiles) in the previous year _________
3. FS item Capital Revenue for the profit center 1000 in period 7 of
the current fiscal year _________
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Solution 7: Drilldown Reporting in
Financial Accounting
Task:
Navigation

1. Execute the standard report for the financial statement analysis
0SAPFS10-01 (Actual/Actual Comparison for Year).

User menu→ AC280 Drilldown Activities→ Execute standard drilldown
reports→ Actual/actual comparison for year

On the selection screen, enter company code 1000 and the Currency type
10. The FIS Annual Rep.Structure is INT. Ledger is 0L Reporting year is
current year. Reporting year from and to is 1-16 and comparison year is the
previous year from 1-16 Choose Classic drilldown report as the output type.

The initial display is a drilldown list. The FIS Annual Rep.Structure and the
financial statement items are shown in the row. The columns show the
financial statement results for the current fiscal year, the previous year
and the variance.

Using your knowledge of the navigation options in the output (changing
from drilldown to detail list and changing the drilldown characteristics), find
the following results and make a note of them in the following table:

1. Financial statement itemWages and salaries for the current fiscal
year _________
2. Financial statement item Provisions for the profit center 1005
(Automobiles) in the previous year _________
3. FS item Capital Revenue for the profit center 1000 in period 7 of
the current fiscal year _________

a) User menu→ Execute standard drilldown reports→ Actual/actual
comparison for year

(or in the SAP menu: Accounting→ Financial Accounting→ General
Ledger→ Information System→ General ledger reports (New)→
Financial Statement / Cash Flow→ General→ Financial Statement
Actual/Actual comparisons

Company code: 1000

Currency type: 10

In Report selections, enter FIS Annual Rep.Structure as INT

Continued on next page
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Ledger is 0L

Reporting year is the Current year

Reporting From & To is 1-16

And comparison year is the previous year with 1-16 as periods for the
fields Comparison per. from & To

Output type: Classic drilldown report

The initial display is a drilldown list:

� Financial statement items in the rows
� Financial statement value results for the current fiscal year, the

previous year, and the variance in the columns

Switch from the SAP Easy Access menu to your user menu .

In the folder Execute standard drilldown reports: Report, choose
Actual/actual comparison for year (financial statement analysis
actual/actual comparison for year). On the selection screen, enter
company code 1000, FIS Annual Rep.Structure INT, and the
current fiscal year. Execute the report.

FIS Annual Rep.Structure and the financial statement items are
displayed in the rows. Navigate down to Profit and loss statement in
the version, and then proceed until you findWages and salaries.

→ Profit and loss statement→ Staff costs→Wages and salaries

Make a note of the financial statement value for this item in the current
fiscal year.

Proceed to Liabilities and continue to navigate until you find
Provisions.

→ Liabilities→ Provisions

Scroll through the navigation area above until you find the profit
center. Select the Tangible assets row by clicking the angle brackets
icon (<>). Then click profit center in the navigation area. The report
values for the Tangible assets are now drilled down by business
area. Make a note of the balance sheet value for the combination of
Provisions and profit center 1005 (Automobiles) in the previous year.

You can change the characteristic display: You can choose a name and
key by choosing Settings→ Characteristic display.

You can now reset the drilldown by the Financial statement item
characteristic by choosing the Σ (deactivate characteristic) icon. The
Financial statement item characteristic is now available for selection in
the navigation area.

Continued on next page
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Select the profit center 1000 row by clicking the angle brackets icon
(<>). Click the FS item drilldown characteristic (you may have to
scroll down the navigation area). The report values for the profit center
1000 are drilled down by financial statement item. The FIS Annual
Rep.Structure and the financial statement items are displayed in the
rows. In the version, proceed to LIABILITIES and then navigate
further until you have found Capital & reserves and then Capital
Revenue.

→ LIABILITIES→ Capital & reserves→ Capital Revenue.

Select the Capital Revenue row row and then click Period/year in the
navigation area. For the Profit center 1000 and the financial statement
item Capital Revenue, the system drills down the report values by
period/year. Make a note of the financial statement value for the
combination of profit center 1000, Capital Revenue, and Period 7
in the current fiscal year.
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Lesson Summary

You should now be able to:
� Use various navigation options in drilldown reports
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Lesson: Form and Report Definition

Lesson Overview
In this lesson, you will learn to use single-axis and dual-axis forms (matrix) for
drilldown reporting in FI.

Lesson Objectives
After completing this lesson, you will be able to:

� Define forms
� Define and execute reports
� Define forms and reports more flexibly using characteristic and text variables

Business Example
Employees in Financial Accounting want to define forms and reports for drilldown
reporting in FI.

Figure 73: Form Definition: Example of Financial Statement Analysis

SAP delivers standard forms, which you can use as templates to create your
own forms. The names for these standard forms are 0SAPBLNCE-01 through
0SAPBLNCE-NN, and you cannot use these names for your own forms.

Defining characteristics for all columns (general selections)

First, define the characteristics that apply to all the columns in your form. Since
you want to enter actual data in all the columns of your form, you can define this
general characteristic by choosing Edit→ General selections.

2009 © 2009 SAP AG. All rights reserved. 131



Unit 4: Drilldown Reporting in Financial Accounting AC280

A dialog box appears for you to select the characteristics for the general selections.
In the dialog box, add the characteristic Record type to the table of selected
characteristics and define the value 0 for actual data.

Figure 74: Form Definition (2): Example of Financial Statement Analysis

Once you have defined the general characteristics, you can then define the
characteristics of the individual columns.

A dialog box appears, in which you can select Key figure with characteristics. A
second dialog box appears. Choose Balance sheet value (BILWERT) from the list
of available key figures. In this case, the key figure reflects the values of the
balance sheet that you want to evaluate for your report.

To carry out an actual/actual year comparison, you also require the Fiscal year
characteristic.

Then define the characteristic values for the characteristics that you have selected.
For example, for the fiscal year, you can enter either fixed values or variables. If
you want to enter fixed values, specify the specific value (for example, 2001).

Figure 79 shows the entry for two columns, in which you selected the fixed values
2001 and 2000 for the Balance sheet value.

You can enter three different lengths of text. These are then used as the column
headings for the elements. You can enter a short, medium, or long text. Using the
text type, you can later determine which text is used for each column. If you want
to enter a two-line heading, note that when you enter a long text you separate the
two lines using a semicolon (;). You can change the text type by choosing Format
→ All columns→ Text type.
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Figure 75: Form Definition (3): Example of Financial Statement Analysis

In the third column, you define the variance between the first and the second
column.

To do this, place the cursor on the third column and choose Edit→ Element→
Define element.

On the following screen, choose Formula. The formula editor appears, in which
you define the formula that is to be used to calculate the variance. Using the
formula editor, you can perform standard arithmetic operations (+, -, *, /) with
any elements.

Under ID, double-click the first value, select the minus sign, and then double-click
the second value under ID.

On the following screen, maintain the text types for the Variance column.

Save the form.
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Figure 76: Report Definition: Example of Financial Statement Analysis

Enter the name of a new report or choose the name of the report whose definition
you want to change. You have to choose an appropriate form for the report type
(financial statement analysis, financial statement key figures, or balance display).
You can choose a reference report if necessary.

On the Characteristics tab page, the system displays a list containing all the
available characteristics. In the characteristic list, select the characteristics that
you want to use for your evaluation in the report, and use the arrow buttons to
add them to the report. These characteristics are the drilldown characteristics
that you use to navigate in the report.

Using the Sort characteristics function, you can determine the order of the
characteristics in the navigation block of the report list for the executed report.
The order of the characteristics determines the layout of the standard drilldown.
The characteristics that you defined for a characteristic value when you defined
the report are above the navigation block and you cannot re-sort them. To
improve performance, you should not select characteristics that you do not need
in the drilldown report. Even if you are printing, you should only retain the
characteristics that you actually require, otherwise the system outputs superfluous
subtotals. The number of characteristics offered for selection is resricted by the
selection criteria defined in the form. If you have already specified a characteristic
in the form, it is no longer offered for selection.
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Figure 77: Report Definition (2): Example of Financial Statement Analysis

Once you have selected a characteristic, all the values for this characteristic are
included in the report. There are various ways of restricting the value quantity of a
characteristic for output in the report.

On the Characteristics tab page, you can restrict the characteristic values for each
drilldown characteristic chosen. There are various options dependent on the report
definition and the characteristic selected.

1. You do not make an entry. If you do not make any of the restrictions described
below, the system selects all the characteristic values when you run the report.
For example, the system displays all business areas for the Business area
characteristic. In all other cases, the system reads only the characteristic value that
you entered, for example, only Assets under construction for the Business area.

SAP recommends that you choose characteristics carefully to limit the quantity of
data selected. This improves system response times.

1. You define a characteristic value for a characteristic. If, for example, you are
only interested in the value 1100 for the Company code, you can restrict the report
accordingly. The characteristic and the characteristic value then appear above the
navigation block on the report list and have been defined (that is, you cannot use
the characteristic as a drilldown characteristic).

1. You use a variable for characteristic values (see figure 83).
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Figure 78: Variables: Overview

There are two types of variables: global variables and local variables.

If you use a variable only in a special form or report, you create a local variable.
This is then only recognized within the form or report. If you define a local
variable in a form, this variable applies in each report that uses the form. A local
variable that you define in the report itself only applies to this report.

If you use certain variables frequently, you can define them globally. You can
then use these variables in all forms and reports. You maintain global variables in
Customizing. If you then want to use global variables for characteristics in a form
or report, the system provides them as possible entries.

Hint: If you change a global variable, all reports and forms that use this
variable are affected.

SAP delivers variables that start with a number.

If you use certain variables frequently, you should define them globally instead of
in a report or form. You can then use these variables in all forms and reports. This
is particularly useful for characteristics that frequently form part of general report
selections (for example, period, fiscal year, and so on).
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Figure 79: Variables for Form Definition

Certain variables for characteristic values are delivered, for example 1FY (fiscal
year).

Variables are uniquely identified by their name and their use (text/characteristic,
and so on) and variables for characteristic values are identified by the field to
which they refer.

One of the things that you have to specify when you define variables is a
replacement type. The replacement type specifies how a variable is replaced by a
value. You can replace a variable with a value either automatically or manually.

Figure 80: Variables Example: Fiscal Year Column
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You can enter the name of the variable in the dialog box that is displayed when
you select the Variable checkbox.

Let us say, for example, you want to create a form in which the year is entered in
the first column using a variable. The second column should display the previous
year.

In the first column, choose the characteristic fiscal year and assign the variable
1FY as a value. You previously defined 1FY as a global variable with obligatory
entry.

Figure 81: Variables Example: Previous Year

You can link variables for characteristic values that refer to a numeric input field
(for example, 1FY for current fiscal year 2001) sequentially with constants (for
example: 1FY-1 for the previous year 2000). This function is supported for global
and local variables for characteristic values.

You want to create a form in which the year is entered in the first column using a
variable. You want to display the previous year in the second column.

In the first column, choose the characteristic fiscal year and assign the variable
1FY as a value. You previously defined 1FY as a global variable with obligatory
entry. This display is shown in figure 86.

In the second column (as shown in figure 85), also select fiscal year and then
specify the variable name 1FY. Enter a minus sign (-) in the Operator field, and 1
in the Offset field. When you use the Create report or Execute report functions, the
system requests only the fiscal year for variable 1FY; it automatically determines
the previous year.
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Figure 82: Variables: Texts

You can enter a short, medium, or long text for the column headings. Using the
text type, you can later determine which text is used for each column. If you want
to enter a two-line heading, you must separate the two lines using a semicolon (;).

If you want texts in the rows or columns to be defined by variables and not to
be fixed, you have to use a text variable. Text variables are used only in form
reports (in the form itself). They are replaced when you choose the Execute report
function. You have to maintain global variables in Customizing before you can
enter them in the text field of the form. For local variables, you have to enter the
dollar sign ($) and an appropriate name.

For text variables, the replacement type determines the additional entries. You
usually define an automatic replacement path and the text is taken from the
master data. Note that text variables can only be automatically replaced if they
refer to characteristics and you chose the corresponding characteristic when you
defined the element. For example, you define the following for a local variable
$FYT (text for fiscal year): Automatic replacement using the value in the From
field of the characteristic Fiscal year (from character 1, length 4). You specify the
text length when you define the variables. The maximum length of the name of a
local variable is eight characters. For replacement with entry, the text length is
identical to the length of the variable name.
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Figure 83: Layout Options in Forms

You can use several functions to define the layout of a form:

� Color setting: You can use this function to display a selected element in a
different color.

� Number format: You use this function to define the scaling and the number
of decimal places. Note that the definition that you make here always refers
to specific rows or columns. Once you have executed a report, you can
refine this definition (that is, you can make other settings for specific rows
or columns).

� Text type: This defines which text (short, medium, or long) is displayed in
the rows or columns.

� Column width: You use this function to change the column width. First,
select the column(s) that you want to edit and then change the column width.

� You can also add separators, empty lines, and texts for emphasis.
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Figure 84: Layout Options in Forms (2)

Additional settings are listed below:

� Zero suppression: If you use this function, cells with the value zero remain
empty in the report. In the form, this formatting is shown by �xxx.xxx.xxx.�

� Indentation: You can use this function to indent the text of individual rows,
for example, to reflect a graphic sorting.

� Hide columns or rows: This function hides the row/column on which you
place the cursor. The content of the row/column that you have hidden is
retained and you can still use it in formulas. You can edit the rows that you
have hidden by choosing Hidden rows→ Change. You can also delete or
display these rows/columns.

� Reverse the +/- sign: This function reverses the +/- signs in the report.
Negative values are displayed positively and positive values are displayed
with a minus sign. In the form, this is shown by the minus sign (-).
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Figure 85: Cell Calculation in Forms

You can define percentages of totals for rows and columns in the form. You do
this using the Percentage of total function when you define the formula in the
formula editor.

The content of a cell is usually determined by the row and column for which it is
the point of intersection. If this is not sufficient to determine the content, you also
have to define the cell. To do this, place the cursor on a cell and choose Edit→
Element→ Define element, or double-click the cell.

If you are not actually editing the cell, but it is to be included in formulas, choose
Selected. If you then go to the formula definition in the formula editor, the system
provides the selected cells for selection.

Choose Inactive if you want to deactivate a cell in cases where the value is of no
use. The cell is then empty, and appears as 0 (zero) in the form.
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Figure 86: Cell Calculation in Forms (2)

Cell type: Formula : The Formula cell type is provided when you have defined
at least one cell that can be included in the formula. If you select this cell type,
the formula editor appears automatically. In the formula editor, you can define a
formula based on existing cells. You use a special cell text to describe the cell.

Note that this special cell does not have to contain the value that would result from
the intersection of the row and column selection.

Example of cell processing: Changing fixed assets over several years.

The result of fixed assets is retained as a cell for each fiscal year.

For the Change to fixed assets row, the relevant cells are linked to each other
mathematically as a formula at each row/column intersection point. For example,
Z002-Z003 (in figure 91) corresponds to the subtraction of the fixed assets value
for 1999 from the fixed assets value for 2000.
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Figure 87: Cell Calculation in Forms (3)

Additional example of cell processing: Increase or decrease in fixed assets.

Formulas for increase: MX0 (Z001-Z002); MX0 (Z002-Z003); MX0 (Z003-Z004)
→ Maximum of operand and zero

Formulas for decrease: : MN0 (Z001-Z002); MN0 (Z002-Z003); MN0
(Z003-Z004)→ Minimum of operand and zero
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Exercise 8: Drilldown Reporting in
Financial Accounting

Exercise Objectives
After completing this exercise, you will be able to:
� Define and execute different types of forms and reports in FI-GL
� Explain and use navigation options when you are displaying a report
� Define forms and reports more flexibly using characteristic and text variables
� Try various layout settings for the report output
� Explain the different types of cells and use cells in formulas
� Use different output types for reports and test the functions during output

Business Example
Employees in Financial Accounting want to learn about the evaluation options
provided by drilldown reporting and use the various navigation options.

Task 1:

1. Create a form G##-BALPL-01 (## = your group number) for the Reporting
for Table FAGLFLEXT form type. Enter G## Act/act year as the
description. Choose One axis with key figure as the structure

User menu → AC280 Drilldown Activities→Drilldown Reporting:
Maintain Forms→ Create Form

In the general selections, add the Record type 0 for actual and Ledger 0L.

Edit→ General data selection→ General data selection

Choose the column display for your entries in the form.

Goto→ Column display

Define 3 columns:

Column 1:

Key figure BILWERT (Balance Sheet value) with the characteristic Fiscal
year. Enter the current fiscal year for the characteristic Fiscal year (fixed
value). Enter FY XXXX (XXXX = current year) as a short, medium, and
long text.

Column 2:

Continued on next page
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Key figure BILWERT (Balance Sheet value) with the characteristic Fiscal
year. Enter the previous fiscal year for the characteristic Fiscal year (fixed
value). Enter FY XXXX (XXXX = previous year) as a short, medium, and
long text.

Column 3:

Variance between the current fiscal year and the previous fiscal year
(using formula). Enter Variance as the short, medium, and long text.

Check your form

Save your form.

Task 2:

1. For this form, create the report G##-BALPL-01 (## = group number) for
the report type Reporting for Table FAGLFLEXT with the description G##
Act/act year.

Environment→ Report→ Create (or Report button)

From the drilldown characteristics, choose financial statement item,
company code, profit center, and account number. You should be able
to enter the hierarchy selection (financial statement version) using the
characteristic Financial statement item when you run the report. Enter the
fixed value 1000 for the characteristic Company code.

Change the order of the user-defined characteristics.

Sort user-defined characteristics button, after

Currency (1), Currency type (2) and Company Code (3) sort by:

FS Item (4),

Account number (5), and

Profit center (6).

On the Output type tab page, choose Classic drilldown (Basic list: D-down)
and Available on selection screen.

Save your report.

Task 3:

1. Execute the report:

Exit the screen for maintaining the report.

Continued on next page
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Start the report from your user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

Place the cursor on report G##-BALPL-01 and choose

Drilldown report→ Execute (or double-click your report) G##-BALPL-01.

Currency type: 10

The FIS Annual Rep.Structure: INT:

Output type: Classic drilldown report

Execute

Navigate within the report until you find the account number for office
supplies. Make a note of the financial statement value for the Profit center
Motorcycles (1000) for the current fiscal year.

_______________________________________________________________

_______________________________________________________________

Task 4:

1. Create a form G##-BALPL-02 (## = your group number) for the form
type Reporting for Table FAGLFLEXT. Enter G## Act/act year var. as the
description. Choose One axis with key figure Create as the structure.

User menu→ AC280 Drilldown Activities→Drilldown Reporting: Maintain
Forms→ Create Form

In the general selections, add the Record type 0 for actual and Ledger 0L.

Edit→ General data selection→ General data selection

Choose the column display for your entries in the form.

Goto→ Column display

The form should have the same structure as your first form.

Column 1:

Key figure BILWERT (balance sheet value) with the characteristic Fiscal
year. Enter the global variable 1FY for the characteristic Fiscal year.

Enter the text:

Short: FY &1FY and click Copy short text.

Column 2:

Continued on next page
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Key figure BILWERT (Balance Sheet value) with the characteristic Fiscal
year. For the fiscal year, enter the global variables 1FY and in the As
operator field, enter a hyphen (�) and Offset 1. Enter the text:

Short: FY &1FY and choose Copy short text.

Column 3:

Variance between the current fiscal year and the previous fiscal year
(using formula). Enter Variance as the short, medium, and long text.

Check your form.

Save your form.

Task 5:

1. Create report G##-BALPL-02:

On the maintenance screen for the form:

Environment→ Report→ Create (or Report button)

For the form you have just created, create the report G##-BALPL-02 (## =
group number) for the report type Reporting for Table FAGLFLEXT with
the description G## Act year var.

Select the drilldown characteristics FS Item, Company code, Profit Center
and Account number.

Enter INT for the financial statement version.

(Double-click the characteristic Financial statement item).

Change the order of the user-defined characteristics by choosing Sort
user-defined characteristics.

After Currency (1) and Currency type (2)

Sort by FS Item (3)

Company code (4)

Account number (5), and

Profit center (6).

Choose Classic drilldown (Basic list: drilldown) as the output type and
Available on selection screen.

Enter the Current fiscal year as the default value for the fiscal year.
(Variables tab page)

Save your report.
Continued on next page
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2. Execute the report:

Exit the maintenance screen for the report.

Start the report from your user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

Double-click report G##-BALPL-02.

Accept the current fiscal year. You want to display the financial statement
values for currency type 10 and company code 1000.

Execute

When you display the report, navigate using the characteristics Profit center,
Account number, and Financial statement item.

3. Execute this report again. On the selection screen, enter the previous year as
the fiscal year.

Task 6:
Key figures report

1. Create form:

Once you have completed the form, it should look as follows:

Fiscal year 2009 Fiscal year 2008 Fiscal year 1999
Assets
Fixed assets xx,xxx.xx xx,xxx.xx xx,xxx.xx
Financial
statements total

xx,xxx.xx xx,xxx.xx xx,xxx.xx

% financial
statement total

xx.xx xx.xx xx.xx

Example: The current fiscal year in the above report is 2009.

Note:

You want to determine the values for the characteristic Fiscal year and the
texts in which the fiscal years are displayed using local variables.

In the form, define the characteristic variable FY and the text variable FY.

User menu→ Drilldown Reporting: Maintain Forms→ Create form

Create a form G##-BILKENN1 (## = your group number) for the Reporting
for Table FAGLFLEXT form type.

Continued on next page
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Enter G## Asset proportion as the description.

Choose the structure Two axes (matrix).

Edit→ General data selection→ General data selection

The general selections should contain the characteristic Financial statement
version with the value INT, the characteristic Record Type 0 (actual) and
Ledger 0L.

Columns

You want to determine the values for the fiscal year and the texts in which
fiscal years are displayed, using local variables. In the form, define the
characteristic variable FY and the text variable FY.

Create the first column (column 1):

Element type: Key figures with characteristics

Key figure: BILWERT (Balance sheet value)

Characteristic: Fiscal year

Local variable FY

(this ensures that you can subsequently enter the fiscal year on the selection
screen)

Text for column 1: Short, FY1 $FY; Medium, FiscYr $FY; Long, Fiscal
year ; $FY

Enter

Confirm

The width of this column should be 19.

Place the cursor on the column and choose:

Formatting→ Column→ Column width

Enter

To copy the formatting, and the content of the first column to the second
column, place the cursor on the first column and click on the icon select.

Place the cursor on the second column and click . Copy the formatting,
and the content of the first column to the third column the same way.

You now have to change the second column:

Edit→ Element→ Change

Double-click the variable FY

Local variable FY with Operator � and Offset 1
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Change short, medium, and long texts button

Text for column 2: Short, FY2 $FY; Medium, FiscYr $FY; Long, Fiscal
year ; $FY

You now have to change your third column:

Edit→ Element→ Change

Double-click the variable FY

Local variable FY with Operator � and Offset 2

Choose Change short, medium, and long texts

Text for column 3: Short, FY3 $FY; Medium, FiscYr $FY; Long, Fiscal
year ; $FY

You can now change the Text type for all columns:

Formatting→ All columns→ Text lengths

Select Two-line long text.

The values in all columns should have 2 decimal places.

Place the cursor on each column and choose:

Formatting→ Number format (or the Number format button )

Choose the format 0.00 for decimal places.

You now have to define the variables you used; FY as a characteristic
variable and FY as a text variable:

Extras→ Variables→ Variable definition

Enter Fiscal year as the description for your variable for the characteristic
value (this is the text that subsequently appears on the selection screen).

Enter Fiscal year text as a description for your text variable

Double-click text variable FY and enter the following:

Replace selected field: Automatically

Selected characteristic: RYEAR

Replace selected field: From field

Replace selected characteristic value/text with: Characteristic value

Selected field: Offset 1 Length 4

This ensures that the fiscal year (e.g., 2001) is actually displayed as 2001
in the column heading of your list.

To increase the key column width, place the cursor on the key column.
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Formatting→ Column→ Column width

Enter 30 as the column width.

Rows

1. Configure long text for all rows:

Formatting→ All rows→ Text lengths

Choose One-line long text as the text type.

2. Enter the text Assets in the first row.

Edit→ Rows→ Insert row;then Edit→ Rows→ Insert text: Assets

3. Separator

Edit→ Rows→ Insert dividing line

Enter the character - - as an underscore for the separator.

In the following dialog box containing the query: Should the underscore
appear only in the value columns?, choose No

4. Financial statement items 1010000, 1020000, and 1030000, which are
to be inserted individually as rows. The total for all three will then be created
in a formula and then the three individual rows hidden.

Place the cursor on the row beneath the separator.

Edit→ Element→ Insert element (or double-click this row)

Element type: Characteristic overview (selection button)

FS Item as a characteristic in the Selected characteristics list

Enter the FS Items 1010000, 1020000, and 1030000 each individually
one after the other as rows and keep the texts for them as offered. To be
able to enter these Items you have to, each time, choose the Hierarchy icon
below �Change hierarchy node entry� and then enter the FS Item number
or use the matchcode button to navigate down and choose the Item number
that way. Finally, choose Confirm to bring the Item with its description
into the formula row.

After these three rows, insert a Formula row with the addition of these
three rows.

Texts for the Formula row:

Short: Assets; Medium: Fixed assets; Long: Fixed assets.

You should then HIDE the 3 rows containing the FS Items 1010000, 1020000
and 1030000. To do this place the cursor on each of these rows and then
choose Edit→ Rows→ Hide.
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5. Financial statement item 1000000 ASSETS for the Financial statement
total row:

Edit→ Element→ Insert element (or double-click this row)

Element type: Characteristic overview (selection button)

Financial statement item as a characteristic in the Selected characteristics
list. Choose the Hierarchy icon below "Change hierarchy node entry"
and then enter the

FS item 1000000

Texts for the element definition:

Short: FSTotal; Medium: FS Total; Long: Financial Statement total

6. Separator

Edit→ Rows→ Insert dividing line

Enter the character - - as an underscore for the separator.

In the following dialog box containing the query: Should the underscore
appear only in the value columns?, choose No

Formula for the % financial statement total row (Y001 %A Y002):

Edit→ Element→ Insert element (or double-click this row)

Element type: Formula (selection button)

Formula: Y001 %A Y002

Texts: short: % Portion; Medium % financial statement total; Long: %
portion financial statement.

This row should be displayed in a different color to the other rows.

Formatting→ Color setting: Color for totals

Check your form.

Save your form.

Task 7:

1. Create report for key figures:

For this form, create the report G##-BILKENN1 (## = group number) for
report type Reporting for Table FAGLFLEXT with the description G## Asset
proportion.

Environment→ Report→ Create (or Report button)
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Choose Company code and Profit center as drilldown characteristics.

On the Output type tab page, choose Classic drilldown reporting (Basic list:
Detail) and Available on selection screen.

Save your report.

Task 8:

1. Execute the report:

Exit the maintenance screen for the report.

Exit the maintenance screen for the form.

Start the report from your user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

G##-BILKENN1 drilldown report→ Execute

(or double-click report G##-BILKENN1).

On the selection screen enter:

Currency type: 10

You can keep the current Fiscal Year which is offered. to you.

Execute

Drill the report down by profit center values.

Task 9:

1. Create a form G##-BILKENN2 (## = your group number) for the Reporting
for Table FAGLFLEXT form type.

User menu→ Drilldown reporting: Maintain forms→ Create form

Use form G##-BILKENN1 as a template. Enter G## Change: F.Assets as
the description.

The form should be structured as follows:
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Fiscal year
2009

Fiscal year
2008

Fiscal year
2007

Fiscal year
2006

Assets
Fixed assets xx,xxx.xx xx,xxx.xx xx,xxx.xx xx,xxx.xx
Financial
statements
total

xx,xxx.xx xx,xxx.xx xx,xxx.xx

% financial
statement total

<Empty row>

<Empty row>

xx.xx xx.xx xx.xx

Change to
fixed assets

xx.xx xx.xx xx.xx

Example: The current fiscal year in the above report is 2009.

Note:

New column:

Add the fourth column for the fiscal year - 3. The value and the text of the
fiscal year for the fourth column are to be derived in the same way as the
other columns in the previous form.

To copy this formatting and the content of the third column for this fourth
column, place the cursor on the third column and click on the icon Select

Place the cursor on the fourth column and click.

You now have to change your fourth column:

Local variable FY with Operator � and Offset 3

Text for column 2: Short: FY4 $FY

Medium: FsclYear $FY

Long: Fiscal year; $FY

The fourth column (fiscal year - 3) should now only show the fixed assets.

Deactivate the corresponding cells:

(Row: Financial statement total <> Column: FY4 $FY) Define the cell
type as Inactive.

(Row: % financial statement total <> Column: FY4 $FY) Define the cell
type as Inactive.
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New rows:

After the % financial statements total row, you want to display two empty
rows and then a separator.

The next row should show the change to fixed assets, but only for the
current year, the previous year, and the year before last.

Procedure

To enable you to recognize the corresponding columns in your cell names,
you have to change the text type for all columns:

Formatting→ All columns→ Text lengths Text type: Short text

Select the corresponding cells: Fixed assets for FY1 $FY,

Fixed assets for FY2 $FY,

Fixed assets for FY3 $FY,

Fixed assets for FY4 $FY,

Place the cursor three rows beneath the entry % financial statement total,
and add a separator.

Edit→ Rows→ Insert dividing line

Enter - - as the character for the separator. The separator should appear
across the entire form.

In the row after the separator, choose Formula and enter your formula
component, for example Y001.

Enter the texts: Short: Change. Medium Change. Long Change fixed assets.

To determine the Change to fixed assets, you have to enter the formulas:

FY1 $FY FY2 $FY FY3 $FY
Change
to fixed
assets

Assets /FY1
$FY� Assets
/FY2 $FY

Assets /FY2 $FY
� Assets /FY3
$FY

Assets /FY3 $FY�
Assets /FY4 $FY

Text:
Short,
medium,
long

Change FY1 Change FY2 Change FY3

First select the cells in the Fixed assets row. These are the cells:

Fixed assets row, Column FY1 $FY;

Edit→ Element→ Change: Selected
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Fixed assets row, Column FY2 $FY;

Edit→ Element→ Change: Selected

Fixed assets row, Column FY3 $FY;

Edit→ Element→ Change: Selected

Fixed assets row, Column FY4 $FY;

Edit→ Element→ Change: Selected

The change to fixed assets should only be for the current year, the previous
year, and the year before last. Edit the corresponding cells by entering the
formula for calculating fixed assets. Choose Change FYX (X = year 1, 2,
3) as texts.

In the cell for the row Change to fixed assets and the column FY4 $FY,
choose Inactive as the cell type.

To have two-line headings for your columns, you have to change the text
type for all columns:

Formatting→ All columns→ Text lengths

Enter Two-line long text.

Check your form.

Save your form.

Task 10:

1. For this form, create the report G##-BILKENN2 (## = group number)
for the Reporting for table FAGLFLEXT form type with the description
G## Change: fixed assets.

On the maintenance screen for the form, choose:

Environment→ Report→ Create (or Report pushbutton)

Choose Company code and Profit center as drilldown characteristics.
On the Output type tab page, choose Classic drilldown (Basic list: Detail)
and Available on selection screen.

Save your report.

Task 11:

1. Execute your report. Exit the maintenance screen for the report by choosing
Exit. Start the report from your user menu.
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Choose Drilldown: Maintain and execute reports → Execute
reports.Choose report G##-BILKENN2. You want to display the financial
statement values for the currency type 10 and company code 1000 for the
current fiscal year
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Solution 8: Drilldown Reporting in
Financial Accounting
Task 1:

1. Create a form G##-BALPL-01 (## = your group number) for the Reporting
for Table FAGLFLEXT form type. Enter G## Act/act year as the
description. Choose One axis with key figure as the structure

User menu → AC280 Drilldown Activities→Drilldown Reporting:
Maintain Forms→ Create Form

In the general selections, add the Record type 0 for actual and Ledger 0L.

Edit→ General data selection→ General data selection

Choose the column display for your entries in the form.

Goto→ Column display

Define 3 columns:

Column 1:

Key figure BILWERT (Balance Sheet value) with the characteristic Fiscal
year. Enter the current fiscal year for the characteristic Fiscal year (fixed
value). Enter FY XXXX (XXXX = current year) as a short, medium, and
long text.

Column 2:

Key figure BILWERT (Balance Sheet value) with the characteristic Fiscal
year. Enter the previous fiscal year for the characteristic Fiscal year (fixed
value). Enter FY XXXX (XXXX = previous year) as a short, medium, and
long text.

Column 3:

Variance between the current fiscal year and the previous fiscal year
(using formula). Enter Variance as the short, medium, and long text.

Check your form

Save your form.

a) Procedure:

In your user menu, choose transaction FGI4 - Create form in the folder
Drilldown reporting: Maintain forms.

User menu→ Drilldown reporting: Maintain forms→ Create form
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In the general selections, add the Record Type 0 for actual and Ledger
0L.

Edit→ General data selection→ General data selection

Click Record type in the list of available characteristics and then click
the arrow pointing left to add this characteristic to the list of selected
characteristics. Enter 0 as the From value. Click Ledger in the list of
available characteristics and then click the arrow pointing left to add
this characteristic to the list of selected characteristics. Enter 0L as the
From Value. Choose Confirm.

Choose the column display for your entries in the form.

Goto→ Column display

First column:

Double-click the first column (element 1) and choose Key figure
with characteristics (selection button). Choose BILWERT (Balance
Sheet Value) as the key figure. Select Fiscal year in the list of
Available characteristics and choose the arrow pointing left to add this
characteristic to the list of Selected characteristics. Enter the current
fiscal year (XXXX) as the From value.

Enter the texts by choose the Change short/medium/long text symbol.
Enter the text: Short: GJ XXXX (XXXX = current year) and then
choose the Copy short text pushbutton. Accept your entry and then
choose Confirm.

Second column:

Double-click the second column (element 2) and choose Key figure
with characteristics (selection button). Choose BILWERT (Balance
Sheet Value) as the key figure. Click Fiscal year in the list of
available characteristics and then click the arrow pointing left to add
this characteristic to the list of selected characteristics. Enter the
previous fiscal year (YYYY) as the From value.

Enter the texts for the element definition:

Choose the Change short, medium and long texts symbol. Enter the
text: Short: GJ YYYY (YYYY = previous year) and then choose
the Copy short text pushbutton.

Accept your entry and then choose Confirm.

Third column:

Double-click the third column (element 3) and choose Formula
(selection button). Enter your calculation formula.
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Click the ID X001, the minus sign, and then the ID X002. Accept
your entries.

Enter the texts for the element definition:

Enter the text: Short: Variance, and then choose Copy short text.
Accept your entry and then choose Confirm.

Check your form: Choose Check.

Save your form.

Task 2:

1. For this form, create the report G##-BALPL-01 (## = group number) for
the report type Reporting for Table FAGLFLEXT with the description G##
Act/act year.

Environment→ Report→ Create (or Report button)

From the drilldown characteristics, choose financial statement item,
company code, profit center, and account number. You should be able
to enter the hierarchy selection (financial statement version) using the
characteristic Financial statement item when you run the report. Enter the
fixed value 1000 for the characteristic Company code.

Change the order of the user-defined characteristics.

Sort user-defined characteristics button, after

Currency (1), Currency type (2) and Company Code (3) sort by:

FS Item (4),

Account number (5), and

Profit center (6).

On the Output type tab page, choose Classic drilldown (Basic list: D-down)
and Available on selection screen.
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Save your report.

a) Procedure:

Create report G##-BALPL-01 (## = group number) for this form. On
the maintenance screen form→change:

Environment→ Report→ Create (or choose Create report).

Choose the report type Reporting for Table FAGLFLEXT.

For your report G##-BALPL-01, accept the same form name offered
and enter G## Act/act year for the report description.

Choose Create.

In the Available characteristics list , click

Financial statement item, company code, profit center and account
number continue, and click the arrow pointing left to add these
characteristics to the Selected characteristics list.

Double-click the characteristic Financial statement item and choose
Enter at execution (selection button).

Enter the fixed value 1000 for the characteristic Company code.

Change the order of the user-defined characteristics:

Click Sort user-defined characteristics and enter

FS Item (4),

Account number (5), and

Profit center (6).

On the Output type tab page, choose Classic drilldown (Basic list:
drilldown) and select the Available on selection screen checkbox.

Save your report.

Task 3:

1. Execute the report:

Exit the screen for maintaining the report.

Start the report from your user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

Place the cursor on report G##-BALPL-01 and choose

Drilldown report→ Execute (or double-click your report) G##-BALPL-01.
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Currency type: 10

The FIS Annual Rep.Structure: INT:

Output type: Classic drilldown report

Execute

Navigate within the report until you find the account number for office
supplies. Make a note of the financial statement value for the Profit center
Motorcycles (1000) for the current fiscal year.

_______________________________________________________________
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_______________________________________________________________

a) Procedure:

Execute your report:

Exit the maintenance screen for the report by choosing Exit until you
see your user menu on the screen.

Start the report from your user menu.

Drilldown: Maintain and execute reports → Execute reports:
Report:G##-BALPL-01→Drilldown report→ Execute (or double-click
your report G##-BALPL-01)

On the selection screen:

Currency type 10 and The financial statement version INT and

Output type: Classic drilldown report

Execute

When you output the report, the financial statement items for the
financial statement version INT are displayed in the rows.

Navigate within the report until you find the account number for office
supplies:

In the navigation area, click the drilldown characteristic Account
number.

Choose Financial statement item.

This produces the drilldown by account number.

Scroll down the list until you find the office supplies account476000.
Alternatively, you can use the binoculars icon to search for the term Off.

Make a note of the financial statement value for the Profit center
Motorcycles (1000) for the current fiscal year:

Select the Office supplies row by choosing the angle brackets icon
(<>) .

In the navigation area, click the Profit center drilldown characteristic.
The report values for account number 476000 (Office supplies)
are now drilled down by profit center. Make a note of the financial
statement value for the combination Account number 476000 (Office
supplies) for theMotorcycles Profit center (1000) in the current
fiscal year.
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Task 4:

1. Create a form G##-BALPL-02 (## = your group number) for the form
type Reporting for Table FAGLFLEXT. Enter G## Act/act year var. as the
description. Choose One axis with key figure Create as the structure.

User menu→ AC280 Drilldown Activities→Drilldown Reporting: Maintain
Forms→ Create Form

In the general selections, add the Record type 0 for actual and Ledger 0L.

Edit→ General data selection→ General data selection

Choose the column display for your entries in the form.

Goto→ Column display

The form should have the same structure as your first form.

Column 1:

Key figure BILWERT (balance sheet value) with the characteristic Fiscal
year. Enter the global variable 1FY for the characteristic Fiscal year.

Enter the text:

Short: FY &1FY and click Copy short text.

Column 2:

Key figure BILWERT (Balance Sheet value) with the characteristic Fiscal
year. For the fiscal year, enter the global variables 1FY and in the As
operator field, enter a hyphen (�) and Offset 1. Enter the text:

Short: FY &1FY and choose Copy short text.

Column 3:

Variance between the current fiscal year and the previous fiscal year
(using formula). Enter Variance as the short, medium, and long text.

Check your form.

Save your form.

a) Procedure:

Form for financial statement analysis:

In your user menu, click transaction FGI4 - Create form in the
Drilldown reporting: Maintain forms folder.

User menu→ AC280 Drilldown Activities→Drilldown Reporting:
Maintain Forms→ Create Form
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Enter the form type Reporting for Table FAGLFLEXT,

Form: G##-BALPL-02(##=group number) and

Description: G## Act/act year var.

Structure: One axis with key figure

In the general selections, add the Record Type 0 for actual and
Ledger 0L.

Edit→ General data selection→ General data selection

Click Record type in the Available characteristics list and then click
the arrow pointing left to add this characteristic to the Selected
characteristics list.Enter 0 as the From value. Click Ledger in the list
of available characteristics and then click the arrow pointing left to
add this characteristic to the list of selected characteristics. Enter 0L
as the From value.

Choose Confirm.

Confirm

Choose the column display for your entries in the form.

Goto→ Column display

First column:

Place the cursor on the first column (Element 1) and

choose Edit→ Element→ Change (or double-click element 1).

Choose Key figure with characteristics (selection button).

Choose BILWERT (Balance Sheet value) for the key figure and add
the characteristic Fiscal year. Place the cursor on Fiscal year in the
Available characteristics list and choose the arrow pointing left to add
this characteristic to the Selected characteristics list.

Choose the global variable 1FY (fiscal year) as a Variable (select
Variable checkbox) by selecting 1FY and choose Enter.

Enter the texts for the element definition:

Choose Change short, medium and long texts.

Enter the text: Short: FY &1FY and choose Copy short text.

Accept your entry and then choose Confirm.

Second column:

Place the cursor on the second column (Element 2) and

choose Edit→ Element→ Change (or double-click element 2).
Continued on next page
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Choose Key figure with characteristics (selection button).

Choose BILWERT (Balance Sheet value) for the key figure and add
the characteristic Fiscal year. Place the cursor on Fiscal year in the
Available characteristics list and choose the arrow pointing left to add
this characteristic to the Selected characteristics list.

Choose the global variable 1FY (fiscal year) as a Variable (select
Variable checkbox) by selecting 1FY.

Also enter a hyphen (�) in the As operator field and 1 (one) in the
As Offset field. Choose Enter.

Enter the texts for the element definition:

Choose Change short, medium and long texts.

Enter the text: Short: FY &1FY and choose Copy short text.

Accept your entry and then choose Confirm.

Third column:

Place the cursor on the third column (Element 3) and

choose Edit→ Element→ Change (or double-click element 3).

Choose Formula (selection button).

Enter your formula.

Click the ID X001, the minus sign, and then the ID X002. Accept
your entries.

Enter the texts for the element definition:

Enter the short text: Variance, and then choose Copy short text.

Accept your entry and then choose Confirm.

Check your form.

Save your form.

Task 5:

1. Create report G##-BALPL-02:

On the maintenance screen for the form:

Environment→ Report→ Create (or Report button)
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For the form you have just created, create the report G##-BALPL-02 (## =
group number) for the report type Reporting for Table FAGLFLEXT with
the description G## Act year var.

Select the drilldown characteristics FS Item, Company code, Profit Center
and Account number.

Enter INT for the financial statement version.

(Double-click the characteristic Financial statement item).

Change the order of the user-defined characteristics by choosing Sort
user-defined characteristics.

After Currency (1) and Currency type (2)

Sort by FS Item (3)

Company code (4)

Account number (5), and

Profit center (6).

Choose Classic drilldown (Basic list: drilldown) as the output type and
Available on selection screen.

Enter the Current fiscal year as the default value for the fiscal year.
(Variables tab page)
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Save your report.

a) Procedure:

Create report G##-BALPL-02:

On the maintenance screen for the form:

Environment→ Report→ Create (or Report button)

For the form you have just created, create the report G##-BALPL-02
(## = group number) for report type Reporting for Table
FAGLFLEXT with the description G## Act year var.

Select the drilldown characteristics Financial statement item, Company
code, Profit center, and Account number.

Enter INT for the financial statement version:

Double-click the characteristic Financial statement item and choose
financial statement version INT.

Change the order of the user-defined characteristics by choosing
Sort user-defined characteristics.

By FS Item (3)

by Company code (4),

Account number (5), and

Profit Center (6).

On the Variables tab page, define the current fiscal year as the variable
value.

On the Output type tab page, choose Classic drilldown (Basic list:
drilldown) and Available on selection screen.

Save

2. Execute the report:

Exit the maintenance screen for the report.

Start the report from your user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

Double-click report G##-BALPL-02.

Accept the current fiscal year. You want to display the financial statement
values for currency type 10 and company code 1000.

Execute
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When you display the report, navigate using the characteristics Profit center,
Account number, and Financial statement item.

a) Procedure:

Execute the report

Exit the maintenance screen for the report. Start the report from your
user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

Place the cursor on the report G##-BALPL-02 (## = group number)
that you created.

Drilldown report→ Execute

(or double-click the report G##-BALPL-02). On the selection screen:

Current fiscal year

Company code: 1000

Currency type 10

Execute.

When you output the report, the financial statement items for the
financial statement version INT are displayed in the rows. The columns
contain the current fiscal year, the previous year, and the variance.

When you display the report, navigate using the characteristics Profit
Center, Account number and Financial statement item.

3. Execute this report again. On the selection screen, enter the previous year as
the fiscal year.

a) On the selection screen, enter the PREVIOUS fiscal year.

Execute.

When you display the report, the financial statement items for the
financial statement version INT are displayed in the rows. The columns
contain the previous year, the year before last, and the variance.

Task 6:
Key figures report

1. Create form:

Once you have completed the form, it should look as follows:
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Fiscal year 2009 Fiscal year 2008 Fiscal year 1999
Assets
Fixed assets xx,xxx.xx xx,xxx.xx xx,xxx.xx
Financial
statements total

xx,xxx.xx xx,xxx.xx xx,xxx.xx

% financial
statement total

xx.xx xx.xx xx.xx

Example: The current fiscal year in the above report is 2009.

Note:

You want to determine the values for the characteristic Fiscal year and the
texts in which the fiscal years are displayed using local variables.

In the form, define the characteristic variable FY and the text variable FY.

User menu→ Drilldown Reporting: Maintain Forms→ Create form

Create a form G##-BILKENN1 (## = your group number) for the Reporting
for Table FAGLFLEXT form type.

Enter G## Asset proportion as the description.

Choose the structure Two axes (matrix).

Edit→ General data selection→ General data selection

The general selections should contain the characteristic Financial statement
version with the value INT, the characteristic Record Type 0 (actual) and
Ledger 0L.

Columns

You want to determine the values for the fiscal year and the texts in which
fiscal years are displayed, using local variables. In the form, define the
characteristic variable FY and the text variable FY.

Create the first column (column 1):

Element type: Key figures with characteristics

Key figure: BILWERT (Balance sheet value)

Characteristic: Fiscal year

Local variable FY

(this ensures that you can subsequently enter the fiscal year on the selection
screen)

Continued on next page
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Text for column 1: Short, FY1 $FY; Medium, FiscYr $FY; Long, Fiscal
year ; $FY

Enter

Confirm

The width of this column should be 19.

Place the cursor on the column and choose:

Formatting→ Column→ Column width

Enter

To copy the formatting, and the content of the first column to the second
column, place the cursor on the first column and click on the icon select.

Place the cursor on the second column and click . Copy the formatting,
and the content of the first column to the third column the same way.

You now have to change the second column:

Edit→ Element→ Change

Double-click the variable FY

Local variable FY with Operator � and Offset 1

Change short, medium, and long texts button

Text for column 2: Short, FY2 $FY; Medium, FiscYr $FY; Long, Fiscal
year ; $FY

You now have to change your third column:

Edit→ Element→ Change

Double-click the variable FY

Local variable FY with Operator � and Offset 2

Choose Change short, medium, and long texts

Text for column 3: Short, FY3 $FY; Medium, FiscYr $FY; Long, Fiscal
year ; $FY

You can now change the Text type for all columns:

Formatting→ All columns→ Text lengths

Select Two-line long text.

The values in all columns should have 2 decimal places.

Place the cursor on each column and choose:

Formatting→ Number format (or the Number format button )

Continued on next page

172 © 2009 SAP AG. All rights reserved. 2009



AC280 Lesson: Form and Report Definition

Choose the format 0.00 for decimal places.

You now have to define the variables you used; FY as a characteristic
variable and FY as a text variable:

Extras→ Variables→ Variable definition

Enter Fiscal year as the description for your variable for the characteristic
value (this is the text that subsequently appears on the selection screen).

Enter Fiscal year text as a description for your text variable

Double-click text variable FY and enter the following:

Replace selected field: Automatically

Selected characteristic: RYEAR

Replace selected field: From field

Replace selected characteristic value/text with: Characteristic value

Selected field: Offset 1 Length 4

This ensures that the fiscal year (e.g., 2001) is actually displayed as 2001
in the column heading of your list.

To increase the key column width, place the cursor on the key column.

Formatting→ Column→ Column width

Enter 30 as the column width.

Rows

1. Configure long text for all rows:

Formatting→ All rows→ Text lengths

Choose One-line long text as the text type.

2. Enter the text Assets in the first row.

Edit→ Rows→ Insert row;then Edit→ Rows→ Insert text: Assets

3. Separator

Edit→ Rows→ Insert dividing line

Enter the character - - as an underscore for the separator.

In the following dialog box containing the query: Should the underscore
appear only in the value columns?, choose No

4. Financial statement items 1010000, 1020000, and 1030000, which are
to be inserted individually as rows. The total for all three will then be created
in a formula and then the three individual rows hidden.

Continued on next page
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Place the cursor on the row beneath the separator.

Edit→ Element→ Insert element (or double-click this row)

Element type: Characteristic overview (selection button)

FS Item as a characteristic in the Selected characteristics list

Enter the FS Items 1010000, 1020000, and 1030000 each individually
one after the other as rows and keep the texts for them as offered. To be
able to enter these Items you have to, each time, choose the Hierarchy icon
below �Change hierarchy node entry� and then enter the FS Item number
or use the matchcode button to navigate down and choose the Item number
that way. Finally, choose Confirm to bring the Item with its description
into the formula row.

After these three rows, insert a Formula row with the addition of these
three rows.

Texts for the Formula row:

Short: Assets; Medium: Fixed assets; Long: Fixed assets.

You should then HIDE the 3 rows containing the FS Items 1010000, 1020000
and 1030000. To do this place the cursor on each of these rows and then
choose Edit→ Rows→ Hide.

5. Financial statement item 1000000 ASSETS for the Financial statement
total row:

Edit→ Element→ Insert element (or double-click this row)

Element type: Characteristic overview (selection button)

Financial statement item as a characteristic in the Selected characteristics
list. Choose the Hierarchy icon below "Change hierarchy node entry"
and then enter the

FS item 1000000

Texts for the element definition:

Short: FSTotal; Medium: FS Total; Long: Financial Statement total

6. Separator

Edit→ Rows→ Insert dividing line

Enter the character - - as an underscore for the separator.

In the following dialog box containing the query: Should the underscore
appear only in the value columns?, choose No

Formula for the % financial statement total row (Y001 %A Y002):

Edit→ Element→ Insert element (or double-click this row)
Continued on next page
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Element type: Formula (selection button)

Formula: Y001 %A Y002

Texts: short: % Portion; Medium % financial statement total; Long: %
portion financial statement.

This row should be displayed in a different color to the other rows.

Formatting→ Color setting: Color for totals

Check your form.

Save your form.

a) Procedure:

Create form:

Once you have completed the form, it should look as follows:

Fiscal year
2009

Fiscal year
2008

Fiscal year
1999

Assets
Fixed assets xx,xxx.xx xx,xxx.xx xx,xxx.xx
Financial
statements
total

xx,xxx.xx xx,xxx.xx xx,xxx.xx

% financial
statement total

xx.xx xx.xx xx.xx

Example: The current fiscal year in the above report is 2001.

User menu→ AC280 Drilldown Activities→Drilldown Reporting:
Maintain Forms→ Create Form

Create a form G##-BILKENN1 (## = your group number) for the
Reporting for table FAGLFLEXT form type.

Enter G## Asset proportion as the description.

Choose the structure Two axes (matrix).

Choose Create

Edit→ General data selection→ General data selection

The general selections should contain the characteristic Financial
statement version with the value INT, the characteristic Record type 0
(actual) and Ledger 0L.

Continued on next page
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Click Financial statement version, Record type 0 (actual)
and Ledger 0L. Then click the arrow pointing left to add these
characteristics to the Selected characteristics list. For the financial
statement version, enter INT as the From value, 0 for the Record
type and 0L for the Ledger.

Choose Confirm.

You want to determine the values for the characteristic Fiscal year and
the texts in which the fiscal years are displayed using local variables.

In the form, define the characteristic variable FY and the text
variable FY.

Choose Financial statement value as the key figure.

The values in all columns should have 2 decimal places.

Columns

Column 1:

Create the first column (column 1):

Place the cursor on Column 1,

Edit→ Element→ Change

Element type: Key figures with characteristics

Enter

Key figure: BILWERT (Balance sheet value)

Characteristic: Choose Fiscal year from the list of available
characteristics (you may need to scroll in the list).

Arrow: Selected to left

Select from

Local variable: FY

Enter

Change short, medium, and long texts button

Text:

for column 1: Short: FY1 $FY Medium: FsclYear $FY Long:
Fiscal year; $FY

Enter

Confirm

The width of this column should be 19:

Continued on next page
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Place the cursor on the column and choose:

Formatting→ Column→ Column width

To copy the formatting, and the content of the first column to the
second column, place the cursor on the first column and click .
Place the cursor on the second column and click .

Copy the formatting, and the content of the first column to the third
column the same way.

You now have to change the second column:

Double-click the second column.

Edit→ Element→ Change

Place the cursor on the From value FY.

Local variable FY with Operator hyphen (�) and Offset 1

Enter

Change short, medium, and long texts button

Text for column 2: Short FY2 $FYMedium FiscYr $FY Long Fiscal
year ; $FY

Enter

Confirm

You now have to change your third column:

Double-click the third column.

Edit→ Element→ Change

Place the cursor on the From value FY.

Local variable FY with Operator � and Offset 2

Enter

Change short, medium, and long texts button

Text for column 3: Short FY3 $FYMedium FiscYr $FY Long Fiscal
year ; $FY

Enter

Confirm

Change Text type (text lengths) for all columns:

Formatting→ All columns→ Text lengths

Enter Two-line long text.
Continued on next page
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The values in all columns should have 2 decimal places.

Place the cursor on each column and choose:

Formatting→ Number format (or the Number format button )

Choose the format 0.00 for decimal places.

You now have to define FY as a characteristic variable and as a text
variable:

Extras→ Variables→ Variable definition

Description of your variable for the characteristic value: Fiscal year

Enter Fiscal year text as a description for your text variable

Double-click your text variable FY and enter the following:

Replace selected field: Automatically

Selected characteristic: FYEAR

Replace selected field with: From field

Replace selected characteristic value/text with: Characteristic value

Selected field: Offset 1, length 4

Enter

Enter

Increase the key column width:

Place the cursor on the key column: Formatting→ Column→
Column width; 30 as column width

Rows

1. Configure long text for all rows:

Formatting→ All rows→ Text lengths: One-line long text

Choose One-line long text as the text type.

2. Enter the text Assets as the first row.

Place the cursor on the first row

Edit→ Rows→ Insert row; then Edit→ Rows→ Insert text

Edit→ Element→ Change text: Assets

Copy short text button

Enter

3. Separator

Continued on next page
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Place the cursor on the row beneath the empty row with the
text Assets.

Edit→ Rows→ Insert dividing line

Enter the character - - as an underscore for the separator.

Enter

In the following dialog box with the query: Should the separator
appear only in the value columns? Choose No.

Enter

4. Financial statement items 1010000, 1020000, and 1030000,
which are to be inserted individually as rows. The total for
all three will then be created in a formula and then the three
individual rows hidden. :

Place the cursor on the row beneath the separator.

Edit→ Element→ Insert element (or double-click this row).

Element type: Characteristic overview (selection button).

FS Item as a characteristic in the Selected characteristics list.

Enter the FS Items 1010000, 1020000 and 1030000 each
individually one after the other as rows and keep the texts for
them as offered. To be able to enter these Items you have to, each
time, choose the Hierarchy icon below Change hierarchy node
entry' and then enter the FS Item number or use the matchcode
button to navigate down and choose the Item number that way.

Finally, choose Confirm to bring the Item with its description
into the formula row.

After these three rows, insert a Formula row with the addition of
these three rows.

Texts for the Formula row:

Short: Assets;Medium: Fixed assets; Long: Fixed assets.

You should then HIDE the 3 rows containing the FS Items
1010000, 1020000 and 1030000.

To do this place the cursor on each of these rows and then choose
Edit→ Rows→ Hide.

Enter

Confirm

Continued on next page
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5. Financial statement item 1000000 ASSETS for the row Financial
statement total: Place the cursor on the row beneath Fixed assets.

Edit→ Element→ Insert element (or double-click this row)

Element type: Characteristic overview (selection button).

Click FS item in the Available characteristics list and then click
the arrow pointing left to add this characteristic to the Selected
characteristics list.

Choose the Hierarchy icon below Change hierarchy node entry
and then enter the value 1000000.

Enter the texts for the element definition:

Change short, medium, and long texts button Enter the text:

Short: FSTotal; Medium: FS Total; Long: Financial
Statement total

Enter

Confirm

6. Separator:

Place the cursor on the row beneath the row containing the
text Financial statement total.

Edit→ Rows→ Insert dividing line

Enter the character - - as an underscore for the separator.

Enter

In the following dialog box containing the query: Should the
underscore appear only in the value columns?, choose No

Enter

7. Formula for the% financial statement total row (Y001 %A Y002):

Place the cursor on the row beneath the separator.

Edit→ Element→ Insert element (or double-click this row)

Element type: Formula (selection button)

Formula: Y001 %A Y002

Enter

Texts: short: % portion; Medium% financial statement total;
Long: % portion financial statement.

Enter

Continued on next page
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This row should be displayed in a different color to the other rows.

Place the cursor on the row.

Formatting→ Color setting: Color for totals

Check your form.

Save your form.

Task 7:

1. Create report for key figures:

For this form, create the report G##-BILKENN1 (## = group number) for
report type Reporting for Table FAGLFLEXT with the description G## Asset
proportion.

Environment→ Report→ Create (or Report button)

Choose Company code and Profit center as drilldown characteristics.

On the Output type tab page, choose Classic drilldown reporting (Basic list:
Detail) and Available on selection screen.

Save your report.

a) Procedure:

Report G##-BILKENN1 for key figures:

For this form, create the report G##-BILKENN1 (## = group number)
for Reporting for Table FAGLFLEXT with the description G##
Asset proportion.

Environment→ Report→ Create (or Report pushbutton)

Report type Reporting for Table FAGLFLEXT with the description
G## Asset proportion

Create button

Choose Company code and Profit center as drilldown characteristics.
On the Output type tab page, choose Classic drilldown reporting (Basic
list: Detail) and Available on selection screen.

Save your report.

Task 8:

1. Execute the report:

Continued on next page
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Exit the maintenance screen for the report.

Exit the maintenance screen for the form.

Start the report from your user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

G##-BILKENN1 drilldown report→ Execute

(or double-click report G##-BILKENN1).

On the selection screen enter:

Currency type: 10

You can keep the current Fiscal Year which is offered. to you.

Execute

Drill the report down by profit center values.

a) Refer to the task description.

Task 9:

1. Create a form G##-BILKENN2 (## = your group number) for the Reporting
for Table FAGLFLEXT form type.

User menu→ Drilldown reporting: Maintain forms→ Create form

Use form G##-BILKENN1 as a template. Enter G## Change: F.Assets as
the description.

The form should be structured as follows:

Fiscal year
2009

Fiscal year
2008

Fiscal year
2007

Fiscal year
2006

Assets
Fixed assets xx,xxx.xx xx,xxx.xx xx,xxx.xx xx,xxx.xx

Continued on next page
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Fiscal year
2009

Fiscal year
2008

Fiscal year
2007

Fiscal year
2006

Assets
Financial
statements
total

xx,xxx.xx xx,xxx.xx xx,xxx.xx

% financial
statement total

<Empty row>

<Empty row>

xx.xx xx.xx xx.xx

Change to
fixed assets

xx.xx xx.xx xx.xx

Example: The current fiscal year in the above report is 2009.

Note:

New column:

Add the fourth column for the fiscal year - 3. The value and the text of the
fiscal year for the fourth column are to be derived in the same way as the
other columns in the previous form.

To copy this formatting and the content of the third column for this fourth
column, place the cursor on the third column and click on the icon Select

Place the cursor on the fourth column and click.

You now have to change your fourth column:

Local variable FY with Operator � and Offset 3

Text for column 2: Short: FY4 $FY

Medium: FsclYear $FY

Long: Fiscal year; $FY

The fourth column (fiscal year - 3) should now only show the fixed assets.

Deactivate the corresponding cells:

(Row: Financial statement total <> Column: FY4 $FY) Define the cell
type as Inactive.

(Row: % financial statement total <> Column: FY4 $FY) Define the cell
type as Inactive.

New rows:

Continued on next page
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After the % financial statements total row, you want to display two empty
rows and then a separator.

The next row should show the change to fixed assets, but only for the
current year, the previous year, and the year before last.

Procedure

To enable you to recognize the corresponding columns in your cell names,
you have to change the text type for all columns:

Formatting→ All columns→ Text lengths Text type: Short text

Select the corresponding cells: Fixed assets for FY1 $FY,

Fixed assets for FY2 $FY,

Fixed assets for FY3 $FY,

Fixed assets for FY4 $FY,

Place the cursor three rows beneath the entry % financial statement total,
and add a separator.

Edit→ Rows→ Insert dividing line

Enter - - as the character for the separator. The separator should appear
across the entire form.

In the row after the separator, choose Formula and enter your formula
component, for example Y001.

Enter the texts: Short: Change. Medium Change. Long Change fixed assets.

To determine the Change to fixed assets, you have to enter the formulas:

FY1 $FY FY2 $FY FY3 $FY
Change
to fixed
assets

Assets /FY1
$FY� Assets
/FY2 $FY

Assets /FY2 $FY
� Assets /FY3
$FY

Assets /FY3 $FY�
Assets /FY4 $FY

Text:
Short,
medium,
long

Change FY1 Change FY2 Change FY3

First select the cells in the Fixed assets row. These are the cells:

Fixed assets row, Column FY1 $FY;

Edit→ Element→ Change: Selected

Fixed assets row, Column FY2 $FY;

Continued on next page
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Edit→ Element→ Change: Selected

Fixed assets row, Column FY3 $FY;

Edit→ Element→ Change: Selected

Fixed assets row, Column FY4 $FY;

Edit→ Element→ Change: Selected

The change to fixed assets should only be for the current year, the previous
year, and the year before last. Edit the corresponding cells by entering the
formula for calculating fixed assets. Choose Change FYX (X = year 1, 2,
3) as texts.

In the cell for the row Change to fixed assets and the column FY4 $FY,
choose Inactive as the cell type.

To have two-line headings for your columns, you have to change the text
type for all columns:

Formatting→ All columns→ Text lengths

Enter Two-line long text.

Check your form.

Save your form.

a) Procedure:

Create a form G##-BILKENN2 (## = your group number) for the
form type Reporting for Table FAGLFLEXT, with the description
G## Change AV:

User menu→ AC280 Drilldown Activities→Drilldown Reporting:
Maintain Forms→ Create Form

Use form G##-BILKENN1 as a template.

Copy from form: G##-BILKENN1. Create pushbutton.

The form should be structured as follows:

Fiscal year
2009

Fiscal year
2008

Fiscal
year 2007

Fiscal
year 2006

Assets
Fixed assets xx,xxx.xx xx,xxx.xx xx,xxx.xx xx,xxx.xx

Continued on next page
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Fiscal year
2009

Fiscal year
2008

Fiscal
year 2007

Fiscal
year 2006

Assets
Financial
statements
total

xx,xxx.xx xx,xxx.xx xx,xxx.xx

% financial
statement
total<Empty
row>

<Empty row>

xx.xx xx.xx xx.xx

Change to
fixed assets

xx.xx xx.xx xx.xx

Example: The current fiscal year in the above report is 2009.

Procedure: Column

To copy this formatting and the content of the first column to the fourth
column, place the cursor on the fourth column and choose .

Double-click the fourth column.

Edit→ Element→ Change

Place the cursor on the From value FY.

Local variable FY with Operator - and Offset 3

Enter

Change short, medium, and long texts button

Text for column 2: Short FY4 $FY Medium FsclYear $FY Long
Fiscal year; $FY

Enter

Confirm

The fourth column should now only show the fixed assets value.

Double-click the corresponding cells:

Cell in the row: Financial statements total; in the last column (FY4
$FY).

Define the cell type as Inactive.
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Cell in the row: % financial statement total, in the last column (FY4
$FY).

Define the cell type as Inactive.

Procedure: Rows

After the % financial statements total row, you want to display two
empty rows and then a separator.

The next row should show the change to fixed assets, but only for the
current year, the previous year, and the year before last.

To enable you to recognize the corresponding columns in your cell
names, you should change the text type for all columns:

Formatting→ All columns→ Text lengths

Enter the text type Short text.

Place the cursor three rows beneath the entry % financial statement
total, and add a separator.

Edit→ Rows→ Insert dividing line

Separator characters: � �.

Should the underscore appear only in the value columns? NO

Place the cursor on the row beneath the separator.

Edit→ Element→ Insert element (or double-click this row)

Element type: Formula; formula component (for example, Y001 ).

Texts: Short: Change. Medium: FA change; Long: Change to
fixed assets

To determine the change to fixed assets, you have to enter the formula:

FY1 $FY FY2 $FY FY3 $FY
Change
to fixed
assets

Assets /FY1
$FY� Assets
/FY2 $FY

Assets /FY2
$FY � Assets
/FY3 $FY

Assets /FY3 $FY�
Assets /FY4 $FY

Text:
Short,
medium,
long

Change FYX Change FYX Change FYX

First, select the cells in the Fixed assets row. These are the cells:

Fixed assets row, Column FY1 SFY;
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Edit→ Element→ Change: Selected

Fixed assets row, Column FY2 $FY;

Edit→ Element→ Change: Selected

Fixed assets row, Column FY3 $FY;

Edit→ Element→ Change: Selected

Fixed assets row, Column FY4 $FY;

Edit→ Element→ Change: Selected

The change to fixed assets should only be for the current year, the
previous year, and the year before last.

Edit the corresponding cells by entering the formula for calculating
fixed assets.

Place cursor on cell: Change to fixed assets row, Column FY1 $FY;

Edit→ Element→ Change: Select Formula

Formula components (meaning): Assets /FY1 $FY � Assets /FY2
$FY

Text: Short: Change FY1, Copy short text button

Enter

Place cursor on cell: Change to fixed assets row, Column FY2 $FY;

Edit→ Element→ Change: Select Formula

Formula components (meaning): Assets /FY2 $FY � Assets /FY3
$FY

Text: Short: Change FY2, Copy short text button

Enter

Place cursor on cell: Change to fixed assets row, Column FY3 $FY;

Choose Edit→ Element→ Change: Formula

Formula components (meaning): Assets /FY3 $FY � Assets /FY4
$FY

Text: Short: Change FY3, Copy short text pushbutton

Enter

Place cursor on cell: Change to fixed assets row, Column FY4 $FY;

Edit→ Element→ Change: Inactive

Enter
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To have two-line headings for your columns, you have to change the
text type for all columns:

Formatting→ All columns→ Text lengths

Enter Two-line long text.

Check your form.

Save your form.

Task 10:

1. For this form, create the report G##-BILKENN2 (## = group number)
for the Reporting for table FAGLFLEXT form type with the description
G## Change: fixed assets.

On the maintenance screen for the form, choose:

Environment→ Report→ Create (or Report pushbutton)

Choose Company code and Profit center as drilldown characteristics.
On the Output type tab page, choose Classic drilldown (Basic list: Detail)
and Available on selection screen.

Save your report.

a) Report G##-BILKENN2 for key figures:

For this form, create the report G##-BILKENN2 (## = group
number) for report type Reporting for Table FAGLFLEXT with the
description G## Change: fixed assets.

Environment→ Report→ Create (or Report pushbutton)

Report type Reporting for Table FAGLFLEXT with the description
G## Change: fixed assets

Create button

Choose Company code and Profit center as drilldown characteristics.

On the Output type tab page, choose Classic drilldown reporting (Basic
list: Detail) and Available on selection screen.

Save your report.

Task 11:

1. Execute your report. Exit the maintenance screen for the report by choosing
Exit. Start the report from your user menu.
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Choose Drilldown: Maintain and execute reports → Execute
reports.Choose report G##-BILKENN2. You want to display the financial
statement values for the currency type 10 and company code 1000 for the
current fiscal year

a) Execute the report:

Exit the maintenance screen for the report.

Exit the maintenance screen for the form. Start the report from your
user menu.

Choose Drilldown: Maintain and execute reports→ Execute reports.

G##-BILKENN2

Enter the Currency type 10 and Company code 1000 and Current
fiscal year on the selection screen.

And select Classic drilldown report in the report type

Execute
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Lesson Summary

You should now be able to:
� Define forms
� Define and execute reports
� Define forms and reports more flexibly using characteristic and text variables
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Lesson: Displaying Reports

Lesson Overview
In this lesson, you will learn about output types and the functions provided in
drilldown reports.

Lesson Objectives
After completing this lesson, you will be able to:

� Use different types of report outputs
� Create graphics
� Export data to Microsoft Excel
� Have the system perform currency translation

Business Example
Employees in Financial Accounting want to use various types of report output.
They also want to learn about additional functions within drilldown reporting.

Figure 88: Different Output Types for Reports

The output type that you choose in the report definition is only a default setting.
When you run the report, the output type that you define is already selected.
However, you can choose an alternative output type, graphic report output,
when you run the report.
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You use the graphic report output if you want to display the report data attractively
on the screen, or if you need several views of the report data simultaneously (for
example, drilldown list and detail list). For the graphic report output, you can
define the required output areas and determine which HTML template is to be
used for the report header (information area). For example, you can include your
company logo in the report. The header and footer will also appear if you have
defined them and prepared the HTML template accordingly.

Classic drilldown report: For classic drilldown reports, you can define which
list type (drilldown/detail) is to be used as the basic list and whether headers and
footers are to be printed. For special purposes, you can define that the object lists
are output using the SAP List Viewer. This gives you the option of creating reports
that have several characteristic values in the leading column. You can also use the
additional options provided by the SAP List Viewer, such as flexible filter and
sort options, definition of display variants, and so on. Report output to XXL. The
system continues processing the report data using a spreadsheet.

Figure 89: Function Levels for Different Users

Drilldown reporting functions are composed of three groups:

Level 1 contains the basic drilldown reporting functions. You can navigate within
the characteristic hierarchy of a predefined report using these functions. You
can use the functions of the detail list to carry out a specific analysis of larger
volumes of data. Certain functions are not available at this function level (for
example, functions for maintaining reports, for changing settings in the report list,
or for connections to additional products such as the Microsoft Excel list viewer).
This level is intended for users who occasionally want to use certain form reports
in drilldown reporting for further analyses, without requiring all the navigation
functions.
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Level 2 covers the complete functions of drilldown reporting (all navigation
functions), and provides a connection to the Excel list viewer, PC download,
graphic functions, functions for changing the display, and all functions within
hierarchies. You can display exceptions. Certain functions are not available at this
function level (for example, functions for maintaining reports and functions for
setting up a customized print layout). This level is intended for users who require
all the analysis functions in drilldown reporting and the connections stated above.
All functions also covers print preparation, saving reports, defining exceptions,
and report maintenance direct from drilldown reporting, thus all the functions
provided by drilldown reporting. This level is designed for users who maintain
reports or set up print preparation in addition to the functions for level 2. You can
change the level by choosing Extras→ Additional functions.

Figure 90: Frozen Data

You can freeze data for each report and variable combination. This enables you to
fulfil business requests for defined statuses of a report.

You can create frozen data for a report online or in the background.

When using this method, you do not have to wait for the transaction data records
to be read and you automatically receive the last data saved.

The database server is not greatly affected. SAP therefore recommends that you
work with frozen data for complex reports involving large volumes of data.
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Figure 91: Background Processing

You can save report data at specified times in the background (transaction
FS(K/D)IB). By saving report data, you do not have to select more data from the
database when you run a report. The data is already available in a format that
reduces the report runtime dramatically.

Using selection variants, you can save the variable entries and additional settings
as variants for a report.

You can choose the following list types: drilldown list, detail list, and SAP List
Viewer.
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Exercise 9: Drilldown Reporting in
Financial Accounting

Exercise Objectives
After completing this exercise, you will be able to:
� Define and execute different types of forms and reports in FI-GL
� Explain and use navigation options when you are displaying a report
� Define forms and reports more flexibly using characteristic and text variables
� Try various layout settings for the report output
� Explain the different types of cells and use cells in formulas
� Use different output types for reports and test the functions during output

Business Example
Employees in Financial Accounting want to learn about the evaluation options
provided by drilldown reporting, and use the various navigation options.

Task 1:
For the existing form 0SAPFS10-01, create the report G##-BALANC1 (## =
group number) with the description GR##-balance display for the report type
Reporting for Table FAGLFLEXT.

1. Drilldown Reporting: Maintain and execute reports→ Create report

Choose the following drilldown characteristics in addition to the fixed
characteristics Currency (1) and currency type (2):

Financial statement item (3)

Account number (4), and

Profit Center (5).

The numbers in parentheses ( ) correspond with the sort order.

In the hierarchy selection for the financial statement item, you determine
that you have to enter the financial statement version when you execute
the report.

As the output type, choose Classic drilldown (basic list: detail) and
Available on selection screen..

Save your report.

Continued on next page
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Task 2:
Execute the report.

1. Exit the maintenance screen for the report by choosing Exit.

Execute your report.

Start the report from your user menu.

Drilldown Reporting: Maintain and execute reports→Execute reports

Drilldown report→ Execute (or double-click report G##-BALANC1.)

Choose the current fiscal year.

You want to output the financial statement values for company code 1000.

Currency type 10

Choose financial statement version INT.

Period is 1.

Ledger is 0L with Current fiscal year

Task 3:
In the navigation area, change your fixed characteristics to currency type and
currency EUR.

1. In the output, drill down your report according to the characteristic values
for account number and Profit center to see the period balance for the
current fiscal year for Consumptn, raw mat.1 (account 400000) and the
Profit center 1010 (High speed pumps).

Reset the selection of the characteristicsAccount number and Profit center.

Execute the following functions:

a) Number format for amount columns, scaling 100000

Settings→ Number format: Amount columns(or: pushbutton Number
Format)

b) Hierarchy display (+ Expand/Collapse) for the financial statement item
in the navigation area on the left, choose Financial statement item.

Navigate→ FS item

Navigate→ Hierarchy→ Expand All.

Navigate→ Hierarchy→ Collapse, and then once again choose:

Navigate→ Hierarchy→ Collapse.

c) Currency translation:

Continued on next page
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Settings→ Currency: USD with mean rate (as of start of period)

d) Characteristic Display:

Settings→ Characteristic Display: Name and key

Task 4:
Execute your report , G##-BALPL-02 (## = group number).

1. Drilldown Reporting: Maintain and execute reports→Execute reports

Drilldown report→ Execute (or double-click report G##-BALPL-02).

Current fiscal year

Company code: 1000

Report→ Save data

Run the report again with the same selection data.

Task 5:
Execute your report in the background.

1. Drilldown Reporting: Maintain and execute reports→Background
processing

Define Reporting for Table FAGLFLEXT as the report type.

Report G##-BALPL-02

Execute

Enter the Currency type 10.

Enter Company Code 1000 and the previous fiscal year.

Choose 1 (reselect) as the Read mode, and

Rebuild frozen report data as presummarized data.

Execute the program in the background.

Program→ Execute in background

Choose the output device LP01 (do not print immediately) and then choose
Immediate as the start.

Choose Save.

Check whether your background job is complete.

Continued on next page
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Now perform your report online again, entering the same selection data
as you entered for background processing (fiscal year: previous year and
company code 1000).

Which report data does the system propose?
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Solution 9: Drilldown Reporting in
Financial Accounting
Task 1:
For the existing form 0SAPFS10-01, create the report G##-BALANC1 (## =
group number) with the description GR##-balance display for the report type
Reporting for Table FAGLFLEXT.

1. Drilldown Reporting: Maintain and execute reports→ Create report

Choose the following drilldown characteristics in addition to the fixed
characteristics Currency (1) and currency type (2):

Financial statement item (3)

Account number (4), and

Profit Center (5).

The numbers in parentheses ( ) correspond with the sort order.

In the hierarchy selection for the financial statement item, you determine
that you have to enter the financial statement version when you execute
the report.

As the output type, choose Classic drilldown (basic list: detail) and
Available on selection screen..

Save your report.

a) As drilldown characteristics, choose the following:

In addition to the fixed characteristics:

� (1) Currency and
� (2) Currency type,

choose the user-defined characteristics:

� (3) FS item,
� (4) Account number, and
� (5) Profit center.

On the Output type tab page, choose the output type Classic drilldown
(basic list: Detail) and Available on selection screen.

Save your report.

Continued on next page
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Task 2:
Execute the report.

1. Exit the maintenance screen for the report by choosing Exit.

Execute your report.

Start the report from your user menu.

Drilldown Reporting: Maintain and execute reports→Execute reports

Drilldown report→ Execute (or double-click report G##-BALANC1.)

Choose the current fiscal year.

You want to output the financial statement values for company code 1000.

Currency type 10

Choose financial statement version INT.

Period is 1.

Ledger is 0L with Current fiscal year

a) Company code 1000 and Financial statement version INT

Execute

Task 3:
In the navigation area, change your fixed characteristics to currency type and
currency EUR.

1. In the output, drill down your report according to the characteristic values
for account number and Profit center to see the period balance for the
current fiscal year for Consumptn, raw mat.1 (account 400000) and the
Profit center 1010 (High speed pumps).

Reset the selection of the characteristicsAccount number and Profit center.

Execute the following functions:

a) Number format for amount columns, scaling 100000

Settings→ Number format: Amount columns(or: pushbutton Number
Format)

b) Hierarchy display (+ Expand/Collapse) for the financial statement item
in the navigation area on the left, choose Financial statement item.

Navigate→ FS item

Navigate→ Hierarchy→ Expand All.

Navigate→ Hierarchy→ Collapse, and then once again choose:

Continued on next page
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Navigate→ Hierarchy→ Collapse.

c) Currency translation:

Settings→ Currency: USD with mean rate (as of start of period)

d) Characteristic Display:

Settings→ Characteristic Display: Name and key

a) Procedure:

In the right-hand Navigation area: currency type: arrow downwards
or using the magnifying glass, choose 10 (company code currency)

In the navigation area on the left:

Choose Account number

In the navigation area on the right:

Choose the magnifying glass next to the account number.

In the value list, search for 400000 using the binoculars (choose
Execute to select the value)

In the navigation area on the left: Choose Profit center

In the navigation area on the right:

Click the magnifying glass next to Profit center

Profit center 1010 (High speed pumps)

Reverse:

In the navigation area on the right:

Choose the totals icon in front of Profit center, and

on the totals icon in front of Account number

Execute the following functions:

a) Number format for amount columns, scaling 100000

Settings→ Number format: Amount columns(or: pushbutton Number
Format)

b) Hierarchy Display:

Navigate→ FS item

Navigate→ Hierarchy→ Expand all

Navigate→ Hierarchy→ Collapse and again

Navigate→ Hierarchy→ Collapse

Continued on next page
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c) Currency translation

Settings→ Currency:

By currency: USD

Translation type: Mean rate (as of start of period).

d) Characteristic Display: All characteristics with name and key.

Settings→ Characteristic Display

Task 4:
Execute your report , G##-BALPL-02 (## = group number).

1. Drilldown Reporting: Maintain and execute reports→Execute reports

Drilldown report→ Execute (or double-click report G##-BALPL-02).

Current fiscal year

Company code: 1000

Report→ Save data

Run the report again with the same selection data.

a) Choose the current fiscal year.

You want to display the financial statement values for company code
1000. When the data is displayed, choose Save.

Report→ Save data

If you run the report again with the same selection data, you have the
option of reselecting the data or choosing the report data for the last
extract saved. Execute the report with your saved data.

Task 5:
Execute your report in the background.

1. Drilldown Reporting: Maintain and execute reports→Background
processing

Define Reporting for Table FAGLFLEXT as the report type.

Report G##-BALPL-02

Execute

Enter the Currency type 10.

Enter Company Code 1000 and the previous fiscal year.
Continued on next page
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Choose 1 (reselect) as the Read mode, and

Rebuild frozen report data as presummarized data.

Execute the program in the background.

Program→ Execute in background

Choose the output device LP01 (do not print immediately) and then choose
Immediate as the start.

Choose Save.

Check whether your background job is complete.

Now perform your report online again, entering the same selection data
as you entered for background processing (fiscal year: previous year and
company code 1000).

Which report data does the system propose?

a) PREVIOUS fiscal year

Company code 1000

Read mode: 1 (reselect)

Presummarized data: Choose Rebuild frozen report data.

Program→ Execute in background

Output device: LP01

Continue

Values for Start Time: Immediately

Save

The following message appears:

�Job scheduling performed for program. You can check whether your
background job is complete by choosing:�

System→ Own jobs

Report G##-BALPL-02

Drilldown report→ Execute

Enter the same selection data as for background processing (Fiscal
year: PREVIOUS YEAR and company code 1000).

The system provides the report data that was saved by background
processing.
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Lesson Summary

You should now be able to:
� Use different types of report outputs
� Create graphics
� Export data to Microsoft Excel
� Have the system perform currency translation
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Lesson: Report/Report Interface and Report Assignment

Lesson Overview
In this lesson, you will learn about report/report interfaces and report assignments,
which are provided within drilldown reports.

Lesson Objectives
After completing this lesson, you will be able to:

� Set up a report/report interface
� Use report assignments

Business Example
Employees in Financial Accounting want to use various drilldown reports. Report
assignments to drilldown reports are considered of interest.

Figure 92: Report/Report Interface

To enable you to report on a number of characteristics or changing combinations
of characteristics, you would have to define a very comprehensive report that
might not actually be executable online due to the large volume of data.

Using the report/report interface, you can link several individual reports, each
with a limited number of characteristics, to allow you to perform flexible data
evaluations online.
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Recipient objects are other drilldown reports, report portfolios, queries, ABAP
reports, Report Writer reports, and transactions.

Using the report/report interface you can, for example:

� Link reports that contain different characteristics in an application. This
enables you to report on a larger number of characteristics than with
individual reports.

� Link reports created in the different application classes.

Figure 93: Report Assignment

1.

You assign the recipient reports in the report definition by choosing Options.
Choose Report assignment and define the report type (report portfolio, query,
drilldown report, ABAP report, Report Writer, or transaction).
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Exercise 10: Drilldown Reporting in
Financial Accounting

Exercise Objectives
After completing this exercise, you will be able to:
� Define and execute different types of forms and reports in FI-GL
� Explain and use navigation options when you are displaying a report
� Define forms and reports more flexibly using characteristic and text variables
� Try various layout settings for the report output
� Explain the different types of cells and use cells in formulas
� Use different output types for reports and test the functions during output

Business Example
Employees in Financial Accounting want to learn about the evaluation options
provided by drilldown reporting and use the various navigation options.

Task 1:
Change report G##-BALPL-02 (## = group number) such that you forward the
data from this report to a recipient report.

1. Line item report FAGL_ACCOUNT_ITEMS_GL

Choose

the Options tab page.

Choose Extras, then Report assignment.

Choose Insert row.

Choose the Other report type pushbutton: Report type RT,

Choose FAGL_ACCOUNT_ITEMS_GL (no variant); description of recipient
report: Line item G/L accounts

Save the report assignment.

Save the report.

Continued on next page
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Task 2:
Execute report G##-BALPL-02 (## = group number). Choose currency type 10,
company code 1000 and Current fiscal year.

1. In the output choose the Account number to breakdown on and go down until
you find the account 113100 Dte Bank domestic.

Place the cursor on the amount for the current fiscal year.

Choose Call up report .

Call up the report for G/L account line items and go to the document display.
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Solution 10: Drilldown Reporting in
Financial Accounting
Task 1:
Change report G##-BALPL-02 (## = group number) such that you forward the
data from this report to a recipient report.

1. Line item report FAGL_ACCOUNT_ITEMS_GL

Choose

the Options tab page.

Choose Extras, then Report assignment.

Choose Insert row.

Choose the Other report type pushbutton: Report type RT,

Choose FAGL_ACCOUNT_ITEMS_GL (no variant); description of recipient
report: Line item G/L accounts

Save the report assignment.

Save the report.

a) Change report G##-BALPL-02.

Choose User menu→ Change report.

Place the cursor on G##-BALPL-02.

Choose Drilldown report→ Change.

FAGL_ACCOUNT_ITEMS_GL (no variant).

Choose the Options tab page

Choose Extras, then Report assignment.

Choose Insert row.

Choose the Other report type pushbutton: Report type RT,

Enter FAGL_ACCOUNT_ITEMS_GL (no variant); description of
recipient report: Line

item G/L accounts

Continued on next page
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Task 2:
Execute report G##-BALPL-02 (## = group number). Choose currency type 10,
company code 1000 and Current fiscal year.

1. In the output choose the Account number to breakdown on and go down until
you find the account 113100 Dte Bank domestic.

Place the cursor on the amount for the current fiscal year.

Choose Call up report .

Call up the report for G/L account line items and go to the document display.

a) Click on the navigation element Account number, then on FS Item to
allow for a breakdown by account number. Then scroll down until you
find the account 113100. Click on the balance for the current year
and then press the Call up Report icon. This will bring you to the
G/L Account Line Items Display.
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Lesson Summary

You should now be able to:
� Set up a report/report interface
� Use report assignments
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Unit Summary
You should now be able to:
� Describe your knowledge of the architecture of drilldown reporting
� Explain the terms characteristics and key figures and the different types

of each.
� Explain the difference between single-axis and dual-axis forms and use these

forms appropriately
� Use various navigation options in drilldown reports
� Define forms
� Define and execute reports
� Define forms and reports more flexibly using characteristic and text variables
� Use different types of report outputs
� Create graphics
� Export data to Microsoft Excel
� Have the system perform currency translation
� Set up a report/report interface
� Use report assignments
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Unit 5
Insight into BW for Financial

Accounting Queries

Unit Overview
Employees in Accounts Receivable Accounting now want to find out about the
evaluation options that can be used in BW for data from Financials.

Unit Objectives
After completing this unit, you will be able to:

� Explain the basics of SAP BW architecture
� Gain an overview of the InfoProviders in Financials
� Explain the basics of the InfoCube 0FIAR_C02: FIAR Transaction Data
� Create and change queries
� Explain and use the navigation options provided for query display
� Save query output in a workbook
� Define and use characteristic value and text variables
� Define conditions and exceptions and use them when you display a query
� Tailor certain properties of queries to your requirements
� Add queries to existing workbooks

Unit Contents
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Exercise 11: InfoArea for Financials ... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .219
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Lesson: Exceptions, Conditions, and Other Query Properties... . . . . . . . . .262

Exercise 13: Insight into SAP BW: Queries... . . . . . . . . . . . . . . . . . . . . . . . . . .269
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Lesson: SAP BW Architecture and InfoArea for
Financials

Lesson Overview
In this lesson, you will learn about the basic structure of the SAP Business
Information Warehouse (SAP BW) and standard queries in Financials.

Lesson Objectives
After completing this lesson, you will be able to:

� Explain the basics of SAP BW architecture
� Gain an overview of the InfoProviders in Financials

Business Example
Employees in Financial Accounting want to use the evaluation options delivered
in SAP BW. They are primarily interested in finding out the basics of the SAP
BW architecture.

Figure 94: SAP BW Architecture

The SAP Business Information Warehouse (SAP BW) uses a multilevel
architecture to enable maximum flexibility.
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SAP BW can extract and deploy data from a variety of sources. This includes
R/3 and R/2 systems, external systems, flat files, commercial data providers,
and other SAP BW systems.

The SAP BW server delivers all of the tools required for modeling, extracting,
implementing, summarizing, saving, and calling up the data. Since the description
of the data is stored in a shared metadata repository, irrespective of the source, data
can be combined from a large number of sources and used in extended analyses.
The functions delivered in the Administrator Workbench allow administrators
to control, monitor, and maintain all processes for data procurement.

SAP BW users can access data using the SAP Business Explorer, a standard Web
browser, or third-party presentation tools that are certified for use with a general
BAPI interface.

Figure 95: DataSource and InfoSource

An InfoSource is a quantity of information that logically belongs together,
summarized into a single unit.

The InfoSource is located in the BW system and contains the communication
structure.

A communication structure delivers the data that is to be sent to the InfoCube.

It contains the InfoObjects, which represent data that logically belongs together
for the InfoSource.

The DataSource in the OLTP system contains the extraction source structure
and the transfer structure.

The extraction programs use these structures to access and extract data from the
source system.
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The DataSource is replicated in the SAP BW System. This is where a duplicate
of the transfer structure is generated

The transfer structure in the BW system is linked with the InfoSource using
transfer rules.

These rules allow incoming data to be debugged and modified.

InfoSources can comprise transaction data and master data (attributes, texts,
and hierarchies).

Figure 96: InfoArea Financial Accounting

The SAP BW databasis comprises data areas (InfoProviders) that are distinct
from the business perspective.

You analyze the SAP BW dataset by defining queries for InfoProviders in the
BEx Query Designer.

By selecting and combining InfoObjects (characteristics and key figures) or
re-usable structure in a query, you determine the ways in which the data for the
selected InfoProvider can be analyzed.

In the InfoArea Financial Accounting, there are standard InfoProviders (such
as InfoCubes and ODS objects) and queries for the application areas Asset
Accounting, Accounts Receivable Accounting, General Ledger Accounting,
Accounts Payable Accounting, and Lease Accounting.
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Exercise 11: InfoArea for Financials

Exercise Objectives
After completing this exercise, you will be able to:
� Find standard queries in the area Financials
� Execute two standard queries in General Ledger Accounting and Accounts

Payable Accounting

Business Example
Employees working in Financial Accounting want to gain an overview of the
standard queries in SAP BW.

Task:

1. You would like to see a structured list of the cumulated balances with a
comparison of the current fiscal year against the previous year for the area
General Ledger Accounting. Call up the BEx Analyzer and execute the
query G/L: Balances structured - accumulated, comp. with prev.year.

Company code: 1000

Financial statement version: INT

Current fiscal year: 2003

Posting period: Current period

Deactivate the hierarchy so that you get just the account numbers shown
(key) sequentially in the list.

The accounts should then be shown only as key.

2. You would like to obtain a list of account balances and a sales list for your
vendors in the area Accounts Payable Accounting. Call up the BEx Analyzer
and execute the query

Vendors: Overview

Company code: 1000

Period/Fiscal year: 001.2003 through 016.2003

The vendors should be displayed as just key:

Then, only the cumulated balance should be displayed:

Continued on next page
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Now restore the original status of the query:
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Solution 11: InfoArea for Financials
Task:

1. You would like to see a structured list of the cumulated balances with a
comparison of the current fiscal year against the previous year for the area
General Ledger Accounting. Call up the BEx Analyzer and execute the
query G/L: Balances structured - accumulated, comp. with prev.year.

Company code: 1000

Financial statement version: INT

Current fiscal year: 2003

Posting period: Current period

Deactivate the hierarchy so that you get just the account numbers shown
(key) sequentially in the list.

Continued on next page
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The accounts should then be shown only as key.

a) Open Queries → InfoAreas → Financial Management &
Controlling→ Financial Accounting→ General Ledger Accounting
→ General Ledger: Transaction Figures→ (Query) G/L: Balances
structured - accumulated, comparison with previous year (sixth query
in the list)

Place the cursor on this query and execute it (choose OK).

b)

Company code: 1000

Financial statement version: INT

Current fiscal year: 2003

Posting period: 12

c) Execute the query.

d) Deactivate the hierarchy so that you get just the account numbers
shown (key) sequentially in the list:

Right-click G/L accounts and choose Hierarchy active to deactivate
the hierarchy.

e) The accounts should then be shown only as key:

Right-click the column G/L Accounts and choose G/L Accounts→
Display as→ G/L Account→ Key

f) Restore the original status of the query

Then right-click in one of the result columns and choose Back to Start.

2. You would like to obtain a list of account balances and a sales list for your
vendors in the area Accounts Payable Accounting. Call up the BEx Analyzer
and execute the query

Vendors: Overview

Company code: 1000

Period/Fiscal year: 001.2003 through 016.2003

The vendors should be displayed as just key:

Then, only the cumulated balance should be displayed:

Continued on next page
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Now restore the original status of the query:

a) Open Queries → InfoAreas → Financial Management &
Controlling→ Financial Accounting→ Accounts Payable Accounting
→ FIAP: Transaction Data→ (Query) Vendors: Overview

Place the cursor on this query and execute it (choose OK).

b) Entries:

Company code: 1000

Period/Fiscal year: 001.2003 through 016.2003

c) Execute the query.

d) The vendors should be displayed as just key:

Select the column Vendor and choose Vendor→ Display as→ Key

e) Only the cumulated balance should be displayed:

Right-click above and choose Structure→ Select Filter Value. Then
hold down the Control key and select Debit, Credit, Balance, and Sales,
and remove them from the selection by choosing Remove

Choose OK

f) Restore the original status of the query

Right-click in one of the result columns and choose Back to Start.
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Lesson Summary

You should now be able to:
� Explain the basics of SAP BW architecture
� Gain an overview of the InfoProviders in Financials
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Lesson: InfoCube for Financials

Lesson Overview
In this lesson, you will learn about the basic structure of an InfoCube, using the
structure of the InfoCube 0FIAR_C02: FIAR Transaction Data as an example.

Lesson Objectives
After completing this lesson, you will be able to:

� Explain the basics of the InfoCube 0FIAR_C02: FIAR Transaction Data

Business Example
Employees in Financial Accounting want to use the SAP BW InfoCube
0FIAR_C02: FIAR Transaction Data. They are primarily interested in finding out
about its architecture.

Figure 97: InfoCube: Example

The central data containers on which SAP BW reports and analyses are based are
called InfoCubes. They contain two types of data: key figures and characteristics.
Each individual InfoCube contains a self-contained dataset, since queries always
refer to an InfoCube.
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An InfoCube consists of multiple InfoObjects and is set up according to a star
schema. It includes a fact table containing the key figures of the InfoCube and
multiple dimension tables in which the characteristics of the InfoCube are stored.
An InfoCube is assigned to an InfoArea and is supplied with data from one or more
InfoSources. A report in the Business Explorer always refers to only one InfoCube.

Fact tables and dimension tables are linked by identifying abstract numbers
(IDs) contained in the key part of the respective database table. Fact tables and
dimension tables are both relational database tables.

The characteristics of a dimension, with their attributes and text descriptions,
refer to the master data.

� Figure 101 shows the structure of the InfoCube 0FIAR_C02: FIAR
Transaction Data

Figure 98: From InfoCube to Worksheet View

You can analyze the dataset of the Business Information Warehouse by defining
queries using the data contained in an InfoCube. An InfoCube could be
described as a multidimensional cube from which sections are removed whenever
characteristics and key figures are chosen in a query definition.

The multidimensionality of query data allows you to generate different views of
an InfoCube's dataset. The OLAP Processor compiles queries from the InfoCube
data and provides methods to allow multidimensional navigation in the dataset.

The Business Explorer requests the data from the InfoCube and provides an
updated view of the dataset. Only the data actually required in the query is
transferred. If a new view of data is required during navigation, the OLAP
Processor provides it from the InfoCube. The data on the application server is
always the data from the current and last drilldown
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Lesson Summary

You should now be able to:
� Explain the basics of the InfoCube 0FIAR_C02: FIAR Transaction Data
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Lesson: Queries

Lesson Overview
Employees in Financial Accounting want to create and change queries. They
want to use navigation options when they are displaying queries and save query
outputs in a workbook. They also want to define and use characteristic values
and text variables.

Lesson Objectives
After completing this lesson, you will be able to:

� Create and change queries
� Explain and use the navigation options provided for query display
� Save query output in a workbook
� Define and use characteristic value and text variables

Business Example
Employees in Financial Accounting want to create and change queries. They
want to use navigation options when they are displaying queries and save query
outputs in a workbook.

They also want to define and use characteristic values and text variables.

Figure 99: Creating a Query
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Procedure when creating a new query:

� From the standard toolbar, choose Open→ Queries.
� The system displays the selection screen containing all the queries that you

have defined (history). You can request a list of the InfoAreas for which you
can define a new query. Choose the InfoCube containing the data on which
the query is to be based by selecting it with the mouse. You can show the
technical names of the InfoCubes by choosing �Technical Name�.

To create a query, choose �New�.

Figure 100: Choosing Characteristics and Key Figures

In a directory tree on the left side of the screen, the system displays the available
objects from the InfoCube you choose. These include the key figures and
characteristics of the dimensions.

The right side of the screen contains empty directories for filter selection, the lines,
the columns, and the free characteristics of the query. The bottom right section
contains a preview of the results area for the query. This area is also empty at first.

You can expand and collapse the directories by clicking the plus or minus symbol.
For example, you can display a list of all the key figures in the InfoCube by
expanding the key figure node in the InfoCube tree.

You can add the InfoCube's characteristics and key figures to the directories for
the query definition (filter, rows, columns, free characteristics) using Drag&Drop.

Once you have finished defining your query, you can save it by choosing �Save
Query�. You execute the query by choosing �Execute Query�.
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Figure 101: Filtering Data when Defining a Query

When you are defining a query, you can drag characteristics to the columns
or rows.

Once you have executed a query, the system does not initially display free
characteristics in the workbook, but you can integrate these using navigation steps.

Characteristics in the filter are not shown in the drilldown, nor are they shown as
free characteristics in the analysis. They are only used to filter data from the cube.

You can restrict (filter) the characteristic attributes for a characteristic in the rows
and in the columns, as well as in the free characteristics and in the filter.

Figure 102: Selection Menu for Restricting Characteristics
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There are two ways of restricting characteristics:

� To go to the selection menu, choose a characteristic from the InfoCube (in
the tree structure on the left side of the screen) and double-click the icon for
the values. On this screen, you can choose individual values or values from a
value area and you can restrict these values using hierarchies and nodes.

� You can also go to the selection menu by right-clicking a characteristic in the
query definition and choosing Restrict.

Within the selection menu, you can choose values from the list by:

� Dragging the selected values from the box on the left to the box on the right
(Drag&Drop)

� Transferring the selected characteristics using the arrow icons

You can make multiple selections. Once you have finished selecting
characteristics, choose OK.

Figure 103: Filtering Data in the Worksheet

Once you have executed a query, you can also filter data in the worksheet using
the characteristic attributes in the filter cells and results area.
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To filter data using characteristic attributes in the filter cells, right-click the
required characteristic.

� To open the selection menu that you can use to filter the required
characteristic, choose �Find filter value�. This menu offers a selection of
individual values or values from a value area and you can restrict these values
using hierarchies and nodes. You restrict your query result to the chosen
values by choosing OK. To remove the filter value for the corresponding
characteristic, choose Remove filter value.

� You can also display only one column in your query result. You do this by
double-clicking the top of the column. The system then hides all the other
columns. The column heading is shown in the filter area in the Key figure
row. You can reverse this restriction by choosing Remove filter value.

Figure 104: Navigating in the Analysis (2)

A query shows different views of the data in the InfoCube on which the query is
based. From the worksheet, you can use navigation functions to generate various
views of the query data (navigational states), which are then shown in the results
area of the query. The switching of views is known as navigation, and in the
Business Explorer the purpose of navigation is to analyze InfoCube data. When
you define a query, you specify what the first view of the data will be after it has
been added to the workbook.

You can drill down the query result vertically or horizontally for a characteristic
in the filter cells. You do this by choosing Drill down vertically or Drill down
horizontally. You can reverse changes you make to the drilldown by choosing
Remove drilldown.
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You can remove the current drilldown for a characteristic by choosing Remove
drilldown or by double-clicking the characteristic.

You can integrate characteristics in the drilldown by choosing Drill down
vertically or Drill down horizontally. These characteristics are always the last
characteristics to be added to the drilldown.

If you choose the Horizontal drilldown navigation function, the system always
displays all the characteristic attributes for each key figure. To display all the key
figures for a characteristic value, choose Change query.

Figure 105: Navigating in the Analysis (2)

To exchange two characteristics, choose Swap ... with..... This function allows
you to exchange characteristics on the row and column axes of the results area
or to exchange a characteristic from the drilldown with a free characteristic, for
example.

To retain a selected characteristic value as a filter value, choose Keep as filter
value. The system then deletes the characteristic from the drilldown and sets the
filter on the relevant characteristic attribute.

To define a characteristic on a value (that is, filter) and drill down according to
another characteristic on the same axis (row or column axis) in one step, choose
Filter and Drilldown According to.
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Figure 106: Changing a Query

If you want to change a query, choose Change Query.

There are two ways of changing a query:

� If you choose the Change Query (Local View) mode, you can only move or
restrict the objects that are already contained in the query definition. In
addition, when you execute the query again, only the worksheet is updated;
the changes are not saved in the query definition.

� On the other hand, if you choose the Change Query (Global Definition)
mode, the system displays the definition screen and you can use all the
functions that were available when you first defined the query. However,
before you execute the changed query, the system prompts you to save the
changes in the query definition. This changes the original definition of the
query.

There are two ways of saving the changed query:

� You can save the changed query under the old name. To do this, choose
Save Query on the toolbar.

� You can save the changed query under a new name. To do this, choose Save
Query As... on the toolbar. Enter a new technical name and a new description.
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Figure 107: Attributes in the Analysis

If attributes exist for a characteristic, you can display these on the worksheet. To
do this, right-click the characteristic concerned in the query definition and choose
Properties. You can then copy the required attributes and define how you want to
display each attribute (as a key or description, or as a key and description).

In the query definition, you can define a key date by which the attributes are to be
determined by choosing Query properties→ Key date. You can choose the key
date from a calendar or define it using a variable that has already been created.

However, you cannot use display attributes for navigation purposes.
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Figure 108: Adding Text Elements

You can display various text elements of a query (for example, author, last changed
by, InfoCube, time of generation, and so forth) in a user-defined cell area. These
text elements are also known as the query's header information.

To integrate a query's text elements in the worksheet, choose Layout→ Display
text elements→ All. The system displays all existing text elements between the
filter cells and the results area. You can now delete, copy, and move specific text
elements using Microsoft Excel functions.

You can also display, as text elements, the characteristics or variables that were
previously restricted in the query definition.
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Figure 109: Creating Queries with Variables

You can use variables to make your queries more flexible.

To do this, the variables for characteristic values, texts, formulas, hierarchy nodes,
and hierarchies must have been created in SAP BW Variable Maintenance.

The system does not edit the variables or fill them with values until the query is
added to a workbook. Depending on the variable type and processing type chosen,
the variables can be entered or modified manually, or they can be processed
automatically, before the query is executed.

Figure 110: Variables for Characteristic Values
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Variables for characteristic values are parameters that are used in the query
definition. They are not edited or filled with values until the query is added to the
workbook. Variables are placeholders for characteristic values, and can be edited
in the following ways: Manual entry/default value, Customer exit, and SAP
exit.

To use variables in the query definition, choose the characteristic of the InfoCube
that you want to fix to a variable. Expand the characteristics directory and drag
the variable for characteristic values to the directory in the query definition using
drag and drop.

Figure 111: Variables for Texts

Use text variables if you do not want to define row or column texts but want to
enter them or determine them from the master data when the query is executed.

You can use all existing processing types for text variables.

Text variables are normally used in combination with variables for characteristic
values. If you are using a characteristic value variable in a row or column of the
query definition, it is advisable to use a text variable. The text variable has to refer
to the characteristic for which you are using the characteristic value variable, and
it has to be edited using the replacement path.

To use text variables in the query definition, enter the text variable directly in the
text fields (for example, for a calculated key figure or structure). The text variable
has to start and end with an ampersand (&) and it must not contain blank spaces
(for example, &ZPERGJT&).
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Figure 112: Variables for Formulas

You normally use variables for formulas if you do not want to define part of a
formula (a number) but want to enter it when the query is executed. For example,
you could use a formula variable for VAT rate so that the current tax rate is entered
whenever you add the query to the workbook.

You can use all editing types for formula variables.

To use formula variables in the query definition,

select the Key figures directory from the InfoCube tree and, in the context menu,
right-click Newly calculated key figure. The Calculated Key Figure screen
appears.

In the operands directory, choose one of the formula variables and add this to the
entry field for the formula by double-clicking or using Drag&Drop. Choose OK.

When you start the evaluation, you can now enter the number you wish in a dialog
box, or accept the default value.
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Exercise 12: Insight into SAP BW: Queries

Exercise Objectives
After completing this exercise, you will be able to:
� Create and modify your own queries in the BEx Analyzer
� Navigate in the analysis result for the query and filter data
� Integrate additional information as text elements into the query result
� Define and use value and text variables

Business Example
You have the task of creating some query definitions yourself. You want to
implement other analysis functions in the query results.

Hint: The ## symbol is a placeholder for your group (01,02,03 ... and
so on).

Task 1:
You want to find out the cumulative balances of your customers. Call the BEx
Analyzer and create a new query for this purpose.

1. Define a new query using the InfoCube FIAR: Transaction data in the �FI
Accounts Receivable� InfoArea. The query should have the following layout:

Customer Cumulative balance
1000 1000,00
1100 2000,00
.... ....

2. Save the query using the technical name GR##QUERY1 and the description
AC280 QUERY 1 GR##.

3. Execute the query.

Continued on next page
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Task 2:
Once you have looked at the result, you want to change the query.

Change the query using the BEx Query Designer.

Hint: You can only make permanent changes to the query by choosing
�Change Query (Global Definition)�. If you change a query in the
�Change Query (Local View)� mode, the system updates the worksheet,
but does not save the changes in the query definition.

1. You want to find out about customers in company code IDES AG (1000)
only, but do not want to display the company code on the worksheet. You
want to include the Customer industry and the Fiscal year/Period as free
characteristics. You only want to find out about the Trade (TRAD), high
tech (HITE), and Engineering industries (MBAU) and the figures for
December 2002. You also want to display the Sales for the period in the
columns.

2. Save your changed query

Execute the query again.

3. Once you have looked at the result of your changed query, you want to see
the result for Trade (TRAD) in the analysis.

Hint: Set the filter for Trade (TRAD) in the worksheet.

4. Now remove the filter for Trade (TRAD).

Task 3:
To interpret the data, you have to perform various navigation steps. Initially, the
customer should be displayed in the rows, and the two key figures Cumulative
balance and Sales for period should be displayed in the columns. After you have
performed the navigation steps, the worksheet should be laid out as follows:

1. Display the overall result without characteristics in the drilldown.

2. The customer industry should appear after the customer in the query.

Hint: Return to the initial display, in which the customer is displayed
in the rows and the two key figures cumulative balance and sales for
period are displayed in the columns. Then make the changes.

Continued on next page
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Customer
industry
Fiscal
year/period
Customer

Key figures

Customer Customer
industry

Cumulative
balance

Sales for period

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

3. Exchange the characteristics customer and customer industry.

Customer
industry

Fiscal year/period
Customer
Key figures
Customer
industry

Customer Cumulative
balance

Sales for period

....... ....... ....... .......

4. Retain the characteristic value Trade (TRAD) (for customer industry) as a
filter value and list all the customers for this industry in the row.

Customer industry Trade (TRAD)
Fiscal year/period
Customer
Key figures
Customer Cumulative balance Sales for period
.......... ............ .........

5. Now display the figures for a specific customer.

Continued on next page
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Customer industry
Fiscal year/period
Customer XYZ
Key figures
Cumulative balance Sales for period
............ ............

6. Within the customer industries, you now have to display the customers
individually. You have to display the Key for the industry and the key for the
customers. Sort the industries in descending order by key. Always suppress
the result rows for the customers. For the industry, you want an overall
result displayed for the cumulative balance and for the period sales.

Customer
industry
Fiscal year/period
Customer
Key figures
Customer
industry

Customer Cumulative
balance

Sales for period

Trade 1001 EUR 1,500.00 1,000.00 EUR
1002 980.00 EUR 910.00 EUR
1033 ...... ......
...... ...... ......

High tech 1460 3,000.00 EUR 2,500.00 EUR
...... ...... ......

Engineering 1000 EUR 5,670.80 3,215.80 EUR
...... ...... ......

Overall result XX,XXX.XX
EUR

XX,XXX.XX
EUR

7. When you created query AC280 QUERY 1 GR##, you filtered
characteristics. When you are performing the analysis, you want to display
the information that you did not filter (for example, author, last changed
by, info provider, technical name, and so forth). Add the text elements to
the worksheet.

Continued on next page
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8. Save the results of query AC280 QUERY 1 GR## as a new workbook in
your favorites list. Call the workbook Query 1 GR## Result.

Task 4:
You want to find out your customer's sales for the period. In the next exercise you
will create and use characteristic variables for the customer characteristic

1. Define a new query using the InfoCube FIAR: Transaction data in the �FI
Accounts Receivable� InfoArea. You want to filter the query using company
code IDES AG (1000). Enter Fiscal year/Period as free characteristics. You
want to display the customer in the rows and the period sales in the columns.

Customer Sales for period
1000 1000,00
1100 2000,00
... ...

2. Save the query using the technical name GR##QUERY2 and the description
AC280 QUERY 2 GR##.

3. Execute the query.

4. The query output for AC280 QUERY 2 GR## lists all customers in the
company code IDES AG. In the next output, you want to be able to structure
the display of the customer area flexibly. You do not decide on From and To
customers until you perform the analysis.

Change query AC280 QUERY 2 GR##. Define a variable for the
characteristic Customer (InfoObject 0CUSTOMER), which you will need to
select customers. This variable is a range that you have to edit manually or
by using default values. You have to define it as mandatory and ready for
input and it should be possible to change it when you navigate in the query.

Use the following naming conventions:

Variable name: DEBVB## Description: From/To Customer GR##

Enter 1000 as the default value and 2000 as the To default value.

5. Save query AC280 QUERY 2 GR##.

6. Execute query AC280 QUERY 2 GR##. Select customers 1000 to 3000.

Continued on next page
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Task 5:
Now you will be working with text variables. You want to display sales for a
specific fiscal year/period and the corresponding heading (for example, 12/2002)
as follows:

Customer Sales 12/2002
1000 1000,00
1100 2000,00
.... ....

1. Remove the characteristic Fiscal Year/Period from the category Free
Characteristics and Key Figures from the columns. Create a new
characteristic value variable for the fiscal year/period.

Variable name: PERYR##; description: Period/Year ##.

Processed by: Manual entry default value.

Other entries: Individual value, Entry obligatory, Ready for input and
Changeable during query navigation. Enter 12/2002 as the default value.

2. Create a new structure for the columns. The structure should contain a new
selection. The first component of the new selection for the column structure
should contain the sales for the period and the second part should contain
your variable for the fiscal year/period Period/Year ##.

Choose Select text variable.

Create a new text variable. Variable name: PYRTXT##, Description:
Per/Year Text ##, Processed by: Replacement path.

Other entries: characteristic Fiscal year/Period (0FISCPER), replace
variable with External attribute of key, From value, Offset start: 0003,
Offset length 0008. Enter Sales &PYRTXT##& as a description for the
new selection.

3. Save query AC280 QUERY 2 GR##.

4. Execute query AC280 QUERY 2 GR##. Select customers 1000 to 3000 and
enter 011/2002 as the period/year ##.
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Solution 12: Insight into SAP BW: Queries
Task 1:
You want to find out the cumulative balances of your customers. Call the BEx
Analyzer and create a new query for this purpose.

1. Define a new query using the InfoCube FIAR: Transaction data in the �FI
Accounts Receivable� InfoArea. The query should have the following layout:

Customer Cumulative balance
1000 1000,00
1100 2000,00
.... ....

a) Open Queries→ InfoAreas→ Financial Management & Controlling
→ Financial Accounting→ Accounts Receivable Accounting→ Cube
FIAR:Transaction Data→ New

Customer Cumulative balance
1000 1000,00
1100 2000,00
.... ....

Dimensions→ Customer→ Copy the customer (characteristic) to the
rows using drag and drop.

Key Figure→ Copy the cumulative balance to the columns using drag
and drop.

2. Save the query using the technical name GR##QUERY1 and the description
AC280 QUERY 1 GR##.

a) Choose Save query as→ Entry:

Field name Values
Description AC280 QUERY 1 GR##
Technical name GR##QUERY1

Save

Continued on next page
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3. Execute the query.

a) Execute query

Task 2:
Once you have looked at the result, you want to change the query.

Change the query using the BEx Query Designer.

Hint: You can only make permanent changes to the query by choosing
�Change Query (Global Definition)�. If you change a query in the
�Change Query (Local View)� mode, the system updates the worksheet,
but does not save the changes in the query definition.

1. You want to find out about customers in company code IDES AG (1000)
only, but do not want to display the company code on the worksheet. You
want to include the Customer industry and the Fiscal year/Period as free
characteristics. You only want to find out about the Trade (TRAD), high

Continued on next page
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tech (HITE), and Engineering industries (MBAU) and the figures for
December 2002. You also want to display the Sales for the period in the
columns.

a) Choose Change query → Change query (global definition).

Dimensions→ Company code→ Copy the company code to the filter
using drag and drop.

Right-click company code→ Restrict→ Select individual values→
Company code→ Select IDES AG→ Select with pushbutton→ OK

Dimensions → Customer → Copy the industry to the free
characteristics using drag and drop.

Right-click Customer industry→ Restrict→ Select individual values
→ Industry Select � (TRAD) Trade�→ Select with pushbutton→
OK Select �(HITE) High tech� and �(MBAU) Manufacturing� using
the same procedure

Copy Dimensions → Time → Fiscal year/Period to the free
characteristics using drag and drop. The Fiscal year/Period
characteristic is moved too. You can remove this characteristic in the
same way using drag and drop to the left.

Right-click Fiscal year/Period and choose Restrict→ (click down
arrow). Display Other Values→

Restriction(s): Enter Fiscal year/Period 012.2002: Add: OK

Double-click December 2002

OK

Key figure→ Copy the sales for the period into the columns using
drag and drop.

2. Save your changed query

Execute the query again.

a) Execute query

3. Once you have looked at the result of your changed query, you want to see
the result for Trade (TRAD) in the analysis.

Hint: Set the filter for Trade (TRAD) in the worksheet.

a) Right-click the customer industry→ Find filter value→ Select
individual values→. Double-click TRAD→ OK.

Continued on next page

2009 © 2009 SAP AG. All rights reserved. 249



Unit 5: Insight into BW for Financial Accounting Queries AC280

4. Now remove the filter for Trade (TRAD).

a) Right-click the Customer industry→ Remove filter value.

Task 3:
To interpret the data, you have to perform various navigation steps. Initially, the
customer should be displayed in the rows, and the two key figures Cumulative
balance and Sales for period should be displayed in the columns. After you have
performed the navigation steps, the worksheet should be laid out as follows:

1. Display the overall result without characteristics in the drilldown.

a)

Customer's industry Fiscal
year/Period

Customer

Key figures

Cumulative balance Sales for period
........ ........

Right-click Customer→ Remove drilldown.

2. The customer industry should appear after the customer in the query.

Hint: Return to the initial display, in which the customer is displayed
in the rows and the two key figures cumulative balance and sales for
period are displayed in the columns. Then make the changes.

Continued on next page
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Customer
industry
Fiscal
year/period
Customer

Key figures

Customer Customer
industry

Cumulative
balance

Sales for period

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .

a) Right-click Operating Concern and choose Return to Start.

Right-click Customer industry→ Drilldown→ Vertically.

3. Exchange the characteristics customer and customer industry.

Customer
industry

Fiscal year/period
Customer
Key figures
Customer
industry

Customer Cumulative
balance

Sales for period

....... ....... ....... .......

a) Right-click the customer column→ Exchange customer with
customer industry

4. Retain the characteristic value Trade (TRAD) (for customer industry) as a
filter value and list all the customers for this industry in the row.

Customer industry Trade (TRAD)
Fiscal year/period
Customer

Continued on next page
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Key figures
Customer Cumulative balance Sales for period
.......... ............ .........

a) Right-click the customer industry→ Find filter value→ Select
individual values→. Double-click TRAD→ OK.

Double-click the Customer Industry column. This displays a list of all
customers with the characteristic value TRAD.

5. Now display the figures for a specific customer.

Customer industry
Fiscal year/period
Customer XYZ
Key figures
Cumulative balance Sales for period
............ ............

a) Right-click Customer industry→ Remove filter value and double-click
the Customer column.

Right-click Customer→ Find filter value→ Select individual values.
Double-click a Customer (for example, Becker Berlin), choose OK.

6. Within the customer industries, you now have to display the customers
individually. You have to display the Key for the industry and the key for the
customers. Sort the industries in descending order by key. Always suppress
the result rows for the customers. For the industry, you want an overall
result displayed for the cumulative balance and for the period sales.

Continued on next page
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Customer
industry
Fiscal year/period
Customer
Key figures
Customer
industry

Customer Cumulative
balance

Sales for period

Trade 1001 EUR 1,500.00 1,000.00 EUR
1002 980.00 EUR 910.00 EUR
1033 ...... ......
...... ...... ......

High tech 1460 3,000.00 EUR 2,500.00 EUR
...... ...... ......

Engineering 1000 EUR 5,670.80 3,215.80 EUR
...... ...... ......

Overall result XX,XXX.XX
EUR

XX,XXX.XX
EUR

a) Remove filter value for customer

Right-click Customer and choose Remove filter value.

� Double-click Customer Industry. This drills down the individual
customer industries in the row.

� Double-click Customer. This drills down the individual
customers in the row, to the right of the customer industries.

� Right-click the Customer industry column and choose
Customer industry→ Display as→ Key

� Right-click the Customer industry column and choose
Customer industry→ Suppress results rows→ Conditional.

� Right-click the Customer industry column. Sort in descending
order by key.

� Select the Customer column with the right-hand mouse and
choose Customer→ Display as→ Key

� Select the Customer column with the right-hand mouse and
choose Customer→ Suppress Results Rows→

Always

Continued on next page
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7. When you created query AC280 QUERY 1 GR##, you filtered
characteristics. When you are performing the analysis, you want to display
the information that you did not filter (for example, author, last changed
by, info provider, technical name, and so forth). Add the text elements to
the worksheet.

a) Layout→ Display text elements→ All.

8. Save the results of query AC280 QUERY 1 GR## as a new workbook in
your favorites list. Call the workbook Query 1 GR## Result.

a) Save query Save as new workbook

In the �Description� field, enter Query1 GR## Result, and choose Save.

Task 4:
You want to find out your customer's sales for the period. In the next exercise you
will create and use characteristic variables for the customer characteristic

1. Define a new query using the InfoCube FIAR: Transaction data in the �FI
Accounts Receivable� InfoArea. You want to filter the query using company
code IDES AG (1000). Enter Fiscal year/Period as free characteristics. You
want to display the customer in the rows and the period sales in the columns.

Customer Sales for period
1000 1000,00
1100 2000,00
... ...

a) Dimensions→ Company code→ Characteristic. Drag the company
code to the filter using drag and drop.

Right-click company code→ Restrict→ Select individual values→
Company code→ Select IDES AG→ Select with pushbutton→ OK

Copy Dimensions → Time → Fiscal year/Period to the free
characteristics using drag and drop. The Fiscal year/Period
characteristic is moved too. You can remove this characteristic in the
same way using drag and drop to the left.

Choose Dimensions→ Customer. Drag the customer characteristic
to the rows using drag and drop.

Key figure: Copy the sales for the period into the columns using drag
and drop.

Continued on next page
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2. Save the query using the technical name GR##QUERY2 and the description
AC280 QUERY 2 GR##.

a) Choose Save query as→ Entry:

Field name Values
Description AC280 QUERY 2 GR##
Technical name GR##QUERY2

OK

3. Execute the query.

a) Execute query

4. The query output for AC280 QUERY 2 GR## lists all customers in the
company code IDES AG. In the next output, you want to be able to structure
the display of the customer area flexibly. You do not decide on From and To
customers until you perform the analysis.

Change query AC280 QUERY 2 GR##. Define a variable for the
characteristic Customer (InfoObject 0CUSTOMER), which you will need to
select customers. This variable is a range that you have to edit manually or
by using default values. You have to define it as mandatory and ready for
input and it should be possible to change it when you navigate in the query.

Use the following naming conventions:

Variable name: DEBVB## Description: From/To Customer GR##

Continued on next page
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Enter 1000 as the default value and 2000 as the To default value.

a) Choose Change query → Change query (global definition).

Expand the node for the dimension Customer. Expand the node
for the characterisitc Customer.

Place the cursor on characteristic value variables for customer.
Right-click

Characteristic value variables for customer→ New variable→
Continue →

Variable name:DEBVB##:

Description: From/To Customer-GR##

Edit manually/Copy default value.

→ Continue

Variable represented: Choose Interval

In the Variable entry is field, choose Obligatory.

Accept Ready for input .

Select Changeable for Query Navigation.

→ Continue.

Enter 1000 as the default value and 2000 as the To default value.

→ Continue→ Exit.

Expand the node for characteristic variables (customer) →
Characteristic value variables . Copy From/to customer GR## to the
rows using drag and drop.

5. Save query AC280 QUERY 2 GR##.

a) Save query AC280 QUERY 2 GR##

6. Execute query AC280 QUERY 2 GR##. Select customers 1000 to 3000.

a) Execute query AC280 QUERY 2 GR## . Select customers 1000 to
3000.

Continued on next page
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Task 5:
Now you will be working with text variables. You want to display sales for a
specific fiscal year/period and the corresponding heading (for example, 12/2002)
as follows:

Customer Sales 12/2002
1000 1000,00
1100 2000,00
.... ....

1. Remove the characteristic Fiscal Year/Period from the category Free
Characteristics and Key Figures from the columns. Create a new
characteristic value variable for the fiscal year/period.

Variable name: PERYR##; description: Period/Year ##.

Processed by: Manual entry default value.

Other entries: Individual value, Entry obligatory, Ready for input and
Changeable during query navigation. Enter 12/2002 as the default value.

a) Choose Change query → Change query (global definition).

Double-click the characteristic variables icon below the Fiscal
year/Period

Continue.

Enter variable name: PERYR## and description: Period/Year ##

Processed by: Edit manually/Copy default value.

Continue.

Variable represented: Enter Individual value

Variable entry is: Enter Obligatory

Accept Ready for input.

Continue.

Enter 12/2002 as the default value.

Continue.

Exit.

Continued on next page
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2. Create a new structure for the columns. The structure should contain a new
selection. The first component of the new selection for the column structure
should contain the sales for the period and the second part should contain
your variable for the fiscal year/period Period/Year ##.

Choose Select text variable.

Create a new text variable. Variable name: PYRTXT##, Description:
Per/Year Text ##, Processed by: Replacement path.

Continued on next page
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Other entries: characteristic Fiscal year/Period (0FISCPER), replace
variable with External attribute of key, From value, Offset start: 0003,
Offset length 0008. Enter Sales &PYRTXT##& as a description for the
new selection.

a) In the Columns area, remove the Key Figures columns by dragging
Key Figures into the left column using drag and drop.

Place the cursor the columns and choose New Structure from the
context menu.

Place the cursor on Structure and choose New Selection from the
context menu.

Move Sales for period to the right using drag and drop.

Dimensions→ Time→ Characteristic Fiscal Year/Period . Copy
Characteristic value variable Period/Year ## to the right below your
key figure using drag and drop. The Fiscal year/Period characteristic is
moved too. Remove the characteristic again by dragging it to the left.

Choose Select text variable .

Create a new text variable: Choose New.

→ Continue

Variable name:PYRTXT##.

Description: Per/Year Text ##

Processed by: Replacement path

→ Continue

Characteristic: Fiscal year/period (0FISCPER)

→ Continue

Replace variable with: External attribute of key

Offset Start: 0003 Offset Length:0008.

Exit.

Enter Sales &PYRTXT##&as a description for the new
selection.Choose OK.

3. Save query AC280 QUERY 2 GR##.

a) Save query AC280 QUERY 2 GR## .

Continued on next page

2009 © 2009 SAP AG. All rights reserved. 259



Unit 5: Insight into BW for Financial Accounting Queries AC280

4. Execute query AC280 QUERY 2 GR##. Select customers 1000 to 3000 and
enter 011/2002 as the period/year ##.

a) Execute query AC280 QUERY 2 GR## .

Select customers 1000 to 3000 and enter 011/2002 as the period/year ##.
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Lesson Summary

You should now be able to:
� Create and change queries
� Explain and use the navigation options provided for query display
� Save query output in a workbook
� Define and use characteristic value and text variables
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Lesson: Exceptions, Conditions, and Other Query
Properties

Lesson Overview
Once they have created queries, employees in Financial Accounting want to work
with exceptions, conditions, and sender/receiver report assignments.

Lesson Objectives
After completing this lesson, you will be able to:

� Define conditions and exceptions and use them when you display a query
� Tailor certain properties of queries to your requirements
� Add queries to existing workbooks

Business Example
Once they have created queries, employees in Financial Accounting want to work
with exceptions and conditions.

Figure 113: Defining Exceptions

You can define a global exception at query level. This then applies to the query
in all workbooks.
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Procedure:

� Using Drag&Drop, drag the required key figures to the directories in the
query definition.

� To display the entry screen on which you define exceptions, choose
Exception→ New exception.

Figure 114: Exception Attributes: Cell Restrictions

Procedure when defining an exception:

� In the Description field, enter a name for the exception.
� Enter the key figures to which you want to apply the exception. There are

two ways of doing this: You can perform the exception for all the key figures
in the query definition, or you can display the exception for a specific key
figure.

� On the Exception Values tab page, specify the threshold values or ranges to
which you want to assign a message priority. Message priorities are used
to preassign the color values that are shown in the query result. As the
difference between the query result and the predefined values increases,
the color displayed changes and can become deeper to reflect a higher
�warning� level. There are nine different shades of green, yellow and red
(traffic light colors).

� To define a new interval, choose New and enter the From and To values in
the corresponding fields. There is a switch to enable you to underlay the
interval with a color. Once you have entered the appropriate warning color,
choose Copy to copy the new exception interval.

� If there are consecutive intervals with overlapping limit values, this value
is displayed only once and is underlaid with the color that represents the
highest warning level, thus displaying the worst case scenario.
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Figure 115: Exception: Result in Worksheet

The query result shows the values defined in the exception underlaid with various
colors. The colors represent the degree of variance.

To change the exception, choose Exceptions and Change exception in the query
definition. The system then provides all the functions used to define exceptions
again.

You can also enter exceptions in the worksheet (right-click in the results area -
exceptions). However, these exceptions can only be used locally in the current
query.

If you have large quantities of data, you can also process exceptions in the
background. To do this, define the relevant settings in the Reporting Agent. The
system then displays and logs the results in the alert monitor.
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Figure 116: Defining a Condition

Procedure when creating a condition: In the Description field, enter a name for
your condition. Make sure that the Active checkbox is selected (this activates the
condition). In the Evaluate conditions below for... to field, enter the characteristics
to which you wish to apply the condition. There are two options:

All characteristics independent in drilldown: The condition is used for all
characteristics in the query. You can navigate freely within the worksheet to
change the characteristics display, and the condition will be taken into account
for all characteristics.

Single characteristics and characteristic combinations: If you select this option,
the system displays all the characteristics for the query in the bottom window. In
this window, you can choose one or more characteristics for which you wish to
display the condition. Selecting characteristics in this way acts as a filter for
the condition. For characteristics that are not selected and thus not restricted, the
system continues to display all the values in the query.

Define the condition in the Present all values that fulfil at least one of the following
conditions field at the bottom of the screen. Define a condition by choosing New
and choosing the key figure and then the operator in the pulldown menus (for
example, Top N, Bottom N, is less than or equal to, is greater than or equal to). In
the Values field, enter the appropriate measure (amount, figures, or percentage).
To copy your condition, choose Copy and confirm your entry by choosing OK.
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Figure 117: Condition: Result in Worksheet

On the worksheet, the system displays only the values that you require.

To change the condition, choose Conditions and Change condition in the query
definition. The system again provides all the functions used to define conditions.

You can also enter conditions in the worksheet (right-click in the results area
- conditions). However, these conditions can only be used locally in the current
query.

Figure 118: Properties of q ueries: Interaction
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In the standard system, interactive functions such as navigate or refresh are
permitted in a workbook. If you want to prevent users from navigating in the
query results or from changing the view of the data, deactivate the function Allow
Interactive Functions.

If input variables are used in a query, you can enter values for variables when
adding the query to the workbook or accept the default values. If you want to
save and reuse any variable values, activate this function. In this way, you do not
need to enter the values for the variables each time you refresh the data. With the
default settings, this function is not activated.

If you want your query to be refreshed when you open the workbook, activate the
corresponding function.

Figure 119: Adding Queries

Queries are always inserted in the workbook at the point where the cursor is
located. Queries from different InfoCubes can be inserted in the same workbook.

If you have inserted several queries in a workbook, switching the drilldown within
a query can lead to a conflict with the operating concern of another query. This
applies to the area beside the query to be changed as well as to the area beneath it.
The system recognizes the conflict and offers you three options:

� You can let the operating concern of the other query be overwritten.
� You can have cells inserted beneath the query or beside it.
� You can have entire lines or columns inserted.
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Exercise 13: Insight into SAP BW: Queries

Exercise Objectives
After completing this exercise, you will be able to:
� Create exceptions and conditions and use them for results
� Tailer queries to your needs
� Add queries to existing workbooks

Business Example
You have the task of creating various query definitions. You want to use additional
analysis functions in the query results.

Hint: The ## symbol is a placeholder for your group (01,02,03 ... and
so on).

Task 1:
You want to display the top 10 customer sales figures for this period. You also
want to highlight sales that fall between 200,000 EUR and 400,000 EUR.

1. Change query AC280 QUERY 2 GR##. Create a new condition with the
description GR##-CONDITION. You want to apply this condition to the
characteristic Customer (0CUSTOM) only. Enter the operators Top N and 10
for the key figure Sales &PYRTXT##&. Accept your entries and choose OK.

2. Create a new exception with the description GR##-EXCEPTION. Enter the
structure Sales &PYRTXT##&. Create the values for the exception: From
value 200,000, To value 400,000, and an alert level (for example, green 2,
good).

Accept your entries. To restrict the cells (area of validity for the
exception), choose All (recommended for relative quantities) and choose
the characteristics Customer and All (all balances). Accept your entries
and choose OK.

3. Save query AC280 QUERY 2 GR##.

4. Execute query AC280 QUERY 2 GR##. Select customers 1000 to 3000 and
enter 012/2002 as the period/year ##.

5. Save the results of query AC280 QUERY 2 GR## as a new workbook in
your favorites list. Call the workbook Query 2 GR## Result.

Continued on next page
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Task 2:
Optional

1. You now want to change some properties of your analysis in your worksheet.
Execute your query AC280 QUERY1 GR## (## = your grpup number). As
the filter value for your customers, enter the value range 1000 through 2000
(Becker Berlin through Carbor GmbH). Deactivate the interactive functions
of your query output.

Once you have viewed your workbook again and have tested the new
settings, activate the interactive functions again and then remove the filter
value for the customers.

2. Add the query you created AC280 QUERY2 GR## (## = your group number)
to the worksheet alongside query AC280 QUERY1 GR## (## = your group
number).

Hint: To insert the second query, select a cell in Excel column F
alongside your query already located in the worksheet (for example,
line 1, column F)

Enter customer 1000 to customer 2000 and period 012 in year 2002. As the
filter value for your customers for AC280 QUERY1 GR##, enter the value
range 1000 through 2000 (Becker Berlin through Carbor GmbH). Remove
exception GR##-EXCEPTION from the second query (AC280 QUERY2
GR##).

Update (refresh) your second query (AC280 QUERY2 GR##). You are
required to enter the value of the variable for period/year. Accept the entries
and execute the query again.

Save the results of the two queries jointly as a new workbook with the
description 2 Queries GR##.

3. Now execute your three workbooks consecutively:

� Result Query 1 GR##

� Result Query 2 GR## and

� 2 Queries GR##
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Solution 13: Insight into SAP BW: Queries
Task 1:
You want to display the top 10 customer sales figures for this period. You also
want to highlight sales that fall between 200,000 EUR and 400,000 EUR.

1. Change query AC280 QUERY 2 GR##. Create a new condition with the
description GR##-CONDITION. You want to apply this condition to the
characteristic Customer (0CUSTOM) only. Enter the operators Top N and 10
for the key figure Sales &PYRTXT##&. Accept your entries and choose OK.

a) Choose Change query → Change query (global definition).

Choose Condition → New condition.

Enter the description G##-CONDITION and select the Active field.

Choose Evaluate conditions below for→ Individual characteristics
and characteristic combinations. Select the field before Customer.

Choose Present all values that fulfil at least one of the following
conditions: New.

→ Enter the following:

Key figures Operator Values
Sales &PYRTXT& Top N 10

Choose Copy.

Choose OK.

2. Create a new exception with the description GR##-EXCEPTION. Enter the
structure Sales &PYRTXT##&. Create the values for the exception: From
value 200,000, To value 400,000, and an alert level (for example, green 2,
good).

Continued on next page
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Accept your entries. To restrict the cells (area of validity for the
exception), choose All (recommended for relative quantities) and choose
the characteristics Customer and All (all balances). Accept your entries
and choose OK.

a) Choose the Exception button and then choose New exception.

Enter the description G##-EXCEPTION and select the Active field.

Choose Evaluation for→ Structure→ Sales &PYRTXT##&.

Choose Values for exception tab page→ New and enter the following
in the columns:

From To Alert level
200000 400000 Good 2

Copy

On the Exception: Area or Validity tab page, choose Area of validity
for all characteristics that are not shown→ All (recommended for
relative quantities).

Choose New.

Characteristic: Customer Operator: All

Choose Copy.

Choose OK.

3. Save query AC280 QUERY 2 GR##.

a) Save query

4. Execute query AC280 QUERY 2 GR##. Select customers 1000 to 3000 and
enter 012/2002 as the period/year ##.

a) Execute query

5. Save the results of query AC280 QUERY 2 GR## as a new workbook in
your favorites list. Call the workbook Query 2 GR## Result.

a) Choose Save→ Save as new workbook in your favorites list.
Description: Query 2 GR## Result.

Continued on next page
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Task 2:
Optional

1. You now want to change some properties of your analysis in your worksheet.
Execute your query AC280 QUERY1 GR## (## = your grpup number). As
the filter value for your customers, enter the value range 1000 through 2000
(Becker Berlin through Carbor GmbH). Deactivate the interactive functions
of your query output.

Once you have viewed your workbook again and have tested the new
settings, activate the interactive functions again and then remove the filter
value for the customers.

a) Execute your query AC280 QUERY1 GR## (## = your grpup number).

b) Open the BEx Analyzer (choose SAP Menu→ Business Explorer→
Analyzer).

Open Business Explorer → Queries

Place your cursor on your query AC280 QUERY1 GR##→ and execute
it (by choosing OK).

c) As the filter value for your customers, enter the value range 1000
through 2000 (Becker Berlin through Carbor GmbH).

Select Customer and choose Find Filter Value from the context menu.

Selection for customer: Value Range

Place your cursor on the first entry (=Becker). Using the right mouse,
choose Technical Names from the context menu.

Double-click 1000 and scroll down through the list until you reach
2000. Double-click 2000. Choose OK.

d) Deactivate the interactive functions of your query output.

With the right mouse, select any cell and choose Operating Concern
→ Properties

Title Element Field Name Value
Interaction Allow Interactive

Functions
Empty

Choose OK.

e) Now test the new setting.

By way of example, you could try to remove the filter value for the
customers. This is no longer possible.

Continued on next page
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Re-activate the interactive functions and then remove the filter value
for the customers.

With the right mouse, select any cell and choose Operating Concern
→ Properties

Title Element Field Name Value
Interaction Allow Interactive

Functions

Choose OK.

Select Customer with the right-hand mouse and choose Remove filter
value from the context menu.

2. Add the query you created AC280 QUERY2 GR## (## = your group number)
to the worksheet alongside query AC280 QUERY1 GR## (## = your group
number).

Hint: To insert the second query, select a cell in Excel column F
alongside your query already located in the worksheet (for example,
line 1, column F)

Enter customer 1000 to customer 2000 and period 012 in year 2002. As the
filter value for your customers for AC280 QUERY1 GR##, enter the value
range 1000 through 2000 (Becker Berlin through Carbor GmbH). Remove
exception GR##-EXCEPTION from the second query (AC280 QUERY2
GR##).

Update (refresh) your second query (AC280 QUERY2 GR##). You are
required to enter the value of the variable for period/year. Accept the entries
and execute the query again.

Continued on next page
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Save the results of the two queries jointly as a new workbook with the
description 2 Queries GR##.

a) Tools → Add Query

Place the cursor on AC280 QUERY2 GR##. Choose OK.

Enter customer 1000 to customer 2000 and period 012 in year 2002.

Execute.

b) As the filter value for your customers for AC280 QUERY1 GR##,
enter the value range 1000 through 2000 (Becker Berlin through
Carbor GmbH).

Select Customer and choose Find Filter Value from the context menu.

Selection for customer: Value Range

Place your cursor on the first entry (=Becker). Using the right mouse,
choose Technical Names from the context menu.

Double-click 1000 and scroll down through the list until you reach
2000. Double-click 2000. Choose OK.

Remove exception GR##-EXCEPTION from the second query (AC280
QUERY2 GR##).

Using the right-hand mouse, select any cell in the operating concern of
query AC280 QUERY2 GR##. Choose Exceptions and then select your
exception GR##-EXCEPTION. This calls up your exception.

Update (refresh) your second query (AC280 QUERY2 GR##). You are
required to enter the value of the variable for period/year. Accept the
entries and execute the query again.

Place your cursor on any cell in the operating concern of query AC280
QUERY2 GR##.

Choose the Refresh Query icon.

Execute

c) Save the results of the two queries jointly as a new workbook with
the name 2 Queries GR##.

Choose the Save icon.

Save as a new workbook. Enter 2 Queries GR## as the description.

Choose OK.

3. Now execute your three workbooks consecutively:

� Result Query 1 GR##

Continued on next page
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� Result Query 2 GR## and

� 2 Queries GR##

a) Choose the Open icon and then select and execute the three
workbooks mentioned above (by choosing the OK pushbutton).
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Lesson Summary

You should now be able to:
� Define conditions and exceptions and use them when you display a query
� Tailor certain properties of queries to your requirements
� Add queries to existing workbooks
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Unit Summary
You should now be able to:
� Explain the basics of SAP BW architecture
� Gain an overview of the InfoProviders in Financials
� Explain the basics of the InfoCube 0FIAR_C02: FIAR Transaction Data
� Create and change queries
� Explain and use the navigation options provided for query display
� Save query output in a workbook
� Define and use characteristic value and text variables
� Define conditions and exceptions and use them when you display a query
� Tailor certain properties of queries to your requirements
� Add queries to existing workbooks
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Unit 6
Appendices

Unit Overview
� Additional Information About Drilldown Reporting
� Menu Paths

Unit Objectives
After completing this unit, you will be able to:

� Describe standard characteristics, key figures, and standard variables, and
list transactions used in drilldown reporting

� Find menu paths in the Implementation Guide (IMG)

Unit Contents
Lesson: Appendix.. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .280
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Lesson: Appendix

Lesson Overview
� Additional Information About Drilldown Reporting
� Menu Paths

Lesson Objectives
After completing this lesson, you will be able to:

� Describe standard characteristics, key figures, and standard variables, and
list transactions used in drilldown reporting

� Find menu paths in the Implementation Guide (IMG)

Business Example
Now that you have looked at drilldown reporting, you want to find out about
standard characteristics and key figures, as well as standard variables and
transactions.

Additional Information About Drilldown Reporting
Drilldown Reporting in FI: Appendix

� Constants
� Cell Calculation with Constants
� Texts
� GL Drilldown Reporting: Customizing
� GL Drilldown Reporting: Standard characteristics and key figures
� GL Drilldown Reporting: Standard variables
� GL Drilldown Reporting: Transactions
� Drilldown Reporting: FI-GL and FI-SL
� GL Drilldown Reporting: Documentation
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Figure 120: Constants

Figure 121: Cell Calculation with Constants
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Additional cell types for cell definition:

� Selection with key figure (value field):
� Choose Selection with key figure (value field) if you want a separate selection

at cell level. You then define the cell by selecting a key figure, characteristics
and their values, and by specifying a special cell text. This cell definition
is visualized by the squared character. Note that this special cell does not
have to contain the value that would result from the intersection of the row
and column selection.

� Define formula priority: This option is offered if the column and the row
contain formulas. Here you define which of the formulas is to be used to
calculate the cell. A result from the column formula means that the formula
defined in the column is used. A result from row formula means that the
formula defined in the row is used. Cells for which you have to define the
formula priority have a red question mark in the form. The selected formula
is visualized using an arrow symbol that points to the dimension that has
priority (If the column formula has priority, the arrow points upwards; if the
row formula has priority, the arrow points left).

Figure 122: GL Drilldown Reporting: Customizing

282 © 2009 SAP AG. All rights reserved. 2009



AC280 Lesson: Appendix

Figure 123: GL Drilldown Reporting: Standard characteristics and key
figures

Figure 124: GL Drilldown Reporting: Standard Variables
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Figure 125: GL Drilldown Reporting: Transactions

Figure 126: Drilldown Reporting: FI-SL

You can use drilldown reporting to evaluate any FI-SL totals tables. You can
create and display the following reports:

� Account balances
� Financial statement reports
� Line item reports called up from the totals report
� Flexible reports using SAP account assignments and your own additional

account assignments
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The evaluation of FI-SL totals tables using drilldown reporting is limited. The
following restrictions apply:

� You can evaluate only one ledger.
� You can only report using the second or third currency (usually the local or

group currency) and one quantity (no additional quantity).
� You can display only one currency in the report.

Before you evaluate your own FI-SL tables using drilldown reporting, you have
to activate the drilldown reporting structure for the relevant FI-SL totals tables.
The drilldown reporting field catalog is only updated for the new fields of the
totals table.

Figure 127: Drilldown Reporting: Documentation

Menu Paths
Unit: Standard reports in FI-GL, FI-AR, and FI-AP

System→ Services→ Reporting SA38
Goto→ Variants
Variant→ Create

→ Display
→ Change
→ Copy

Edit→ Attributes
Environment→ Maintain Selection Variables STVARV

SAP Easy Access menu

Accounting
→ Financial Accounting

→ General ledger
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→ information system
→ General Ledger Reports (New)

→ Financial Statement/Cash Flow
→ General

→ Actual/Actual comparisons
→ Plan/Actual comparison
→ Cash Flow
(...)

→ Account balances
→ General

→ G/L account balances
(...)
→ Structured account balances
(...)

→ Line items
→ General ledger line items

→ General ledger line items , list for printing
(...)

→ Document
→ General

→ Document journal
→ Compact document journal
→ Line item journal
→ Display of changed documents
(�)

→ Master data
→ Chart of accounts
→ G/L account list
→ Account assignment manual
→ Display changes to G\L accounts

→ Accounts Receivable
→ information system
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→ Reports for Accounts Receivable Accounting→
Customers balances

→ Customer balances
→ Customer balances in local currency
→ Customer sales
(...)

→ Vendor items
→ Due date analysis for open items
→ List of vendor open items for printing
→ OI - Vendor due date forecast
→ Vendor payment history with OI sorted list
(...)
→ List of vendor cleared items for printing
→ List of down payments open on key date

→ Master data
→ Vendor list
→ Address list
→ Display changes to vendors
→ Display/confirm critical vendor changes

Unit: Reports in user roles Transaction codes
(or transaction SM30, then Table/View)

Menu→ Create role PFCG

Unit: List Viewer Transaction codes
(or transaction SM30, then Table/View)

SAPEasy Access Menu
Accounting
→ Financial Accounting
→ General ledger
→ Account

Display balances (new) FAGLB03
Display/change line items FAGLL03
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→ Accounts receivable
→ Account

Display balances FD10N
Display/change line items FBL5N

→ Accounts payable
→ Account

Display balances FK10N
Display/change line items FBL1N

Implementation Guide for R/3 Configuration (IMG)

Financial Accounting
→ General Ledger Accounting
→ G/L accounts
→ Line items
→ Display Line Items with ALV

→ Define Special Fields for Finding and Sorting Data
→ Accounts Receivable and Accounts Payable
→ Customer Accounts
→ Line items
→ Display Line Items

→ Define Additional Fields for Line Item Display
→ Local Reporting for Line Items

→ Maintain Selection Variants for the Display of
Customer Line Items

→ Vendor Accounts
→ Line items
→ Display Line Items

→ Define Additional Fields for Line Item Display
→ Local Reporting for Line Items

→ Maintain Selection Variants for the Display of
Vendor Line Items
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Unit: Accounts Receivable/Accounts Payable
Information System

Transaction codes

Implementation Guide for R/3
Configuration (IMG)

(or transaction SM30, then Table/View)

→ Financial Accounting
→ Accounts Receivable and Accounts Payable
→ Information System
→ Accounts receivable
→ Standard Evaluations
Copy Standard Evaluations FY01
Select Standard Evaluations OBDF
Enhance Standard Evaluations CMOD

→ Accounts payable
→ Standard Evaluations
Copy Standard Evaluations FY01
Select Standard Evaluations OBDF
Enhance Standard Evaluations CMOD

Application:
SAP Easy Access menu
→ Accounting
→ Financial Accounting
→ Accounts receivable
→ information system
→ Tools
→ Configure

→ Specify data volume OBAN
→ Select evaluations OBAJ
→ Create Evaluations F0.29

→ Display evaluations F0.30
Application:
SAP Easy Access menu
→ Accounting
→ Financial Accounting
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→ Accounts payable
→ information system
→ Tools
→ Configure

→ Specify data volume OBAO
→ Select evaluations OBAK
→ Create Evaluations F0.45

→ Display evaluations F.46

Unit: Drilldown Reporting in FI Transaction codes
Implementation Guide for R/3 Configuration (IMG)
→ Financial Accounting
→ General Ledger Accounting (new)
→ Information System
→ Drilldown Reports (G/L Accounts)
→ Form
→ Define Form

Specify form Create Form FGI4
Change Form FGI5
Display Form FGI6

Transport Form FGIP
Import Form from Client 000 FGIR
Delete Form FGIZ
→ Define Report

Create report FGI1
Change Report FGI2
Display Report FSI3

Transport Report FGIO
Import Report from Client 000 FGIQ
Delete Report FGIX

(...)
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→ Define Global Variables FGIV
(...)
→ Delete Report Data FGIY

Transaction codes: Short description

FGI0 Execute report

FGI1 Create report

FGI2 Change report

FGI3 Display report

FGI4 Create form

FGI5 Change form

FGI6 Display form

FGIB Background processing

FGIC Maintain currency translation type

FGIG Characteristic groups

FGIK Maintain key figures

FGIM Report monitor

FGIO Transport report

FGIP Transport form

FGIQ Import reports from client 000

FGIR Import reports from client 000

FGIT Translation tool - drilldown reporting

FGIV Maintain global variables

FGIX Reorganize drilldown reports

FGIY Reorganize report data

FGIZ Reorganize forms

Implementation Guide for R/3 Configuration (IMG)
→ Financial Accounting

→ Accounts Receivable and Accounts Payable
→ Information System

→Accounts receivable

2009 © 2009 SAP AG. All rights reserved. 291



Unit 6: Appendices AC280

→ Drilldown Reports (Accounts receivable)
→ Form
→ Define Form

Create Form FDI4
Change Form FDI5
Display Form FDI6

Transport Form FDIP
Import Form from Client 000 FDIR
Delete Form FDIZ
→ Define Report

Create Report FDI1
Change Report FDI2
Display Report FDI3

Transport Report FDIO
Import Report from Client 000 FDIQ
Delete Report FDIX

(...)
→ Maintain Global Variables FDIV
(...)
→ Reorganization of Report Data FDIY

Transaction codes: Short description

FDI0 Execute report

FDI1 Create report

FDI2 Change report

FDI3 Display report

FDI4 Create form

FDI5 Change form

FDI6 Display form

FDIB Background processing

FDIC Maintain currency translation type

FDIK Maintain key figures

FDIM Report monitor
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FDIO Transport report

FDIP Transport form

FDIQ Import reports from client 000

FDIR Import forms from client 000

FDIT Translation tool - drilldown reporting

FDIV Maintain global variables

FDIX Reorganize drilldown reports

FDIY Reorganize report data

FDIZ Reorganize forms

Implementation Guide for R/3 Configuration (IMG)
→ Financial Accounting

→ Accounts payable
→ Drilldown Reports (Accounts payable)

→ Form
→ Define Form

Create Form FKI4
Change Form FKI5
Display Form FKI6

Transport Form FKIP
Import Form from Client 000 FKIR
Delete Form FKIZ
→ Define Report

Create Report FKI1
Change Report FKI2
Display Report FKI3

Transport Report FKIO
Import Report from Client 000 FKIQ
Delete Report FKIX

(...)
→ Define Global Variables FKIV
(...)
→ Delete Report Data FKIY
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Trans. code � Short description

FKI0 Execute report

FKI1 Create report

FKI2 Change report

FKI3 Display report

FKI4 Create form

FKI5 Change form

FKI6 Display form

FKIB Background processing

FKIC Maintain currency translation type

FKIK Maintain key figures

FKIM Report monitor

FKIO Transport report

FKIP Transport form

FKIQ Import reports from client 000

FKIR Import forms from client 000

FKIT Translation tool - drilldown reporting

FKIV Maintain global variables

FKIX Reorganize drilldown reports

FKIY Reorganize report data

FKIZ Reorganize forms
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Lesson Summary

You should now be able to:
� Describe standard characteristics, key figures, and standard variables, and

list transactions used in drilldown reporting
� Find menu paths in the Implementation Guide (IMG)
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Unit Summary
You should now be able to:
� Describe standard characteristics, key figures, and standard variables, and

list transactions used in drilldown reporting
� Find menu paths in the Implementation Guide (IMG)
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Course Summary
You should now be able to:

� Explain why reports are necessary
� Explain the significance of reporting tools
� Differentiate between:
� Standard reports provided by SAP, and
� Reports that you create yourself
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Feedback
SAP AG has made every effort in the preparation of this course to ensure the
accuracy and completeness of the materials. If you have any corrections or
suggestions for improvement, please record them in the appropriate place in the
course evaluation.
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